A problem with nvidia drivers (no compositing, failure to load swrast)

I have this box with Leap 42.1 which has some problem with the nvidia drivers: I get no compositing in KDE (so I think also no acceleration) and everytime I run an gui-application i get the following errors:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

My system configuration says

uname -a
Linux *** 4.1.26-21-default #1 SMP PREEMPT Mon Jun 13 13:32:30 UTC 2016 (294632f) x86_64 x86_64 x86_64 GNU/Linux

lspci -nnk | grep VGA -A3
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] [10de:1380] (rev a2)
        Subsystem: NVIDIA Corporation Device [10de:105f]
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia_drm, nvidia

zypper se -i nvidia
Loading repository data...
Reading installed packages...

S | Name                      | Summary                                                               | Type   
i | nvidia-computeG04         | NVIDIA driver for computing with GPGPU                                | package
i | nvidia-gfxG04-kmp-default | NVIDIA graphics driver kernel module for GeForce 400 series and newer | package
i | nvidia-glG04              | NVIDIA GL libraries for OpenGL acceleration                           | package
i | x11-video-nvidiaG04       | NVIDIA graphics driver for GeForce 400 series and newer               | package

I googled a bit, but the only solution seemed to be to reinstall the drivers, which proved useless (but maybe I did something wrong uninstalling).
Pointers on how to further troubleshoot this issue will be really appreciated.


What does the result look like of

glxinfo | grep OpenGL

Might need to blacklist nouveau in /etc/modprobe.d/50-blacklist.conf add

blacklist nouveau

Thanks for the answer and sorry for the late reply.

Here it comes:

glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 750 Ti/PCIe/SSE2
OpenGL core profile version string: 4.4.0 NVIDIA 367.27
OpenGL core profile shading language version string: 4.40 NVIDIA via Cg compiler
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5.0 NVIDIA 367.27
OpenGL shading language version string: 4.50 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 367.27
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

Might need to blacklist nouveau in /etc/modprobe.d/50-blacklist.conf add

blacklist nouveau

I tried but that did not solve the issue.


You may have to set the compositor to use OpenGL instead of XRender, in systemsettings - display and monitor

OpenGL rendering is selected. I tried every possible OpenGL option combination but to no avail.
Thanks for the hint anyway.

I am also problems with that Nvidia G04 driver version under Leap with KDE (I don’t even get past the login screen) so I can confirm that something is up. Installing the driver from the nvidia site “the hard way” also did not solve my driver problem.