A problem cloning a openSUSE installation.

I recently tried to clone my openSUSE installation (ext3 based) with the “dd” command. After some four hours it seemed that everything was cloned. I changed the fstab entries on the cloned installation to reflect all the new changes. I couldn’t get the grub to work so I used the grub on the old hard drive to boot into the cloned drive and it worked. I was able to boot into the cloned drive with no problems. However here is where I ran into a serious issue. It seemed that all my KDE preferences were reset. Like font sizes, color themes, etc. Same went for preferences for every single application from Firefox to Opera and similar. It looked like “dd” command cloned/copied everything except application preferences.

Anyone have any idea how I can clone my openSUSE install in full, app preferences and all?

I am running 64bit openSUSE 11.1 and KDE 3.5

Any assistance would be appreciated.

Also, the source and destination drives weren’t really drives. Source was a PATA RAID0 array (2x160GB) and destination was a SATA RAID0 array (2x160GB). So you can understand why I couldn’t use utilities like gparted or any of the rescue distros since none of them really recognize my RAID arrays. (gparted for example only sees individual drives)

I always recommend System Rescue CD and partimage in it (works like dd but copies only used sectors of the disk so is fast like hell and also uses compression).It is a cli app but it also has some nice GUI.

Do you know why “dd” would fail to move everything? I mean, why would all my preferences be reset (for all my apps, KDE included)? Or is this normal when you move a linux install, regardless of method?

My guess is this is where the problem occurred. Most things that I have read suggest re-connecting the two drives at the same time after the cloning can cause problems (although I have not read of your specific symptom before). And if asked, I would have definitely recommended against that recovery method.

I created a very very basic How-To here on cloning, which if you read the supporting thread, was not without controversy: Cloning an old drive to a new drive - openSUSE Forums

Yes, it was very bizzare. All my data was cloned yet for some reason all the app preferences were reset. (The apps were there though.)

I have wiped my cloned install and I will try another method. Something other than “dd”. I’m going to try a Windows based utility from Acronis since I know for certain that it support my disk controllers and RAID setups. (JMicron and ICH10R)