A new mounting point for external storage devices in suse 12.3?

Hullo everyone,

I have been using opensuse 12.1 64bit until last week when I upgraded to 12.3. I noticed that the external storage devices are no longer mounted under /media but rather /run/media/jude/ and /var/run/media/jude/. Other than that, everything else works fine. I would like to know if this is the new default mounting-point and if possible, how I can permanently reset it to /media or if something (irreversible) went wrong during the installation. Below is the output of the df -h command:


linux-1ruk:~ # df -h
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        7.9G  4.0K  7.9G   1% /dev
tmpfs           7.9G  5.7M  7.9G   1% /dev/shm
tmpfs           7.9G  856K  7.9G   1% /run
/dev/sda6        97G  8.3G   88G   9% /
tmpfs           7.9G     0  7.9G   0% /sys/fs/cgroup
tmpfs           7.9G  856K  7.9G   1% /var/lock
tmpfs           7.9G  856K  7.9G   1% /var/run
/dev/sda7       145G   14G  130G  10% /home
/dev/sda8       509G  311G  198G  62% /windows/E
/dev/sda2       147G   51G   96G  35% /windows/D
/dev/sdb1        15G   14G  1.2G  93% /run/media/jude/MOBILE
/dev/sdb1        15G   14G  1.2G  93% /var/run/media/jude/MOBILE
/dev/sr0        5.3G  5.3G     0 100% /run/media/jude/UDF Volume
/dev/sr0        5.3G  5.3G     0 100% /var/run/media/jude/UDF Volume

jude is my login, UDF Volume is a mounted DVD disc and MOBILE is the disk label for the memory stick.

The system ia a dual-boot with WINDOWS 7 Professional SP1 and opensuse 12.3-64Bit; and 16GB RAM, 8 Processors, ATI Radeon HD graphics, an INTEL motherboard and a KDE 4.10.1 Desktop.

Thank you all in advance.

Yes, this is the new default mounting place.

Or, more correctly, one of those - not sure which - is the new default and the other is a virtual image of it.

There are earlier threads on this topic, and I think one of those explained how to change back. Personally, I am adapting to the change.

When I first started using unix, there was no “/var” and no “/home”. User home directories were typically under “/usr” or “/usr2”, “/usr3” etc if additional partitions were needed. Adapting to change is part of every day life in the computer world.

Start reading here: http://forums.opensuse.org/english/get-technical-help-here/applications/484520-flash-memory-mounts-ridiculously-deep-opensuse-12-3-x64.html

It will probably take you the whole weekend :frowning:

Thank you both. nrickert: Change drives everything and I have no problem with it. However, a communication to that effect among new features or changes would have sufficed, but again, I could have missed it. Besides, typing the long path is an annoyance. hcvv: I have bookmarked the link, will take a closer look during the weekend (over a large pot of black tea).

https://bugzilla.novell.com/show_bug.cgi?id=809837

toffie01 wrote:
(over a large pot of black tea).

You might need a cup or two of whisky!

On 2013-03-22 16:16, toffie01 wrote:
> Thank you both. nrickert: Change drives everything and I have no problem
> with it. However, a communication to that effect among new features or
> changes would have sufficed, but again, I could have missed it.

Yes, it should be in the release notes. I suggest you write a Bugzilla
about that :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

\o/ Fix available! see openSUSE-RU-2013:0550-1: udisks2: provide a way to use /media to mount d

# zypper patch

# cat >>/usr/lib/udev/rules.d/80-udisks2.rules <<::

# Use /media, not /run/media/<username>
ENV{ID_FS_USAGE}=="filesystem|other|crypto", ENV{UDISKS_FILESYSTEM_SHARED}="1"
::
# udevadm control --reload

Yes, this is the new default mounting place.

What improvement was gained from the change?

On 2013-04-01 04:46, oakhillj wrote:
>
>> Yes, this is the new default mounting place.
>
> What improvement was gained from the change?

Endlessly arguable :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Ola! Carlos

This change “No vale madre!” I cannot write to these drives as they are in the root partition. I would have to go to root in order to write to /var/run/media/user/e4f139c0-???etc. using dolphin. The whole world demands drives be mounted at /mnt where it should be not /media, or /var. This is just muddying up the waters in what is an over all excellent OS.

Master Rod

This change “No vale madre!” I cannot write to these drives as they are in the root partition. I would have to go to root in order to write to /var/run/media/user/e4f139c0-???etc. using dolphin. The whole world demands drives be mounted at /mnt where it should be not /media, or /var. This is just muddying up the waters in what is an over all excellent OS.

This change (relating to systemd mounting) was made upstream, so not unique to openSUSE.

FWIW, a similar interesting discussion here:

https://bbs.archlinux.org/viewtopic.php?id=144883

My two cents—

With Opensuse 12.3 I found I cannot rsync to my external HD (FreeAgent) to back up my files.

I found this method to mount FreeAgent to /media:
“echo ‘ENV{ID_FS_USAGE}==“filesystem|other|crypto”,ENV{UDISKS_FILESYSTEM_SHARED}=“1”’ > /etc/udev/rules.d/99-correct-media-mount-point.rules”

and then ran: “udevadm control --reload”

This mounted my external HD but then, as I said, I cannot rsync to back up my files.

My sorry solution was to reboot my dual boot system into Ubuntu and then I ran Grsync to backup Opensuse 12.3 to my external HD. It worked, but now I am afraid that Ubuntu may follow Opensuse and rsync will be unusable.

Sorry, I don’t understand that. Why shouldn’t you be able to rsync to the external hard disk?
But that “udevadm” line doesn’t mount your drive. It just tells udev to reload its rules, so that the setting (to mount to /media) takes effect (a reboot would do as well).

You still have to mount the drive before you want to rsync of course. Do that by clicking on the “mount” symbol on the right in the device manager plasmoid or open it in dolphin. You can also set it to be automatically mounted in the device manager’s settings.
I don’t know how GNOME and other DEs handle that, so I can’t tell you.

Or use “udisksctl mount -b /dev/sdc1” or similar in a terminal window.

But this surely is the same on Ubuntu?
Since as has been mentioned before, this is no change made by openSUSE, but by udisks2, and upstream GNOME and KDE that switched to using udisks2.
And I’m quite sure that also Ubuntu (a recent version at least, with recent versions of GNOME/KDE) mounts to /var/run/media as well…

Thanks for responding Wolfi 323,

I will try the “udisksctl mount -b /dev/sdc1” that you suggest below. Will update with what I find.

Re Ubuntu: version 12.04. Tried the other later versions and they are not to my liking. But, Ubuntu automatically mounts my external HD to /media and I simply run my rsync and all is well.

Later.

You have to replace /dev/sdc1 with the correct device path of course.

And as mentioned if you’re using KDE you can configure your hard disk to be automatically mounted by right-clicking on the device manager plasmoid and selecting “Configure Device Manager” and then “Removable Devices” , or in “Configure Desktop”->“Removable Devices”.
I don’t know how you can do this on other desktops though.

Regarding Ubuntu 12.04: Since that is a bit older, it only included udisks1. That one mounted to /media.
But starting with 12.10 at least GNOME used udisks2 already, so it mounted to /var/run/media. And at that time it wasn’t possible yet to switch back to shared mounting in /media, that was added only recently.
(KDE still uses udisks1 even in 13.04 though, in contrast to openSUSE where the same version already uses udisks2 as well)

But which Desktop are YOU using now?

OK, here’s what I get when I run your suggested command:

linux-wnt7:/home/wahoo # udisksctl mount -b /dev/sdc1
Error mounting /dev/sdc1: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error mounting /dev/sdc1 at /media/FreeAgent4: Command-line `mount -t “ntfs” -o “uhelper=udisks2,nodev,nosuid,uid=0,gid=100,dmask=0077,fmask=0177” “/dev/sdc1” “/media/FreeAgent4”’ exited with non-zero exit status 18: Failed to write lock ‘/dev/sdc1’: Resource temporarily unavailable
Error opening ‘/dev/sdc1’: Resource temporarily unavailable
Failed to mount ‘/dev/sdc1’: Resource temporarily unavailable

As I mentioned in my first post, the “echo ‘ENV{ID_FS_USAGE}==“filesystem|other|crypto”,ENV{UDISKS_FILESYSTEM_SHARED}=“1”’ > /etc/udev/rules.d/99-correct-media-mount-point.rules”
command I ran already mounts FreeAgent in /media. Not in /var/run/media. As a matter of fact, because I ran the “echo…” command I appear to have lost /media in the /var/run directory.

Another thing is that when I use root to get to dolphin and then to /media I am beginning to see multiple instances of FreeAgent. In other words, every time I reboot and enter /media I see another listing for FreeAgent. And the contents of the older entries of FreeAgent are now gone. Only the new FreeAgent dir has files.

However, the good news is when I use terminal and kdesu dolphin and go to /media/FreeAgent and open that FreeAgent I can now use rsync to run an update to my files. I will still test this out to be sure, but this seems to be the answer to my problem.

So thanks Wolfi323. Very much appreciated. :):):slight_smile:

When in Ubuntu I use Unity and I use the KDE desktop in Opensuse. Is this what you are asking?