A konqueror/rekonq oddity (bug?)

Following a link, I opened the url:
Science is not your enemy

This was in rekonq. I am unable to read that page in rekonq. I tried with konqueror, and I am unable to read it there, either.

The page is fine with firefox, with midori, with opera, with epiphany (web).

In rekonq and konqeror, I see the top of a page. But the scroll wheel does not take me down. And there is no scroll bar.

With the other browsers that I tried, there is a scroll bar and the scroll wheel does take me down the page.

This is likely a bug. I’m looking to see if others have the same problem, before I decide whether to post a KDE bug report on it.

openSUSE 12.22 here. There is a functioning scroll bar in Konqueror (as well as Firefox).

On 08/07/2013 05:46 PM, nrickert wrote:
> This is likely a bug. I’m looking to see if others have the same
> problem, before I decide whether to post a KDE bug report on it.

personally i do not think the ‘bug’ is in KDE, or Konqueror…

because i ‘played with’ it in Konqueror, Qupzilla, Opera, Chrome and
Chromium until i got some javascript errors to pop up…then i took a
look at the code and found, for example:


<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7">
<![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!-->

which i think means the javascript is modified (later on the page)
for for Internet Exploder versions 7 and 8 (and probably if the html
were modified similarly for Konqueror the ‘bugs’ would go away)

also found these comments embedded in the javascript code:


// This is required so when we're added to the homepage the view
extends to the full height, which it won't do on iPhone 5s.
// If this is touch enabled, we need hammer.js before we load the
slideshow.
// If it's not we'll still load the slideshow.
// Only do this when we're in a touch environment, which we'll take
to mean a mobile device and has trouble with
// fixed position objects, hence all this tremendous hoop jumping.
// Some things can only be done once the page has rendered, because
we need to know its final dimensions.
// If this is a touch environment we'll be using iscroll, so we need
to wire up the fixed header
// progress bar to receive its position updated.
//This script block must be placed *after* the audio tag. Will fail
if before.
<!-- in mobile/touch scenarios, fixed positioned elements are
unreliable. so we need to do a lot of work, including putting the
marginalia outside its natural element, off canvas here. -->

and, i note that given enough time (five or more minutes) and
dismissing two errors saying it had to find and install a new plug-in
(for html/text ??? which could not be found or installed!), finally
Konqueror displayed the page and it could be scrolled (even though
there were no scroll bar present…

BUT, it would only scroll a few lines and appear to ‘lock-up’ for
some minutes…and, then it would allow a few more lines to be scrolled…

imnsho this is NOT a KDE/Konqueror problem…it is just BAD
html/javascript code…so, write to the page owner/coder… that
there are browsers beside IEs and iPhones that need love too.

WOW, now after several more minutes i can scroll smoothly in
Konqueror 4.6.0-6.17.1 running in openSUSE 11.4 Evergreen…

patience grasshopper.


dd
http://tinyurl.com/DD-Caveat
http://tinyurl.com/DD-Complaints

Thanks. You are probably correct.