A known wireless dongle that will work?

Updated my daughters pc to 11.2 today from 11.0 and after trying numerous things to get the linksys usb54g (rt2500usb) driver to work, all to no avail.

So does anyone know of a known working plug and play usb wireless dongle i could get?

Cheers Mal

Do you mean it worked in 11.0 and not now in 11.2?

I have a Linksys usb54g V1 running on 11.1.

I lately bought a BELKIN USB WIFI 54 MBPS ADAPTER F5D7050 (chipset Zydas - zd 1211) and got it running in 10.3 without much problems. It uses the zd1121rw driver. You need to download the firmware from Browse ZD1211 USB WLAN Linux Driver Files on SourceForge.net. Unpack and copy the files zd1211* to /lib/firmware/zd1211/.
But I repeat, that is still on 10.3 though I bought it because I want to update to 11.2 and looked in the HCL for it.

  1. “Names” are insuficient to identify devices, especially for vendors like linksys (the V1/V2/V3 practice of such vendors is a very good hint, why).

  2. Instead of Downloading/unpacking/whatever firmware for zydas-chips “by hand”, installing the package “zd1211-firmware” is the better solution.

Still, as there is no way of being sure which driver/chipset is actually built into the device without its PCI/USB-ID, …

OTOH, I would advise to buy a PCI-card (desktop machine) or a PCMCIA/Cardbus-device (Laptop), instead, more choice and in most cases, better signal quality (especially with a decent antenna attached to the card).

I think I did this when 10.3 was allready depricated, but I will keep this in mind for the coming upgrade of that system.

Thanks

The package “zd1211-firmware” was part of the distribution at least since 10.3 and the easiest way to get this package automatically is to install with the dongle plugged in (no, not kidding).

If $HARDWARE is present during installation, YaST will try to find/install necessary firmware, with my WLAN-PCI cards this was (logically) always the case (as I did not rip them out before installation), with removable (wireless) hardware, it is always worth a try to plug it in before installation.

Sounds very user friendly. I will try when I upgrade.

I don’t know how good your german is (well, most dutch people know german a lot better than vice versa, so I will give this a try), but the user “boprop” reported this behavior under 10.3 in this thread:

openSUSE 10.3 - erste Eindrücke und Erfahrungen … - PC-Forum24.de

(Beginning from #21)

Although not explicitely stating he had the dongle plugged in during installation, it is the only logical way why YaST installed zd1211-firmware automatically.

I can understand this German conversation very well. In fact my Tirolerisch is better then my Hochdeutsch :wink:

It is not 100% clear to me because my experience is that YaST at least asks before installing something when it finds new hardware. In any case before II went to exchange the broken SpeedTouch on that system for the Belkin (the system is about 140 km from my home), I tried it here and by looking in dmesg I found I needed the firmware which I found very soon on the Internet. The 10.3 repos were most probably allready gone then.

I remember vague that I also tried on 11.2 and that indeed YaST asked me something about installing something. That was one of the main reasons to go with confidence to that system: on 10.3 it was detected and I had the firmware and on 11.2 it would even be easier. After all it was me that decided for this device for my friend, so I felt responsable for its functionality under openSUSE. :stuck_out_tongue: When at the system, the whole worked as expected.

Well, in that case … :slight_smile:

In the already installed system (i.e on “plug and play”) you are very likely correct, however during installation my expieriences are, that firmware (and sometimes even drivers) are being selected/installed automatically.

The last time I had to deal with removable (wireless) hardware being plugged in before/during installation, the respective firmware (was some ralink device with rt73usb driver IIRC and on openSUSE 11.0) was installed without users interaction needed.

Sounds logical. I will see when I upgrade that system in a few monthes.

Just to add to my traumas, i was mucking about today and i managed to connect to BTOpenzone,which is a wifi hotspot in my area, so that proves the rt2500 driver works, so how come it wont connect to my BT internet wireless?