A How-to explaining how stop 12.3 installs using nvidia cards hanging

I’ve just spent many hours trying to install 12.3 on my laptop, eventually working out that the nouveau drivers do not work with nvidia. Signs that this is the problem are corrupt screen on install, the cursor looking weird and the machine getting slower and slower until it hangs once you boot into KDE.

So, if you have just installed 12.3 and it’s hanging, you need to disable the nouveau driver completely and reboot, then install the nvidia binary blob and you’ll be sorted.

I should possibly have realised sooner because for the past year to 18 months the nouveau driver has been a complete disaster.

Hope this helps others who might struggle.

Do consider that some of us have been able to get the nouveau driver to work. I am using it right now. I can confirm that older nVIDIA chipsets seem to be terrible during the install. You may have success by pressing escape and breaking out of the Plymouth graphic startup and there is always the ability to use the text mode for the installation. I can also suggest to anyone using nVIDIA, that you should consider upgrading the kernel from 3.7 to 3.8 as there seems to be possible issues with that kernel and nVIDIA. Of course, there is nothing wrong with going straight to the nVIDIA proprietary video driver if that is what you want to do.

For kernel upgrades, have a look here: openSUSE and Installing New Linux Kernel Versions - Blogs - openSUSE Forums

For the latest nVIDIA driver, have a look here: Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

For help in installing the nVIDIA driver the hard way, look here: LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.46 - Blogs - openSUSE Forums

And I have other options for nVIDIA as well. The main thing is you over came the problem and you are running OK now, correct?

Thank You for using openSUSE,

There is at least one way to include the proprietary nvidia drivers during installation. This involves downloading the driver files to a USB stick and making them available during installation.

First, go to the nvidia site at Drivers - Download NVIDIA Drivers and determine the correct version for your card.

Next go to the repository at ftp://download.nvidia.com/opensuse/12.3/ and download the files of that version. For me, there were three files for my 7 series card. One file had default, desktop and pae flavors, so I picked desktop to match the kernel. Put these on a USB stick.

I then started a test installation of these with YaST and found there was a dependency for libpangox in the Main-OSS repository. I went to the repository at Index of /distribution/12.3/repo/oss/suse/i586 and put that file on the stick.

When you boot the installation medium, you first get a screen to select Installation, then a Welcome screen, then the System Probing activity, then an Installation Mode screen. That last screen has a check box toward the bottom to “Include Add-on Products from Separate Media”. Check that box and click next. You are offered to set up networking - I skipped it since I had already downloaded to the stick.

Next, you get a page to select the Add-on source, including CD, DVD, hard drive, and USB mass storage. I used USB storage, and the next screen let me pick the drive to use. Whatever medium you pick for your system, I recommend putting the files in the top level of the file structure, since you have to type in the directory on the drive, rather than navigating GUI windows to it.

On the screen for selecting the source, check the box for “Plain RPM directory”.

Proceed with the installation. When at the screen showing the selected configuration, including software; click software, then details, then view -> repositories. In the Add-on repository, check the boxes for proprietary files. (When you check the first, the others will probably be automatically selected.) Continue installation.

FWIW, the 304 series driver works fine with my 7 series card and kernel 3.7.10.

There would appear to be a second way to get the proprietary nvidia drivers, but I could not get it to work. During installation, in the adding separate media step, there is an option to add a repository. I tried that, set up networking, and accepted the default selection of Main-OSS and Main-nonOSS. Those added fine. I then tried to add ftp://download.nvidia.com/opensuse/12.3/ by using the “Specify URL” option, but the next step to check repository type froze. The only way I got off that screen was a hard restart.

With the proprietary driver installed from the start, all the reboots have behaved correctly - no graphics issues. The nouveau driver is in the system, but the nvidia driver gets loaded.


I found the nouveau driver on openSUSE-12.3 works well for nVidia GTX260 hardware (from an installation), and works for nVidia GT210 hardware (from a liveDVD boot). The nouveau driver did not work on an older nVidia GeForce FX5200 for 3.7.x and newer kernels on ALL GNU/Linux distributions and hence did not work on openSUSE-12.3. I first discovered this with a Tumbleweed 3.7.x kernel, and later discovered it on openSUSE-12.3 milestone and RC releases, and also in the GM release of 12.3 and also in a few other different GNU/Linux distributions that i tried. I posted about my experience here: https://forums.opensuse.org/english/get-technical-help-here/tumbleweed/482510-3-7-2-18-kernel-broken-nvidia-fx5200-latest-tumbleweed-kernel.html.

Please note that the bug report I raised on both upstream and on openSUSE-12.3 resulted in an openSUSE kernel developer finding a fix, posting a link to a functional kernel for me to try, and then after it was confirmed that the fix worked (by me) the openSUSE kernel developer has subsequently posted the fix upstream (for other GNU/Linux users to benefit from the openSUSE testing) and also with plans to apply the fix to subsequent openSUSE-12.3 releases.

My recommendation is when users encounter a problem that they believe due to the nouveau driver, that they are very clear in their post as to exactly what graphic hardware device/model their PC with the problem is using. Just saying ‘nvidia card’ is not as helpful as it could be. Then if the problem is confirmed that they raise a bug report and then support the bug report for future resolution. That approach appears to be working for me with the nvidia FX5200 hardware and the nouveau driver.

To be fair, I said if if is hanging, not if there’s any nvidia card to this automatically. It was more of a point of saying if you have nvidia problems then this is [probably] going to sort your problem out.

My empirical findings show that with three modern-ish cards on three different machines, the nouveau driver makes the system either crash or not boot at all. This is with Mageia as well as Open SuSE, so it’s - to my mind - a nouveau problem not a OS problem. On this laptop it’s a GeForce GT 330M on this laptop, I honestly can’t remember what it is on my [Mageia] desktop or my old laptop.

If I’d known/thought about getting rid of the nouveau driver before I’d have saved myself hours and this was just a way of trying to save others time if they found the same issues.

Everything is running fine now, yes, thank you. I rather like SuSE on the whole and, from my perspective, the Broadcom wifi card works which it doesn’t on Mageia at the moment. Plus, the whole reason for upgrading from 12.2 is that I can now plug my Android phone in and transfer files using MTP. :slight_smile:

OK, bearing in mind I’m pretty new to Open SuSE where/how to I report bugs please?

There is guidance in this wiki: https://en.opensuse.org/openSUSE:Submitting_bug_reports

When logging on to bugzilla, you can use your openSUSE forum username and password.

Since you note you are ‘new’ to openSUSE, may I suggest the following approach sometimes can provide great guides for openSUSE aspects that are puzzling:

  • openSUSE bug reports ? Type “openSUSE wiki bugs” in google
  • openSUSE with Skype ? Type “openSUSE wiki Skype” in google
  • openSUSE wik nvidia ? Type “openSUSE wiki nvidia” in google
  • … etc … type “openSUSE wiki topic-of-interest”