A host of problems

Hi folks,
I’ve started having few problems with my openSUSE 11.1 install, most notable after installing the Online automatic updates. Some of these include

  1. At rare occasions, bootup process getting hanged up at “starting jexec service”
  2. Network doesn’t startup, KNetworkManager icon is there in the tray, but it mentions “Network Manager not running”. I have to goto YaST -> Network Services -> Network settings, click on all tabs and hit OK, that triggers openSUSE to start the network services and WiFi connection happens

And the most serious problem, fuse seems to have totally conked off, having a mind of its own. It refuses to unmount while shutting down, at times refuses to mount my /home directory (its on a separate partition).
Sometimes, it mounts, and then remounts on read-only mode. At times, I can’t even traverse through my /home directory, both at console and via dolphin, both hang up, though I can traverse through other directories with no problems

Would appreciate help and replies. I’m using KDE 4.1, that comes installed with OS 11.1
Thanks

establish the netconnection and run zypper update
see if this helps the missed out files get in
also see if the network starts at boot box ticked

Thanks for the reply. have a look,

sathya@shaman~> su root
Password:
shaman:/home/sathya # zypper update
Loading repository data…
Reading installed packages…

The following packages are going to be upgraded:
compiz compiz-branding-openSUSE compiz-fusion-plugins-main compiz-kde4
compiz-manager libcompizconfig libdvdcss libnsssharedhelper0 mozilla-nspr
mozilla-nss ndesk-dbus ndesk-dbus-glib simple-ccsm-kde wine

The following packages are going to change vendor:
compiz compiz-branding-openSUSE compiz-fusion-plugins-main compiz-kde4
compiz-manager libcompizconfig libnsssharedhelper0 mozilla-nspr mozilla-nss
ndesk-dbus ndesk-dbus-glib simple-ccsm-kde

Nothing on fuse here. Also found something weird:


shaman:/home/sathya # ls -la                                                                                                                                                    
ls: cannot access .gvfs: Permission denied                                                                                                                                          
total 411104                                                                                                                                                                        
.....
21:36 .gstreamer-0.10
-rw-r--r--  1 sathya users       323 2008-12-25 12:33 .gtkrc-2.0-kde4
**d?????????  ? ?      ?             ?                ? .gvfs**
drwxr-----  2 sathya users      4096 2008-12-22 20:50 .hplip
...

What’s up with .gvfs? tried a rm -f after su’ing to root, still can’t remove it, says

rm: cannot remove `.gvfs’: Permission denied

i found a .gvfs only in my /root folder.
not in my /home/ramaswamy
it may be root only can delete it.
why do you want to delete it?
it may be connected with some codecs you installed or gedit if you installed.
what problem you have with .gvfs?
you can try move it to /mnt as root.
your problems dont look like related to gnome files.
do the update even if it does not reffer to gnome any way.

I don’t want to delete. I said

what’s up with .gvfs

because I wanted to draw your attention towards the permissions it has & users and groups it is associated with.
I have run the update, with no effect.
And yes before I forget, network starts at boot checkbox ticked and I’m yet to figure out why network doesn’t start.

coolpcguy, I had the same three problems you describe, starting about a week after a fresh install of 11.1 on a ThinkPad T23, using KDE 4.1.3. I found other users mentioning these problems in some other forum threads.

For the jexec and fuse problem, the fix seems to be Yast->System->System Services (Runlevel), scroll to “jexec” in the list, select it, and click Disable.

For the Network Manager problem the fix seems to be Yast->Network Devices->Network Settings, say OK to the warning, on the Global Options tab, uncheck the Enable IPv6 box.

I have been running smoothly for several days after making these fixes, and have noticed no bad side effects. I am puzzled why 11.1 ran well for me for about a week, then started these problems.
Regards,
Howard

My problem with openSUSE 11.1 is a strange “freeze” issue. Both the keyboard and the mouse are frozen.

My hardware details could be found at: Show Box

Please, I need your help. Thanks.

Dell Inspiron 1520 | KDE 4.1.3 “release 69.2”

I installed kernel 2.6.28, and till now, there is no freeze at all :slight_smile:

I hope that fixed the problem.

If you want to install such kernel, you could follow the steps provided at Complete Dose of Linux Poison: Ext4 support on OpenSuse 11.1

Hi ogharib & thanks for your feedback.

I had strange freezes to where my keyboard and mouse would no longer accept input… could move the mouse pointer around though.

Removing the java 1_6_0 version (zypper remove java-1_6_0*) and only keeping the java 1_5_0 version solved the freezes for me.

Now wonder if the 2.6.26 kernel will allow me to use java 1_6_0 again without glitches?

Cheers,
Wj

Thanks a lot for that great hint!
I had the same problem, the jexec prevented the system from starting up. I also had the problem that the shutdown hangs and my external USB drive was recognized, but not accessible. I even could not open a file manager any more. All locks up.

After I renamed the /etc/init.d/jexec file to something else all problems where gone.