A fix for Start Numlock on KDE startup in 4.2.1 release108

The latest update for KDE4.2.1 release108 has eliminated the Start Numlock on KDE start up in the Configure desktop Keyboard and Mouse.
If you like to have your Num Lock on at start up here’e a how to:

  1. Kmenu>Configure Desktop>Advanced Tab
    2.Click Autostart
    3.Click the Add Script Button Then click the icon to the right of script bar
    4.There will be a box with all your folders show up under the places pane select Root
    5.Open the usr folder, then open the bin folder find then select numlockx
    6.Click OK then another box will come up Click OK on that one
    If all has gone well in the Autostart System Settings You should have a line that will look like this:
    See the line
    numlockx /usr/bin/n…
    That’s what you should have if all went well. Now if you shutdown your PC at night or day as the case maybe. When you turn your PC back on your Num Lock will start up when KDE does.

thank you for this workaround it works great.

Good one Sagemta

Thank you!
I liked it to my thread in KDE forums.

Thanks swerdna,ram88,
That means a lot to me.

Finally someone came up with this too!!! Thank you this was a much needed fix.

I too was used to the Num Lock being on at bootup. This fix is great. :slight_smile:
Thank you.

For some reason, I’ve always had numlock on. Up until I just installed 12.1. Now it won’t go on and the names for the menus have changed, so I cannot find the entries you are referring to. Why doesn’t searching “Configure Desktop” aka “Personal Settings” aka “System Settings” yield the info? Why so many names for the same thing?

In recent KDE history, this is in the systemsettings (menu item Configure Desktop - it’s in your favorites unless you’ve changes things). Click Input Devices and it’ll be obvious from there. If for some reason this doesn’t work, there is a way to autostart numlockx that’s more involved, but on openSUSE that’s never been necessary for me (only on Arch and Kororaa).