A Devil Icon showed up as a substitute for regular folders icon


I just got the icons of most of my folders (the regular ones) substituted with a devil icon.

( https://imagebin.ca/v/4ErjqyPDlu5j ) - https://imagebin.ca/v/4ErjqyPDlu5j

If i create a new folder, it gets this icon as well and changing icon theme does not solve the issue

anyone has a clue about what’s happening???

You talking about icons, I bet this is about a desktop environment. But you fail to explain which DE you are using :frowning:

what’s your desktop and preferred file manager
how about showing us a screenshot of your affected desktop and file manager
that picture means nothing
if I have to guess you’ve installed a new application or a theme or …
there is no way for us to know what is happening on your pc from that icon

I’m sorry.

I assumed that, since Plasma is the openSUSE’s “default”, you would get the point! My bad!

Sorry about that! :slight_smile:

Here’s the screenshot: https://imagebin.ca/v/4ErswWj9JkKQ

I’d say try a new clean test user account
you might have accidentally downloaded and installed a plasma 5 theme, that’s the first time I’ve seen that icon I have no idea if it’s part of an application an external theme or it comes with opensuse

The problem is that when others start assuming that you assume it is the default and that thus others assume that you, telling nothing, mean you are using that default (100%), often leads to confusion. Better explain more about what you have/use/see then less. It improves the efficiency of the discussion enormous.

And KDE is not really the default. it is just the one that at installation is chosen because there are always people who do not know what to choose (e.g. because they have no earlier experience with the different DEs). And you can have many DEs on your system, I guess there are enough to use another every day of the week.

And I see see you have given no response to

Please respond always to questions asked, at least with a “I do not know”. because else people who try to help you may feel ignored and thus may ignore your thread from then on.

That’s why i’ve put the “” around the “default” :slight_smile:

There was no “cosmetic” changes made to the system nor no new software installed. No theme installation or anything. The only change that was made was a regular “zypper up” that updated the system (i believe this might have brought some new software, but nothing that is not “recommended” as only the default Leap 15 repos + Mozilla’s are active on the system ).

However, this was made last Tuesday, and either on Wednesday or yesterday this was not seen.

the system is integrated in a network that has multiple systems with both Windows10 and openSUSE 15 - both 64bit - (with one of those opensuse systems having a wine installation with a samba share - if this is important in anyway. This system is not the computer that is having this issues)

The workers do not have root password and are supposedly of limited computer knowledge (but hey, you’ll never know, right…)

File manager is Dolphin.
If you need more info, please just say so :slight_smile:

Thank you

Ah, good. A lot of additional information is coming in.

At the moment I can only support I_A’s idea to try another (best new) user. Curious to hear the result of that.


The workers do not have root password and are supposedly of limited computer knowledge (but hey, you’ll never know, right…)

Those users often are the most dangerous ones >:).
Indeed, beware of giving them the root password.

There was a recent Plasma update, from 5.12.5 to 5.12.6. But I haven’t noticed any icon changes. There are a few minor changes in the ways some menus open up. For example, on Firefox and Opera, I am seeing some secondary bookmark menus opening to the left where they previously opened to the right.

I do agree with the suggestion, that you create a new user account and see what the icons look like there.

I would be wondering about that, myself. I would also be curious what sites they are visiting. I would also be locking the BIOS with a password, and in there blocking any booting from CDs/DVDs/USB devices.

I’d say open kde system settings and in applications -> file associations check the settings for directory
this is what I have
I run a fully updated vanilla plasma 5 under LEAP 15.0
I’d also suggest checking the user mime settings
if all is fine in kde system settings I’d suggest you take a look at the xml files in


you could post the output of

ls ~/.local/share/mime/packages/

you could remove problematic files and rerun

update-mime-database ~/.local/share/mime/

I am sorry to have started a way to go off topic. Making a halfway joking, halfway serious answer to the OP’s message of having users that do not know the root password, I seem to have drawn the attention a bit away from the original problem.

We are talking about the change of an icon for one KDE user. Something a user can do to his/her own KDE environment without needing root permissions. One needs only to know the password of that particular user.

We still need a confirmation about that “one user”. Thus please, do have other users (specially a new created one) on that system the same or not?

I’m sorry for my delay. I’ve been away from job these last few days.

I think tomorrow i can give some feedback again on the issue.

About the user manually changing the definitions i’m pretty sure that’s not the case. It’s a “trusted” user that’s in an open space with the boss (not me) right on in neck ;). So… i would say i’m 98% sure that this change was not intentional.

I can manually change all folders back to the default icon - and they stay that way - but there’s lots and lots of them… Also, everytime i create a new folder, that devilish icon comes back…

I’ll run the commands and check the suggestions given. I’ll post some feedback as soon as i can. Thank you all

there is no need to manually change anything
I’m running LEAP 15 fully updated and I have not seen that icon anywhere
I think the best thing to do is create a test user to see if that is a user or a system issue
if it is a user issue I’m guessing something MIME related got changed I have no idea how
the image above shows the default setting for inode/directory on my rig and if you change it’s icon it will change for all directories (folders are files too)
first check if new users get that icon then we could continue hunting for the reason it showed up

I_A’s solution, apparently solved the problem.

I also checked and other users/accounts are not affected. Anyway, i could not understand what happened…

The user went there and changed it. maybe by accident. The user is in charge of their desktop and can change its look and feel… To stop users from messing around you would need to implement some kiosk mode.

FWIW: the icon is called ‘face-devilish’ and is part of the stock distro Breeze icon theme. In this case I would copy over the plasma* files from the ~/.config of another user.

KDE use to have a kiosk but i believe it’s not active anymore… Do you know anything about it? What Kiosk software would you suggest?

Good idea!!! Didn’t remember that “trick”! Well remembered :smiley: Thanks

Article is only 2 years old so could be out of date


Honestly with KDE throwing so many basic things away I don’t know if it still works