A couple of Questions from an idiot......

Ok so I need to edit a .conf file. I find it in Konqueror, open it, make adjustments, and am THEN told I cannot save it. :X
So I open a console and try eighteen variants of:
sudo kate /usr/local/etc/conky/conky.conf

I get “cannot connect to x server”
Why is this?

I eventually manage to get the job done, and fire up conky (or whatever program)
How do I keep the program running, but get back to a prompt at my console?
If I ctrl-z it freezes whatever I had started?
Do I HAVE to close the console session and open another?

Use the run command instead of the console

err even more confused now! What run command? Where? Alt-F2?
tried that, it just disappears, and kate does not start.

Or is this an answer to Q2?, I guess that would do it, but there must be a way in the console?

Hi
Just copy your template in your home directory under ~/.conkyrc


sudo cp  /usr/local/etc/conky/conky.conf ~/.conkyrc
chmod 644 ~/.conkyrc

Plus why not install the openSUSE version of Conky? I also packaged up
ConkyForcast and have some fonts as well in my home repo.
<http://download.opensuse.org/repositories/home:/malcolmlewis/openSUSE_11.1/noarch/&gt;


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
up 1 day 11:25, 2 users, load average: 2.37, 2.47, 2.43
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

wakou wrote:
> Ok so I need to edit a .conf file. I find it in Konqueror, open it, make
> adjustments, and am THEN told I cannot save it. :X

ok, when you open Konqueror as yourself and try to edit a file which
you do not have permission to read and write (which includes all
files outside YOUR home) then i will not write your edit to the file…

> So I open a console and try eighteen variants of:
> sudo kate /usr/local/etc/conky/conky.conf
>
> I get “cannot connect to x server”
> Why is this?

good plan, and it USED to work…now (and i don’t remember why…you
google it or use the forum search…there was much talk on the change
when it happened–it is something like it can’t attach sudo to the IN
USES Xwindows server) instead of trying to launch any GUI app as root
from a command line (or Alt+F2 run command) instead of

sudo kate /usr/local/etc/conky/conky.conf
use

kdesu kate /usr/local/etc/conky/conky.conf
or
gnomesu kate /usr/local/etc/conky/conky.conf

depending on whether you run KDE or Gnome…if you have the basics of
both installed, you may use either…

> I eventually manage to get the job done, and fire up conky (or whatever
> program)
> How do I keep the program running, but get back to a prompt at my
> console?

yep, i used to know that…but have forgotten…maybe
man screen
will help you…

> If I ctrl-z it freezes whatever I had started?
> Do I HAVE to close the console session and open another?

hmmmm…don’t know…


goldie

Thankyou Malcom, I am sure that will be useful, but:
I was tinkering with conky for the sole purpose of gaining experience with the console, AND:
I only used conky here as an example to illustrate what I meant by the question. How do I start a program in a console, and, when it has started, return to work in the console WITHOUT
freezing the app (ctrl-z)
closing the console and opening another?

Re. conky:
so

~/.conkyrc

takes precedence over

/usr/local/etc/conky/conky.conf

?

Or does it load AFTER it.
If it loads AFTER,

/usr/local/etc/conky/conky.conf

Then is it not best to rename it to

/usr/local/etc/conky/conky.confbak

or similar?

Plus why not install the openSUSE version of Conky? I also packaged up
ConkyForcast and have some fonts as well in my home repo.
<http://download.opensuse.org/repositories/home:/malcolmlewis/openSUSE_11.1/noarch/&gt;

I did not know that there WAS a openSuse specific conky! Is it YAST listed?

Whilst I have the ear of a conky expert, I get nothing in the networking section, I changed eth0 to wlan0 as I use a usb wireless, but nothing shows…?

Use the ampersand ‘&’ to background it.

If I type ‘firefox’ that terminal now just runs firefox.

If I type ‘firefox &’ that terminal executes, then backgrounds firefox, so you can keep working.

With respect do ‘su’ stuff, I think you can accidentally muck up your permissions by using ‘su’ on its own. ‘su -’ is safer, and sometimes lets you run stuff that just ‘su’ won’t.

I may be incorrect on this - it still only makes partial sense to me

TY I*** knew*** there was something like this, I have been bashing away at the ampersand key AFTER I had launched the proggy… and getting nowhere,
also worn out ESC key and Ctrl+ other and typing EXIT and STOP and etc etc etc !

I wonder though if there is not a key combo which allows “Backgrounding” or, from dinosaur days, when computers ran on coal “TSR” after the fact, if for instance you wanted to check a program did what you wanted, and once you knew it did you could issue the key strokes and continue in the same console session?

There are ‘bg’ and ‘fg’ commands… I don’t believe they help directly in this instance, but are certainly an indication that you can manipulate such things.

Going back to very first post, the reason sudo did not work may have been that in openSUSE it does not come configured for any user. You have to configure it to use it.

Hi
Yes, your home one will take precedence :wink:

Have a search here for conky;
Search?

If your wanting to edit a file with a GUI application as root, try kdesu
or gnomesu or xdg-su.

Is wlan0 present when you run the following cat /proc/net/route

PS, if you have more questions, please create a thread in
applications :wink:


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
up 2 days 13:49, 2 users, load average: 0.22, 0.29, 0.27
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

TY Malcolm. As I said in another thread, @ Knurpht “I love Linux people”

Confuseling wrote:
> There are ‘bg’ and ‘fg’ commands… I don’t believe they help directly
> in this instance, but are certainly an indication that you can
> manipulate such things.

Like so:

kate # run e.g. kate from a prompt
^Z # put to sleep, i.e. the process doesn’t do anything.
[1]+ Stopped kate
bg 1 # Wake-up in the background
[1]+ kate &

Btw: if you want to keep using the same console for other apps,
you can use ‘screen’. Before you start working, execute ‘screen’
3 times if you want three consoles to switch between.
Then with CTRL-A-n (where n = 0,1,2) you can select the screen
session to work in.
CTRL-A-? shows you help, CTRL-A-" shows a menu with screen sessions
to switch between.

Theo

I must confess, Rooster, that I did not understand a single word of this. I present in mitigation, some views from the window:


I shall look again at your post, when carnival is over, and I can think again.
If you do not know about it, have a google on “Notting Hill Carnival”
Look at the pictures, and multipy the sound volume by 200%
My poor old brane gives up under these conditions.

Love & tings xxxx
SP.

> I must confess, Rooster, that I did not understand a single word of
> this.

see man screen


goldie

That explains a lot! Thank you.

wakou wrote:
> I must confess, Rooster, that I did not understand a single word of
> this. I present in mitigation, some views from the window:
>
> [image: http://i127.photobucket.com/albums/p145/wakou/Image017.jpg]
> [image: http://i127.photobucket.com/albums/p145/wakou/Image016.jpg]

What the beep are you doing behind a PC with that going on outside?

> I shall look again at your post, when carnival is over, and I can think
> again.
> If you do not know about it, have a google on “Notting Hill Carnival”
> Look at the pictures, and multipy the sound volume by 200%

Only 200%? That’s a mere 6dB, hardly even noticeable.
Now with 20 dB, or 100 times more sound, things get “lively”…

> My poor old brane gives up under these conditions.

Oh go on then; free your mind and enjoy the party!

Theo

Today was “Children’s Day”
Tomorrow, Carnival REALLY gets going.

I can post pics if anyone cares… Unfortunately only an old phone camera, but if you have never been to Notting Hill Carnival then ffs put it in your diary for soon.
I live right in the middle of it so it is for me a bit PITA, but… & but… It IS fantastic!

ON SuSE you prob have to just use “su” instead of “sudo”. Not sure what the sudo settings are on SuSE. But i do know su will get you into root access. Also if kate still gives you hell. Use PICO, its a text based editor that will get around all that other headache.