A bug, I think : KDE 4.10.1 Device Notifier

I just upgraded my 12.2 to KDE 4.10.1

I see the following issue:

I inserted an SD card into internal Card reader,
Device Notifier opened as expected, offered three actions, I chose download with Digikam
Digikam opened and download worked as expected.
I closed the Digikam Import window, Digikam main window still open
I selected the Device Notifier icon, it pops up as expected
As soon as I move the mouse pointer off the system tray, moving toward the Unmount icon, the pop-up closes.

I am able to unmount the SD card from within Dolphin.

Can someone confirm this behavior before I enter a bug?

I just did this with a thumb drive and it worked as expected, must only be SD card or maybe your particular reader.

Thanks for the additional info.

I am somewhat suspicious of USB3 drivers, maybe.

Motherboard has both USB2 and USB3.
I have tried a USB2 thumb drive in USB2 port, it seems OK.
Same Thumbdrive in USB3 port mounts OK, but exhibits the same behavior when I try to unmount thru device notifier.
The SD card reader is USB3.

As first reported, the USB memories (SD or Thumb), behave normally when controlled via Dolphin

I am fairly certain this is the Card Reader Device on the USB bus:

carl@PVE-LinuxSRV5:~> lsusb
Bus 007 Device 002: ID 0bda:0301 Realtek Semiconductor Corp.

I’ll wait for some additional input from someone with an SD card reader

For anyone who comments, USB2 vs. USB3 connection of the card reader may be important info.

As an aside - USB3 Card readers provide SIGNIFICANT SD card download improvement.