82801I: mic doesn't work & produces ugly noices Skype [11.1]

Hi, guys. Sorry, but I have this problem too. :frowning:

I have opensuse 11.1 with KDE. The sound works fine, but mic unfortunately does not.

I’ve tested it with arecord (only noise) and skype (it produces ugly noices and sometimes strange slapping sounds :open_mouth: ).

cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
            HDA Intel at 0xfa100000 irq 22
cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel
# u1Nb.m5Zx97I2gHE:82801I (ICH9 Family) HD Audio Controller
options snd-hda-intel enable=1 index=0
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

Any idea how to solve the problem? Do you need more information?
Please, help me.

I do not use Skype, so I can NOT help you configure that. But you should be able to configure your audio with arecord.

Note when using arecord, follow the advice here: Microphone - openSUSE

In particular, please note the options to use for ‘arecord’ :

arecord -vv -fdat foo.wav

It will give dynamic feedback as to your mic levels when adjusting your mixer.

I took a look at the script output, and I note a 32-bit openSUSE-11.1 with the pae kernel with the packaged 1.0.17/1.0.18 version of alsa, and your PC has an ALC889A hardware audio codec.

You did not mention if you are using an external or internal mic, and if using an external, if you are trying to use a front jack or rear jack on the PC? It appears you have things set to a rear jack?

I note this in your mixer:
!!Amixer output

!!-------Mixer controls for card 0 [Intel]

Card hw:0 ‘Intel’/‘HDA Intel at 0xfa100000 irq 22’
Mixer name : ‘Realtek ALC889A’
Simple mixer control ‘Front Mic’,0
Front Left: Playback 31 [100%] [12.00dB] [off]
Front Right: Playback 31 [100%] [12.00dB] [off]
Simple mixer control ‘Front Mic Boost’,0
Front Left: 3 [100%]
Front Right: 3 [100%]
Simple mixer control ‘Mic’,0
Front Left: Playback 30 [97%] [10.50dB] [on]
Front Right: Playback 30 [97%] [10.50dB] [on]
Simple mixer control ‘Mic Boost’,0
Front Left: 3 [100%]
Front Right: 3 [100%]
Simple mixer control ‘Capture’,0
Front Left: Capture 24 [52%] [8.00dB] [on]
Front Right: Capture 24 [52%] [8.00dB] [on]
Simple mixer control ‘Capture’,1
Front Left: Capture 0 [0%] -16.00dB] [off]
Front Right: Capture 0 [0%] -16.00dB] [off]
Simple mixer control ‘Capture’,2
Front Left: Capture 0 [0%] -16.00dB] [off]
Front Right: Capture 0 [0%] -16.00dB] [off]
Simple mixer control ‘Input Source’,0
Items: ‘Mic’ ‘Front Mic’ ‘Line’ ‘CD’
Item0: ‘Mic’
Simple mixer control ‘Input Source’,1
Items: ‘Mic’ ‘Front Mic’ ‘Line’ ‘CD’
Item0: ‘Mic’
Simple mixer control ‘Input Source’,2
Items: ‘Mic’ ‘Front Mic’ ‘Line’ ‘CD’
Item0: ‘Mic’
I’m puzzled since you do not have the front mic selected (you have mic selected) and you have the front mic muted, but you have its (front mic) boost at 100% and front mic playback at 100%. Why ?

I did a search on the alsa web site for the ALC889A and I note there have been some updates to alsa (currently at 1.0.21) since the 1.0.17/1.0.18 version that you have installed: Search results - AlsaProject However I do not know if those are important.

There is also the possibility that if your mixer is configured correctly, that the auto probe by alsa sound driver / kernel module did not properly configure your mic/sound upon boot, and that you may wish to try forcing a specific setting … I noted in the 1.0.18 alsa there was no entry for the ALC889A but there is in the 1.0.21 alsa HD-Audio-Models.txt file. Hence I am thinking that if you are not successful with the mixer, then you may wish to update your alsa to the latest version of alsa.

In which case send six zypper commands as described in this URL. Note there are Six commands to send: Alsa-update - openSUSE
… please read the instructions carefully. For the second command where you update alsa, alsa-docs, and libasound2, you may also wish to update alsa-firmware, alsa-oss, alsa-utils, alsa-tools, alsa-plugins. Don’t forget to reboot after updating alsa, if you decide to update alsa.

Good luck.

  1. for arecord I used this command: arecord -vv -fdat -d 10 /home/soshial/Downloads/foo.wav, it works.

PC has an ALC889A hardware audio codec.
what does this mean for me?
I’m using external mic and i was trying to use the front jack.
Frankly, I don’t understand what is mic boost and what’s the difference between the “just mic” and front mic?

  1. So what’s happened when I tried to plug a mic in different ways after your advice.

– I tried to plug my mic into rear jack and it worked: I heard my voice in arecord and skype, but it was full of noise. But it means that all this could work. :slight_smile:

– Then I plugged the mic into the front jack and unmuted the “front mic” in kmix - and I could hear my own voice from my speakers, but when I tried to record it using arecord I heard nothing but noise.

What should I do to adjust all settings in a proper way? :slight_smile:
Thank you for assistance!

OK, then your mic works. IMHO when you are troubleshooting your mic, “arecord” with the options noted, is the program you should fall back upon and use to confirm basic mic functionality. Once that is confirmed you can test Skype and other apps that use the mic.

There are dozens ( hundreds ? ) types of audio hardware, and alsa sound driver has to automatically configure for each one. The types are categorized with different names, and the name associated with yours is ALC889A. So if we want to look for updates, or if we want to custom configure it, then we know what to search under (ie under “ALC889A” which is your specific hardware). Clear as mud? :slight_smile:

Mic boost is just that. I boosts the input from your mic, making it louder. BUT it might also introduce distortion. Typically noise/distortion is a trade off between high volume and bad background noise. You need to 1st get basic recording (even if noisy). You now have that. Then you need to test the affect of lowering the capture and lowering the boost of each of the controls in a logical step by step manner (take notes) so that you understand by test the functionality and effect of each.

Note you have to unmute AND select it. Last I looked at the script output, you did not have front mic selected.

Okay, I did what you said – I unmuted the “front mic”, plugged the mic into it, then made front mic boost to 33% and agian I have noise in arecord and my voice (with no noise) in my speakers (i mean, all the sound from mic retranslates into audio out – my speakers – which i suppose shouldn’t be).

So, what did I misset? thx

Take a look at all your mixer settings, and try tune them to see if you can improve this.

I also gave you advice how, if the mixer approach does not work, as to how you can update alsa. What did you do there? Did you follow thru all the advice given?

I’ve just updated to 1.0.21. Now I don’t have sound at all ((
What should I do??

Chances are it does work, and there is just a misconfiguration somewhere. Please with your PC connected to the internet, open a konsole/terminal and type:
that will give you a URL after it has completed. Please post that URL here.

Also, please provide the output of the following commands (so I can check your update was implemented correctly):
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libsound2
uname -a
cat /etc/modprobe.d


rpm -qa | grep alsa

rpm -qa | grep pulse


rpm -q libsound2
package libsound2 is not installed
rpm -q libasound2

uname -a
Linux auth #1 SMP 2009-08-15 17:53:59 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel
# u1Nb.m5Zx97I2gHE:82801I (ICH9 Family) HD Audio Controller
options snd-hda-intel enable=1 index=0
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel


OK thanks. Did you check to see if sound functioned when the speaker tests are run with root permissions? (to check for a permissions problem ? ).

Did you reboot after updating?

Anyway, try updating all your alsa apps to 1.0.21. Open a konsole/terminal, with your PC connected to the internet, and with root permissions type:

zypper ar http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.1/ multimedia
zypper install alsa-utils alsa-firmware alsa-plugins alsa-plugins-pulse alsa-oss
zypper rr multimedia

Reboot and test.

If that does not work, we can try the daily snapshots.

I have updated all my alsa apps and it worked. Now my speakers work again :slight_smile:
And rear jack works too as before updating, but the front doesn’t. ((
(I checked, that in Windows the front one does work)

And , how about the noise in arecord? Can you tune out the noise?

If not, then its readling more and more like a possible mixer problem …

BUT, if you are convinced its not the mixer, then IMHO its more time efficient to raise a bug report on this, and you will get the attention of an alsa developer ( … which is one of the great things about openSUSE, as we have a couple alsa developers who can address bug reports :slight_smile: ).

Information on raising bug reports here: Submitting Bug Reports - openSUSE

Raise it against component sound. Keep watching for the flag “new info requested” as that means the developer wants some information or wants you to test something.

You can almost be guaranteed you will be asked to run:
/usr/sbin/alsa-info.sh --no-upload
and then copy from /tmp the file alsa-info.txt to the buzilla web site

Now we have this bug posted :slight_smile:

but noone yet has answered :frowning: