82801H (ICH8 Family) HD Audio Controller (rev 04); No sound

Hi there, a completely new user of openSUSE and Linux, and really am loving the change from Windows.

I’m only having one problem, no sound :frowning:

After freshly installing openSUSE 11.1 gnome on my Medion MD96970 or WIM 2220, i was sad to find when looking at volume control that there was null output, so I went through SDB:AudioTroubleshooting - openSUSE and tried to update alsa but still no go.

I’ve included a link to my /usr/sbin/alsa-info.sh
http://www.alsa-project.org/db/?f=43eab1d78141c7cf14451bb7b3d0c76e3b42e090

And some more info below


jw@linux-fsdy:~> speaker-test -c2 -Ddefault -l5 -twav

speaker-test 1.0.19

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 3.803478
 0 - Front Left
 1 - Front Right
Time per period = 3.757853
 0 - Front Left
 1 - Front Right
Time per period = 4.098913
 0 - Front Left
 1 - Front Right
Time per period = 4.069515
 0 - Front Left
 1 - Front Right
Time per period = 4.108247

jw@linux-fsdy:~> rpm -qa | grep alsa
alsa-oss-1.0.17-1.37
alsa-firmware-1.0.19.git20090317-1.1
alsa-plugins-1.0.18-6.12
alsa-plugins-pulse-1.0.18-6.12
alsa-1.0.19.git20090410-1.1
alsa-tools-1.0.19.git20090320-1.4
alsa-utils-1.0.19.git20090410-1.1
alsa-driver-kmp-pae-1.0.19.20090406_2.6.27.19_3.2-1.1

jw@linux-fsdy:~> rpm -qa | grep pulse
pulseaudio-0.9.12-9.6
pulseaudio-module-gconf-0.9.12-9.6
pulseaudio-module-lirc-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
alsa-plugins-pulse-1.0.18-6.12
libpulse-browse0-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-zeroconf-0.9.12-9.6
libpulse0-0.9.12-9.6
libpulsecore4-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
pulseaudio-module-x11-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6

jw@linux-fsdy:~> rpm -q libasound2
libasound2-1.0.19.git20090410-1.1

jw@linux-fsdy:~> uname -a
Linux linux-fsdy 2.6.27.21-0.1-pae #1 SMP 2009-03-31 14:50:44 +0200 i686 i686 i386 GNU/Linux

jw@linux-fsdy:~> cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=medion

Haven’t had any sounds with the tests, Hope its an easy fix :wink:

This indicates a problem:

!!ALSA Version
!!------------

Driver version:     1.0.17
Library version:    
Utilities version:  1.0.19

You have the old 1.0.17 driver with the latest 1.0.19 utilities. That is practically guaranteed to break your sound/

That is confirmed by this:

You have the very latest 2.6.27.21 kernel, with alsa built for the 2.6.27.19 kernel. You will have to wait some days until the openSUSE alsa dev releases an update of alsa for the 2.6.27.21 kernel.

The new kernel was just released on Wednesday this week. … Sometimes it takes up to a week for the updated sound drivers (associated with the new kernel) to hit the street.

After installing opensuse, there was no sound so i ran the software update and went through the whole troubleshooting thing

I can do a fresh install and hopefully we can try and work from there, I’ll upload some info from that in a bit

With the freshest of installs i’ve got the following info, it looks as if it hasn’t recognised the sound card, with not a lot in the modprobes.d/sound file

New link for info:http://www.alsa-project.org/db/?f=ba64785a653363ccaf3c87a17830155d0b6a21c5


jw@linux-ngfi:~> speaker-test -c2 -Ddefault -l5 -twav

speaker-test 1.0.18

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 4.522554
 0 - Front Left
 1 - Front Right
Time per period = 4.522850
 0 - Front Left
 1 - Front Right
Time per period = 4.521209
 0 - Front Left
 1 - Front Right
Time per period = 4.534163
 0 - Front Left
 1 - Front Right
Time per period = 4.522336

jw@linux-ngfi:~> rpm -qa | grep alsa
alsa-oss-1.0.17-1.37
alsa-utils-1.0.18-6.4
alsa-plugins-pulse-1.0.18-6.12
alsa-1.0.18-8.7
alsa-plugins-1.0.18-6.12

jw@linux-ngfi:~> rpm -qa | grep pulse
pulseaudio-0.9.12-9.6
pulseaudio-module-gconf-0.9.12-9.6
pulseaudio-module-lirc-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
alsa-plugins-pulse-1.0.18-6.12
libpulse-browse0-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-zeroconf-0.9.12-9.6
libpulse0-0.9.12-9.6
libpulsecore4-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
pulseaudio-module-x11-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6

jw@linux-ngfi:~> rpm -q libasound2
libasound2-1.0.18-8.7

jw@linux-ngfi:~> uname -a
Linux linux-ngfi 2.6.27.7-9-pae #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux

jw@linux-ngfi:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel
# u1Nb.yxMCD9zgGiF:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

Try installing alsa-firmware from the OSS repository.

Its also located here (which is not a proper repos URL, as I have gone too many subdirectories deep):
Index of /distribution/11.1/repo/oss/suse/noarch

Then reboot and test.

Or simply wait a week or less until the alsa/openSUSE dev creates an alsa for the latest kernel release.

Its possible the alsa-firmware won’t work, and that the autoprobe for your codec failed upon boot, in which case an edit to your /etc/modprobe.d/sound file will be necessary.

Here is the list of possible model options (to be applied one at a time) for your PC’s alc888 codec.

ALC883/888
==========
  3stack-dig	3-jack with SPDIF I/O
  6stack-dig	6-jack digital with SPDIF I/O
  3stack-6ch    3-jack 6-channel
  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
  6stack-dig-demo  6-jack digital for Intel demo board
  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
  acer-aspire	Acer Aspire 9810
  acer-aspire-4930g Acer Aspire 4930G
  medion	Medion Laptops
  medion-md2	Medion MD2
  targa-dig	Targa/MSI
  targa-2ch-dig	Targs/MSI with 2-channel
  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
  lenovo-101e	Lenovo 101E
  lenovo-nb0763	Lenovo NB0763
  lenovo-ms7195-dig Lenovo MS7195
  lenovo-sky	Lenovo Sky
  haier-w66	Haier W66
  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
  6stack-dell	Dell machines with 6stack (Inspiron 530)
  mitac		Mitac 8252D
  clevo-m720	Clevo M720 laptop series
  fujitsu-pi2515 Fujitsu AMILO Pi2515
  fujitsu-xa3530 Fujitsu AMILO XA3530
  3stack-6ch-intel Intel DG33* boards
  auto		auto-config reading BIOS (default)

I have to run now (another commitment way from computers). If you sound doesn’t work, post and I’ll walk you thru the necessary edits.

OK, … I’m back! :slight_smile:

If installing alsa-firmware does not help, then consider the following …

Modify your /etc/modprobe.d/sound file, trying out each of the model options (one at a time) that I listed in the above thread.

For example, lets say you wish to try the option “medion-md2”. To do that, open an editor with root permissions so you can edit the file. … In KDE as a regular user you could type:
kdesu kwrite /etc/modprobe.d/sound
and enter root password when prompted for a password, and then edit the file.

In gnome as a regular user you could type:
gnomesu gedit /etc/modprobe.d/sound
and enter root password when prompted for a password, and then edit the file.

After editing the file for “medion-md2” it should look like:

options snd-hda-intel model=medion-md2
options snd slots=snd-hda-intel
# u1Nb.yxMCD9zgGiF:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

then restart your alsa sound driver with su -c ‘rcalsasound restart’ (and enter root password when prompted) and restart your mixer (kmix in kde and alsamixer in gnome) and test your sound.

If “medion-md2” does not work, then replace it with another option from the list I provided, save the change, restart your sound driver with the command I gave, restart your mixer, and test. Do that for each model option.

If you wish feedback (in addition to any errors) as to what you get from the model option, you could look at your dmesg file. One way to do that (with your PC connected to the internet) is to type:
dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/a
and then check out the URL that is provided. Typically I do a search in that file for keywords “snd”, or “hda” or “alsa”.

Good luck.

Sorry, just woken up.

I thought I’d give some additional info, if I delete the sound card’s configuration in the YaST control panel and try quick automatic setup with it, it comes up with this error.

An error during the installation of
82801H (ICH8 Family) HD Audio Controller
The kernel module snd-hda-intel for sound support
could not be loaded. This can be caused by incorrect
module parameters, including invalid IO or IRQ parameters.

Would there be something wrong with the snd-hda-intel module?

I’ve installed the new firmware and tried editing the modprobe sound file with the models but each time I run the
‘speaker-test -c2 -Ddefault -l5 -twav’ test it keeps coming up with this error,

Playback open error: -111,Connection refused
ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused

Immediately after a reboot, please run the dmesg command I provided above to get more information on errors, and also try the model options (one at a time) in your /etc/modprobe.d/sound file.

dmesg link is:dmesg.txt - nopaste.com (beta)

Will try all of the models again now :slight_smile:

The first time you ran the diagnostic script, it identified the hardware audio codec in your PC as an ALC888.

However the dmesg appears to indicate the alsa auto probe is identifying your hardware audio codec as an ALC268 where it states: " hda_codec: Unknown model for ALC268, trying auto-probe from BIOS… "

I note this from the dmesg:

HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
HDA Intel 0000:00:1b.0: setting latency timer to 64
input: CHICONY USB Keyboard as /devices/pci0000:00/0000:00:1a.1/usb2/2-1/2-1:1.1/input/input10
ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
ALSA sound/pci/hda/hda_codec.c:2334: hda_codec: model 'medion' is selected
HDA Intel 0000:00:1b.0: PCI INT A disabled
HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
HDA Intel 0000:00:1b.0: setting latency timer to 64
hda_codec: Unknown model for ALC268, trying auto-probe from BIOS...
ALSA sound/pci/hda/hda_codec.c:3047: autoconfig: line_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3051:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3055:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3056:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3064:    inputs: mic=0x0, fmic=0x0, line=0x0, fline=0x0, cd=0x0, aux=0x0
hda_codec: Cannot set up configuration from BIOS.  Using base mode...
ALSA sound/pci/hda/hda_intel.c:1816: SPDIF already defined
ALSA sound/core/control.c:329: control 2:0:0:Front Playback Volume:0 is already present
ALSA sound/core/control.c:329: control 2:0:0:Front Playback Switch:0 is already present
ALSA sound/core/control.c:329: control 2:0:0:Headphone Playback Switch:0 is already present
ALSA sound/core/control.c:329: control 2:0:0:Mic Boost:0 is already present
ALSA sound/core/control.c:329: control 2:0:0:Front Mic Boost:0 is already present
ALSA sound/core/control.c:329: control 2:0:0:Capture Volume:0 is already present
ALSA sound/core/control.c:329: control 2:0:0:Capture Switch:0 is already present
ALSA sound/core/control.c:329: control 2:0:0:Input Source:0 is already present
ALSA sound/core/control.c:329: control 2:0:0:IEC958 Default PCM Playback Switch:0 is already present
HDA Intel 0000:00:1b.0: PCI INT A disabled
HDA Intel: probe of 0000:00:1b.0 failed with error -16

If the various model options for the ALC888 do not work, then you could try the options for the ALC268:

ALC267/268
==========
  quanta-il1	Quanta IL1 mini-notebook
  3stack	3-stack model
  toshiba	Toshiba A205
  acer		Acer laptops
  acer-dmic	Acer laptops with digital-mic
  acer-aspire	Acer Aspire One
  dell		Dell OEM laptops (Vostro 1200)
  zepto		Zepto laptops
  test		for testing/debugging purpose, almost all controls can
		adjusted.  Appearing only when compiled with
		$CONFIG_SND_DEBUG=y
  auto		auto-config reading BIOS (default)

… although I find the script is usually pretty accurate (ie I believe the ALC888 more than I believe the 268).

I think you should write a bug report if you have no success with the model options. Be certain to select the category “SOUND” in your bug report so that it comes to the attention of the alsa/openSUSE developer. Submitting Bug Reports - openSUSE

Before trying out openSUSE, I tried gOS an Ubuntu derivative off a liveCD, in its sound output devices there were:
(I could only get very little sound out of them)
ALC 268 Analog
ALC 883 Analog
ALC 883 Digital
ALSA
OSS
PulseAudio

And a copy of its dmesg.txt is at:nopaste.com (beta)

The only interesting things were:

  135.476424] hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...
  135.478955] hda_codec: Unknown model for ALC268, trying auto-probe from BIOS...
  135.479453] hda_codec: Cannot set up configuration from BIOS.  Using base mode...
  135.480320] ALSA /build/buildd/linux-ubuntu-modules-2.6.24-2.6.24/debian/build/build-generic/sound/alsa-driver/pci/hda/../../alsa-kernel/pci/hda/hda_intel.c:1470: SPDIF already defined

Thanks for all the help, none of the model options are working.
Will submit a bug report and hope for the best :wink:

If you manged to get sound out of the live CD, what would be interesting would be its output of the alsa-info script … ie … when booting to that live CD, and connected to the internet, copy and paste the following line:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh

and paste here the output URL. If sound is working on that live CD, then the above script may give some hints as to what is being done to make it work.

Link for livecd alsa info at:http://www.alsa-project.org/db/?f=0863445a69ecab78a89851d958efb86dcca2a70f

Just an extra note for this, the sound does work, however, it’s very faint, quiet sound out of notebook speakers with a subwoofer and 2 speakers needed to be plugged in to the headphone jack to hear ‘normal’ volume.:stuck_out_tongue:

There is not much showing up for a mixer there. Presumeably you needed to run alsamixer to then improve the volume on that Ubuntu live CD. I note your PC’s sound hardware codec is identified as an ALC888 there.

Reference your openSUSE, did you try booting with no option specified in the /etc/modprobe.d/sound file?

When you write the bug report, you may wish to include reference to this quasi functional Ubuntu configuration. … This somewhat old (1.0.15/1.0.16) functional Ubuntu config supports IMHO the view I have that Ubuntu are very tardy (or simply do not) submit many of their fixes upstream.

I see that 1.0.19 of the alsa rpms has been released now for the 2.6.27.19 kernel. Accordingly I updated the wiki: Alsa-update - openSUSE