82801H (ICH8 Family) HD Audio Controller (rev 03)

Thankyou for that. Can you also give me the output of the commands:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
cat /etc/modprobe.d/sound

Here we go:

rpm -qa | grep alsa

alsa-oss-1.0.15-48.1
alsa-utils-1.0.16-35.1
alsa-driver-kmp-pae-1.0.16.20080707_2.6.25.5_1.1-1.1
alsa-1.0.16-39.1
alsa-driver-unstable-kmp-pae-1.0.16.20080704_2.6.25.5_1.1-1.1
alsa-plugins-1.0.16-57.1
alsa-firmware-1.0.16-24.1
alsa-plugins-pulse-1.0.16-57.1

rpm -qa | grep pulse

libpulse-browse0-0.9.10-26.1
pulseaudio-module-lirc-0.9.10-26.1
libpulse0-0.9.10-26.1
pulseaudio-esound-compat-0.9.10-26.1
libpulsecore4-0.9.10-26.1
gstreamer-0_10-pulse-0.9.7-42.pm.1
pulseaudio-module-zeroconf-0.9.10-26.1
pulseaudio-module-bluetooth-0.9.10-26.1
libpulse-mainloop-glib0-0.9.10-26.1
pulseaudio-module-gconf-0.9.10-26.1
pulseaudio-utils-0.9.10-26.1
pulseaudio-0.9.10-26.1
alsa-plugins-pulse-1.0.16-57.1
pulseaudio-module-x11-0.9.10-26.1

rpm -q libasound2

libasound2-1.0.16-39.1

cat /etc/modprobe.d/sound

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

Please, IMHO trying to play a file with a proprietary codec (ie an mp3) is not the best test to see if your overall system has sound. It is too specific. Instead, please copy and paste the following into a konsole and use it as your test:
speaker-test -c2 -Ddefault -l5 -twav

From your posts above I see you tried that sort of konsole “speaker-test” before, and I urge you to keep doing that sort of test each time you want to test your system sound. We can solve any kaffeine mp3 playing issues later.

Thank you for the various command outputs. That looks good (except for /etc/modprobe.d/sound file). Note when your run alsaconf or YAST>HARDWARE>SOUND it will wipe out any custom settings you may have entered in your /etc/modprobe.d/sound file. So if you get a setting in that file that works, do NOT run alsaconf nor YAST>HARDWARE>SOUND.

Ok, did you try the edits from the post above, post#4 with ALC883/888 options possibly applicable to an ALC889 to your /etc/modprobe.d/sound file (where we noted that the ALC883/888 options may work for an ALC889 (which you have in your Acer Aspire 6920G) ??

Also, IMHO the /etc/modprobe.d/sound file above is what you get after running alsaconf. We can try edit that variant, although it may be that is not a good baseline, and it may be better to try this after YAST>HARDWARE>SOUND.

anyway, please add the line “options snd-hda-intel model=auto” to the end of that file, ie try:

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=auto

then restart your alsa with “rcalsasound restart” and test your sound. Be certain to check your mixer as it could have been reset.

If that fails, instead of “auto” you could try “acer” and if that fails “acer-aspire”.

And if that fails, go to yast and try YAST>HARDWARE>SOUND and try configure your sound card (which will create a different /etc/modprobe.d/sound file) and then using that newly created sound file as a baseline, add the line “options snd-hda-intel model=auto” at the end of the file as noted above, restart your alsa, and continue testing again, as above.

dear friends,

iam following this topic with great interest.
i have also a 6920g and like to install it for a testproject an a mac emulation. sound problem is the same and it looks even other have probs with that 889 in the acer, looks a bit different than the usual alc 889 drivers.

when u get it run, u may tell me whats the different to the regular 889 drivers and may with luck i can use that information to bring my system run in my emulation.

thanks and fine regards
chris

Dear All

I too have been following this with great interest. I have an acer aspire 5920.
I had a similar problem after installing SUSE 11 i.e. no audio from the laptop speakers.
You have probably already tried this but this fixed it for me:-

I installed the alsa-utils as suggest (thanks oldcpu ;-))
I then launched the volume control from the start menu (or gnome-volume-control from xterm).
After much messing around I found that for some reason the laptop speakers had been assigned the “surround” channel. This is hidden and muted by default.
To access it, in the volume application select edit -> preferences.
check the “surround” option and close the preferences window.
Unmute the option and raise the volume level. Try the following command again to test:-
speaker-test -c2 -Ddefault -l5 -twav

I then had sound. I’ve yet to figure out how to get the volume appelet to launch gnome-volume-control as default but that is another thread :wink:

BTW thanks to all on the Forums

I have been having the same issues with sound on my ASUS Laptop, i have managed to sort it by editing /etc/modprobe,d/sound

options snd slots=snd-hda-intel
options snd-hda-intel model=hp

u1Nb.ULiNFUWt9WF:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

I now have sound from the speakers but not the headphones, its a start, I hope this helps someone

Sorry forgot to add

Codec: Realtek ALC660-VD

Hope it helps folks

I had the same problem with Intel ICH8 family on my laptop Asus F9S.
I installed Alsa 1.0.17.git20080715-1.1 putting the option “lenovo” instead of “auto”.
It seems that the word “lenovo” is the magic solution.

Note that there are many possible options that one can put in the /etc/modprobe.d/sound file. But one needs to put the option that is specific to their hardware, and often no two laptops are alike. For example, if one looks at the ALSA-Configuration.txt file for the lastest (as of today I think) 1.0.18RC1 of the alsa driver, various audio codecs are as follows (with each of them having a different model options that can be applied):
ALC880, ALC260, ALC262, ALC267/268, ALC269, ALC662/663, ALC882/885, ALC883/888, ALC861/660, ALC861VD/660VD, CMI9880, AD1882, AD1884A / AD1883 / AD1984A / AD1984B, AD1884, AD1981, AD1983, AD1984, AD1986A, AD1988/AD1988B/AD1989A/AD1989B, Conexant 5045, Conexant 5047, Conexant 5051, STAC9200, STAC9205/9254, STAC9220/9221, STAC9202/9250/9251, STAC9227/9228/9229/927x, STAC92HD71B*, STAC92HD73*, STAC9872

I copied the latest alsa 1.0.18 RC1 here:
general pastebin - ALSA-Configuration.txt - post number 1198249
(paste good for 1 year).

So as you can see, stating one has a specific model option applied, often only is directly useful if one also states what hardware audio codec is in use. Else one has to check the ALSA-Configuration.txt file.

As an example, searching the ALSA-Configuration.txt file, one can see that the model option “lenovo” (of that exact syntax) is only applicable to the ALC861VD/660VD for 1.0.18 RC1 of alsa. Different alsa versions may be slightly different.

Hi,

I’ve been having these problems as well on my Compal FL90 notebook running Opensuse 11.0, which has got a “82801H (ICH8 Family) HD Audio Controller (rev 03)” too.
I’ve upgraded Alsa to 1.0.17.git20080905-1.1 (x86_64).

To kick off:
lspci

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

head -n 1 /proc/asound/card0/codec*

==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC268

==> /proc/asound/card0/codec#1 <==
Codec: Motorola Si3054

I have tried configuring Alsa through alsaconfig, I tried editing /etc/modprobe.d/sound (entered several model strings: hp, toshiba, auto…), I tried (sudo) speaker-test -Dplug:front -c2 -l5 -twav, which never returns sound. But when restarting rcalsasound I do get this:

Shutting down sound driver                                           done
Starting sound driver:  hda-intel                                    done

…And I can hear some ‘crisp’ in my earphones, but nothing more.
When I execute rcalsasound restart I also get a warning message that ‘volume control’ has shut down unexpectedly.
Also after restarting the sound server when I try to open Volume Control from the Gnome panel I get ‘connection failed:connection refused’ (this last problem disappears after a reboot).

I hope someone can help me out in configuring sound on my otherwise fully configured Opensuse 11.0 installation.
I’m willing to cooperate in terms of posting outputs etc.

greetings,
driesel

Hi,

After another reboot I’ve got my sound working after all without doing anything aditionally ;).
Anyway, great thanks to the Opensuse community for various tips!

Hello! I have a notebook - Acer Aspire 8920 and when i used this alsa and this code

options snd-hda-intel index=0 enable=1 model=auto
# u1Nb.g5Eu65_2Iy6:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
  • i have a sound from 2 speakers(front left & front right), but how can i take all 5.1 sound?

IF i use parametr model=acer or acer-aspire - i haven’t any sound

Please start a new thread, and maybe someone who has 5.1 sound working will help you (I do not have 5.1 sound hardware). In the new thread, please provide more information.

To determine if you have 5-channel sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole: speaker-test -c6 -l5 -twavYou should hear a female voice saying the various speakers five times. Note -c6 is what I propose for testing 5 channel sound. (Its possible -c5 is a better setting - I don’t know as I do not have 5.1 hardware).

If you have no success with the audio troubleshooting guide, then I will need more information if I am to make a recommendation … So in the new thread (assuming you are using openSUSE-11.1), can you provide more very detailed information so a good recommendation can be given by who ever gives you help? You can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and typing:
/usr/sbin/alsa-info.shthat will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL in the new thread. (Just the URL) It may be that you need to run that script with root permissions.

Please also post whether you are using KDE3, KDE4, or Gnome.

Also, in your post in the new thread, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

I have a HP Pavilion dv7-1080ew laptop with the “Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)” (as reported by “lspci”) running OpenSUSE 11.1 and can’t get the sound to work.

I’ve installed the latest Alsa packages from the Multimedia repository (“alsa-1.0.19.git20090122-1.1” reported by “rpm -qa alsa”) after unsuccessful attempts so far with the standard version 1.0.18. I have no sound on my front headphones jack nor the internal speakers, even though I set most channels to maximum in alsamixer.

To make matters worse, I have sound playing OK under Ubuntu 8.10 after patching /etc/modprobe.d/alsa-base according to hints in the thread 269586 of Ubuntu bug database. I tried the same trick (adding “options snd-hda-intel enable_msi=1” to /etc/modprobe.d/sound) in OpenSUSE but that did not help. What then could I be doing wrong?

Please start a new thread and do not tag on to this old thread. Invariably not enough information is provided to help, and then one ends up with multiple people, all with different problems, trying to solve their problem in the same thread. Invariably then one takes the solution for someone else and inappropriately apply’s their solution to one’s PC, and messes up one’s configuration even further, making it even more difficult to unravel the problem. So PLEASE start a new thread.

In the new thread, when providing an assessment if your sound works, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole: speaker-test -c2 -l5 -twavYou should hear a female voice saying the various speakers five times. Note -c2 is what I propose for testing 2 channel sound. Also try with root permissions.

If that provides no sound, then in the new thread (assuming you are using openSUSE-11.1), can you provide more very detailed information so a good recommendation can be given by who ever gives you help? You can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and typing:
/usr/sbin/alsa-info.shthat will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL in the new thread. (Just the URL) It may be that you need to run that script with root permissions.

Please also post whether you are using KDE3, KDE4, or Gnome.

Also, in your post in the new thread, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/soundMany users mess up their alsa update, and forget to install the driver (alsa-driver-kmp-default or alsa-driver-kmp-pae as appropriate). Also, for the dv7 I think one needs to add “options snd-hda-intel enable_msi=1 model=hp-m4” to /etc/modprobe.d/sound. (I did not see the model option in your post).

So, I am on the same boat. I was trying to follow this thread from the begining to resolve my sound issue.

The issue - Sound doesn’t work in my laptop. Sound card is 82801H(ICH8 Fmaily) with SUSE 11.1. But before suse I have tried mandriva 2009 which could make the sound work without any problem.

System - Its a HP laptop. Model dv3005tx

Detailed debugging informetion -
ALSA information is located at http://www.alsa-project.org/db/?f=42f3ea9275c79f1da9e1591ee7f4d93dfe86c7f0


opensuse:~ # lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
opensuse:~ # head -n 1 /proc/asound/card0/codec*
==> /proc/asound/card0/codec#0 <==
Codec: IDT 92HD71B7X

==> /proc/asound/card0/codec#1 <==
Codec: LSI ID 1040
opensuse:~ # uname -a
Linux opensuse 2.6.27.7-9-pae #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux
opensuse:~ # cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=hp
opensuse:~ # rpm -qa | grep alsa
alsa-oss-1.0.17-1.37
alsa-devel-1.0.18-8.7
alsa-1.0.18-8.7
alsa-plugins-1.0.18-6.12
alsa-driver-kmp-pae-1.0.19.20090120_2.6.27.7_9.1-2.1
alsa-plugins-pulse-1.0.18-6.12
alsa-utils-1.0.18-6.4
opensuse:~ # rpm -qa | grep pulse
pulseaudio-module-gconf-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
libxine1-pulse-1.1.15-20.8
pulseaudio-module-x11-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6
alsa-plugins-pulse-1.0.18-6.12
libpulse-browse0-0.9.12-9.6
pulseaudio-module-zeroconf-0.9.12-9.6
pulseaudio-module-jack-0.9.12-9.6
libpulsecore4-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
pulseaudio-0.9.12-9.6
pulseaudio-module-lirc-0.9.12-9.6
libpulse0-0.9.12-9.6
opensuse:~ # rpm -q libasound2
libasound2-1.0.18-8.7

What I have tried -
I have tried everything discussed in this thread. I have updated the ALSA, chenged verious configurations like model=auto, model=ref etc.

Extra info -
Sound works in vista. And the codec is IDT high definition codec.

PLEASE start a new thread. By the way, it looks to me like you have a problem here:

You have mixed alsa-driver-kmp-pae install with a 11.1 alsa. That is almost certain to break your sound.

If you start a new thread, I’ll give you the zypper commands to fix this.

I have a generic 64-bit machine with an Intel ICH8 family integrated sound card. I found another person with the same type of setup and the same problem - no sound after clean installation of Opensuse 11.1. His solution worked for me - add “model=ref-no-jd” to the options line in /etc/modprobe.d/sound and reboot.