64bit openSUSE-12.1 KDE unable to connect wireless to different router

I am currently unable to connect my openSUSE-12.1 KDE wireless on my Dell Studio 1537 laptop to my portable Edimax 3G-6218N router. The KDE Network manager suggests an IP address is not being assigned and also suggests the authentication fails. I am also unable to delete the existing configuration in KDE network manager due to what appears to be a bug in KDE NetworkManager (at least when I press delete the ssid entry does not disappear).

The hardware on this router is:


04:00.0 Network controller [0280]: Intel Corporation Ultimate N WiFi Link 5300 [8086:4235]
        Subsystem: Intel Corporation Device [8086:1121]
        Kernel driver in use: iwlagn

I note my wife’s WinXP PC, my Asus Transformer Android 3.2.1 Tablet, and my wife’s iPod Touch 3G can all connect with no problems to this Edimax 3G-6218N router.

I note also that my Dell Studio 1537’s WiFi Link 5300 wireless can connect to the other wireless router in our home (a ‘permanent’ Speedport W920V wireless with no problem … I had a 24 hour solid wireless connection last night with the Speedport).

I also note I was able to connect to this Edimax 3G-6218N router a week ago with no problem. What has changed between now and then ?

  • I performed a firmware upgrade to the Edimax 3G-6218N (I was told to do this by manufacturer) and
  • I changed its channel from 11 to 8.
  • changed host name in Edimax router’s setup

I am suspicious that the host name change or channel change ‘may have caused’ the problem but I do not know enough about wireless to pursue that speculation (which may be completely irrelevant, being speculation). I had to change the channel because I could not see the router on Channel 11 (with my Dell) due to a strong signal from the neighbour’s wireless.

Here is some content from dmesg, where the initial failed wireless connections are with the “Edimax-rijira” (which is the Edimax 3G-6218N router) and the final successful wireless connection at ‘245’ is the “rijira” SSID with the Speedport.


========= dmesg ===============
   12.776512] iwlagn 0000:04:00.0: device EEPROM VER=0x120, CALIB=0x4
   12.776515] iwlagn 0000:04:00.0: Device SKU: 0Xf0
   12.776528] iwlagn 0000:04:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
..............
   12.868198] iwlagn 0000:04:00.0: loaded firmware version 8.83.5.1 build 33692
............
   38.071914] iwlagn 0000:04:00.0: L1 Enabled; Disabling L0S
   38.080962] iwlagn 0000:04:00.0: Radio type=0x0-0x2-0x0
....
   38.277952] iwlagn 0000:04:00.0: L1 Enabled; Disabling L0S
   38.281183] iwlagn 0000:04:00.0: Radio type=0x0-0x2-0x0
   38.324677] ADDRCONF(NETDEV_UP): wlan0: link is not ready
........
   38.430273] ADDRCONF(NETDEV_UP): eth0: link is not ready
..........
..........
   97.137740] wlan0: authenticate with 00:1f:1f:fa:04:51 (try 1)
   97.139469] wlan0: authenticated
   97.146902] wlan0: associate with 00:1f:1f:fa:04:51 (try 1)
   97.150178] wlan0: RX AssocResp from 00:1f:1f:fa:04:51 (capab=0x411 status=0 aid=2)
   97.150182] wlan0: associated
   97.160427] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
   97.165897] wlan0: disassociated from 00:1f:1f:fa:04:51 (Reason: 14)
   97.172647] cfg80211: Calling CRDA to update world regulatory domain
   97.172704] wlan0: deauthenticating from 00:1f:1f:fa:04:51 by local choice (reason=3)
   97.176271] cfg80211: World regulatory domain updated:
   97.176274] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
   97.176276] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
   97.176279] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
   97.176281] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
   97.176283] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
   97.176285] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
..............
  103.996338] wlan0: authenticate with 00:1f:1f:fa:04:51 (try 1)
  103.998272] wlan0: authenticated
  104.000680] wlan0: associate with 00:1f:1f:fa:04:51 (try 1)
  104.004707] wlan0: RX ReassocResp from 00:1f:1f:fa:04:51 (capab=0x411 status=0 aid=2)
  104.004710] wlan0: associated
  104.022107] wlan0: disassociated from 00:1f:1f:fa:04:51 (Reason: 14)
  104.050568] cfg80211: Calling CRDA to update world regulatory domain
  104.050635] wlan0: deauthenticating from 00:1f:1f:fa:04:51 by local choice (reason=3)
..............
  107.374872] wlan0: authenticate with 00:1f:1f:fa:04:51 (try 1)
  107.376623] wlan0: authenticated
  107.378942] wlan0: associate with 00:1f:1f:fa:04:51 (try 1)
  107.382220] wlan0: RX ReassocResp from 00:1f:1f:fa:04:51 (capab=0x411 status=0 aid=2)
  107.382224] wlan0: associated
  107.395123] wlan0: disassociated from 00:1f:1f:fa:04:51 (Reason: 14)
  107.411927] cfg80211: Calling CRDA to update world regulatory domain
  107.411965] wlan0: deauthenticating from 00:1f:1f:fa:04:51 by local choice (reason=3)
.............
  117.468086] wlan0: authenticate with 00:1f:1f:fa:04:51 (try 1)
  117.471518] wlan0: authenticated
  117.474524] wlan0: associate with 00:1f:1f:fa:04:51 (try 1)
  117.477859] wlan0: RX ReassocResp from 00:1f:1f:fa:04:51 (capab=0x411 status=0 aid=2)
  117.477862] wlan0: associated
  117.488706] wlan0: disassociated from 00:1f:1f:fa:04:51 (Reason: 14)
  117.506945] cfg80211: Calling CRDA to update world regulatory domain
  117.507032] wlan0: deauthenticating from 00:1f:1f:fa:04:51 by local choice (reason=3)
..........................
..........................
  245.673477] wlan0: authenticate with bc:05:43:5f:0e:cd (try 1)
  245.676450] wlan0: authenticated
  245.683042] wlan0: associate with bc:05:43:5f:0e:cd (try 1)
  245.685968] wlan0: RX AssocResp from bc:05:43:5f:0e:cd (capab=0x431 status=0 aid=2)
  245.685971] wlan0: associated
.........
  266.376859] iwlagn 0000:04:00.0: Tx aggregation enabled on ra = bc:05:43:5f:0e:cd tid = 0
=======================================

Here is a pix showing the wireless connections in our area … where the 2 strongest signals are the two wireless in our appartment on channel 1 and channel 8.

http://thumbnails38.imagebam.com/16259/6d896a162584139.jpg](http://www.imagebam.com/image/6d896a162584139)

Here is a pix showing the state that I get in Network manager (it does not go beyond this)

http://thumbnails51.imagebam.com/16259/3ba7f1162584150.jpg](http://www.imagebam.com/image/3ba7f1162584150)

Here is a pix show some more details, … note no ip address assigned and authentication not completing …

http://thumbnails28.imagebam.com/16259/09a608162584148.jpg](http://www.imagebam.com/image/09a608162584148)

Again, wireless works well with openSUSE-12.1 and this hardware with the other (2nd router - a Speedport) in our apartment. And 3 other device can connect to the Edimax with no problem.

The ‘Edimax’ is a portable router, that I wish to take with my wife and I when traveling, so I would like to get this working.

Thank you in advance for any suggestions/help.

I’m bad. That should read:

The hardware on this PC with the problem is:


04:00.0 Network controller [0280]: Intel Corporation Ultimate N WiFi Link 5300 [8086:4235]
        Subsystem: Intel Corporation Device [8086:1121]
        Kernel driver in use: iwlagn

On 12/03/2011 08:46 AM, oldcpu wrote:

> I also note I was able to connect to this Edimax 3G-6218N router a week
> ago with no problem. What has changed between now and then ?
>
> - I performed a firmware upgrade to the Edimax 3G-6218N (I was told
> to do this by manufacturer) and
> - I changed its channel from 11 to 8.
> - changed host name in Edimax router’s setup

Changing the ESSID (name) should not cause any difficulty as it is broadcast
with every beacon, unless the new name is “strange”. The name “Edimax-rijura” is
not strange and should work.

Changing channel won’t cause any problems either, except that 8 is not a good
choice as it interferes with both “clear” channels 6 and 11. From the picture, I
can see why you chose 8, but remember, those signals are not really parabolas,
but more like a mesa. Yow will see your neighbor’s stong signal on channel 11.
The signal for b/g wifi is at least 20 MHz wide, while the channels are spaced
at 5 MHz. Thus only 1, 6, and 11 will not interfere with each other. Of course,
there a at least 5 other APs in your neighborhood that are similarly misconfigured.

If it were not for the fact that other devices can associate with the Edimax, I
would suspect that the new firmware for the Edimax has a different bug than the
one they were fixing. Your system disassociated for reason 14, which is a MIC
failure. In plain language, that means that the router is not handling the WPA
or WPA2 encryption correctly. The secret is correct as it authenticated OK, but
then failed when your system tried to receive encrypted data.

> Here is a pix showing the state that I get in Network manager (it does
> not go beyond this)
>
> ‘[image: http://thumbnails51.imagebam.com/16259/3ba7f1162584150.jpg]’
> (http://www.imagebam.com/image/3ba7f1162584150)

There is a bug in the current NM that prevents it from displaying the window
requesting the root password when authentication fails. That little key in the
NM applet says that is what is happening here.

> The ‘Edimax’ is a portable router, that I wish to take with my wife and
> I when traveling, so I would like to get this working.

It appears that there is some kind of incompatibility between iwlagn and the
Edimax. What are the OS, version, and hardware on the 3 systems that can connect
to the Edimax? If they include recent Linux versions, then that would indicate a
problem with iwlagn.

It is likely that the only way to debug this would be to capture the actual
traffic in the air using Wireshark using a second computer.

For travel purposes, does it work with WEP encryption, or if you switch from WPA
to WPA2?

ok problem solved … and I do think this was a KDE network manager bug ( ? ) possibly with finger trouble on my part.

Since I was suspicious of a configuration problem, where I felt KDE’s Networkmanger GUI was not working properly (it would not let me delete) I took a look at the directory /etc/NetworkManager/system-connections and noted a text file for each SSID that I had connected to. Inside those files, for the authentication, it had a rather complex file name of a bizarre random ( ? ) number.

I also noted inside the directory /home/oldcpu/.kde4/share/apps/networkmanagement/secrets/ and it had authentication files of the same number (as noted inside the files in /etc/NetworkManager/system-connections) associated with each of the various ssid’s that I had connected to. I noted for my ‘Edimax-rijira’ SSID, it had the WRONG password. I know I had entered the password correct many times, but it was NOT being applied by the KDE gui.

So since this was a text file, and since the password was not encrypted, I simply changed the password in the text file, saved the change, and then I was able to connect to the wireless.

This is IMHO a crazy problem and a crazy solution, but it appears to work now.

Immediate problem SOLVED.

Am I the only one to encounter this in KDE ?

thanks for that. Educational !

That was a great hint ! thanks.

Another golden tidbit. ! Also thanks.

I did not get to test this, but I’m guessing it would have also shed light on the problem.

As I noted , for some reason my old password (the one for ‘rijira’ ) was being applied to ‘Edimax-rijira’ . I may have entered the ‘rijira’ password the first time for ‘Edimax-rjira’ and then corrected it later, and it appears my corrections were never applied.

So it was an authentication problem. …

MANY THANKS for your timely post.

Its user’s like yourself who make this forum , and this openSUSE GNU/Linux distribution, great.

On 12/03/2011 11:46 AM, oldcpu wrote:
>
> I did not get to test this, but I’m guessing it would have also shed
> light on the problem.
>
> As I noted , for some reason my old password (the one for ‘rijira’ )
> was being applied to ‘Edimax-rijira’ . I may have entered the ‘rijira’
> password the first time for ‘Edimax-rjira’ and then corrected it later,
> and it appears my corrections were never applied.
>
> So it was an authentication problem. …
>
> MANY THANKS for your timely post.
>
> Its user’s like yourself who make this forum , and this openSUSE
> GNU/Linux distribution, great.

Thanks for the compliment, and I’m glad you got it sorted out. I also hope the
NM bug will be fixed soon. (https://bugzilla.novell.com/show_bug.cgi?id=727857)

If you are interested, I posted the output of a spectrum analyzer at
http://susepaste.org/39448297. There are 8 APs that show up in an ‘iwlist scan’.
Three are mine and strong: (1) a b/g device (20 MHz channels) on ch. 1, (2) an
802.11n device (40 MHz ch.) on channel 3, and (3) a b/g AP on ch. 11.

Yes, I know that channel 3 is not correct, but 6 and 11 are quite busy in my
neighborhood, and #3 is the lowest you can place a 40 MHz channel.

Thanks for the bug report link.

Most interesting !

Just for the record
No, I have not experienced this.
12.1 kde and also with iwlagn and WPA2

Glad to read that ! … The hiccup I encountered is not a hiccup I would wish on anyone.

… but its working now , and its great having this small Edimax 3G-6218N router. It means anywhere in the world where we can get a sim compatible with our current 3G Huawei K3520 modem, we can plug it in to the Edimax 3G-6218N router and we have internet access (assuming we are in an area with 3G coverage). Or if in a country with different 3G frequencies, simply purchase a new 3G USB modem (which tend to be very inexpensive) and plug it in to this router.

… if visiting a hotel or friend’s place, where they only have one wired connection, we plug that into the router, and create our in WAN for both my wife and myself (and any family members with us) for our wireless devices.

… or if visiting a restaurant, in a train station, or other place, we have immediate internet access for my wife’s iPod and my Asus Transformer.

Granted that this small mobile USB router with its 3G USB modem (together about the size of a blackberry phone) are not as small as integrated 3G in a device, but still they are small, and given with this router we can all share the one 3G device, does mean we keep down our costs for the 3G connection (where such costs can ‘add up’ if one is not careful).

I had a similar incident yesterday.

A changed of ISP resulting in a change of router.
Set new router to WPA2 (different SSID but same password as old router) and somehow doesn’t worked as preferred. Changed new router setting to WPA and a bunch of other settings e.g. upgrade router firmware and switching channels while testing the connection.

All this while my computers running openSUSE/Debian is having intermittent performance (drop connection during WPA2) and later in WPA connected (according to NM with ip address) but couldn’t access the internet.

10+ hours later with many try and error, my wife comes home and starts her Debian (KDE) desktop and everything strangely seems to work perfectly. I suddenly released that her Debian is managed by WICD instead of NetworkManager.

I replaced NetworkManager in my Debian laptop with WICD and everything works.

Replaced NetworkManager in my openSUSE laptop with WICD but WICD shows same sympton as NetworkManager.
Googled and found this post. Located and deleted all the previous connection (/etc/NetworkManager/system-connections) details.

Reconnected with NetworkManager as usual and working till now for 10+ hours.

Oldcpu, thanks for sharing the info, else I wouldn’t have got much sleep.

Question, NetworkManager’s bug since it exist across openSUSE and Debian?

Great info oldcpu. I have been thinking for long to install linux, however got a chance to install only recently.

Initially internet worked but then suddenly it stopped working, dont recall what activity i was performing. However your tip helped. For me the file to be changed was in the system-connections folder itself. It had my root password for some reason. I changed it to the WPA password and all starts working…

great pointer.