64 bit Flash

I just installed the 11.2 RC today and was wondering how to install the 64 bit flash plugin to Firefox?

Any help would be greatly appreciated!

su terminal

zypper in flash-player nspluginwrapper

Make sure you have an internet connection. Next, start up Yast and select Software Management. Once it starts up, select Installation Summary tab.

You should have Flash and a host of other software to install.
Click on the Accept button and it will install Flash.

Good Luck!


It works perfectly!!

Excellent news;)

This installs the 32 bit version of flash-player. If you do

zypper if flash-player

it will say ‘Arch: i586’

If this installed the 64 bit version, there would be no need for nspluginwrapper.

Dude. I know. If the OP wants to go outside the official repo’s we can do that also. Or is a _64 player included in 11.2?

pilotgi wrote:

> This installs the 32 bit version of flash-player.

yes, your right, but there is no final release of adobes flash player for
linux x86-64 architecture afaik
but there is beta that anybody can manually install…

Just for clarity. The zypper command posted by @pilotgi
zypper if flash-player is Not correct.

zypper in flash-player nspluginwrapper
was correct.

Zypper/Usage/11.1 - openSUSE

The ‘if’ option gives you information about a particular package. I was just saying that ‘zypper if flash-player’ gives you the info about that package, such as the architecture.

Correct. It wasn’t clear though. Sorry. I wasn’t being picky.:):slight_smile:

Disregarding all the nonsense posted by caf4926, if you want to install the 64-bit version of flash then you can try the rpm’s at Index of /repositories/home:/Grieff/openSUSE_11.2 (1-click install through Software.openSUSE.org : search flash and scroll down). I haven’t tried installing it using those particular rpm’s, but i’ve done it manually. To install the 64-bit plugin manually i know there is a previous thread in these forums somewhere.

Nonsense eh! So much so that the OP declared the matter solved in post #4.

There is beta 64 bit software available which we have to install manually. I didn’t use the rpm way yet, but always following this tutorial(mine) to install with one line command.
Programming and Linux: Install Flash 64bit in Linux

I installed it manually because i don’t want any of 32bit software and with 32bit libraries to use and install. Just want to use clean 64bit.

There’s at least one openSUSE contributor delivering 64bit flashplayer rpms:
Index of /repositories/home:/Grieff/openSUSE_11.2
It’s available through one-click install via Software.openSUSE.org