64 bit chromium anyone?

I compiled a 64 bit chromium for everyone to use, unfortunatelly i have no idea how to put it in an rpm file. I do know that flash works, for ad blocking is AdSweep and it is fast like hell :slight_smile:

P.S. AdSweep doesn’t block adds, it hides them (at least the developer of it says so).

P.S.2 Flash plugin (64 bit) works fine, i could watch youtube.com with no problems. As for now i’m using google chrome full time since after i tasted it i now dislike firefox for being so slow…

P.S.3 The 64 bit flash player is included (newest one).

Installation instructions:

Unpack it,
tar -xf google-chrome.tar.gz

, put the chrome folder anywhere you like for example /home/<user>/,

then move the desktop file to usr/share/applications/ directory by issuing command:

sudo mv Google\ Chrome.desktop /usr/share/applications/

After that you need to create a symlink to that chrome executable file by issuing a command

ln -s /directory where chrome is/chrome/chrome /home/<user>/bin

After that you can test out the newest chromium release and be amazed by it’s speed :slight_smile:

P.S.4 Moving from 32 to 64 bit i noticed 10% speed increase in benchmarks on peacekeeper.



Also, if you also want to enable extensions you need to edit the Google Chrome.desktop file and add --enable-extensions to the right from --enable-plugins

Mind that some extensions might slow down the browser.

If chrome doesn’t start then you probably need to install some libraries and in that case open terminal where the chrome executable is and start it by ./chrome and watch for messages.

If it for example says gconf2-so.0 : No such file or directory you need to open Software Management type the exact message of what you are missing in search window and below that tick “RPM “Provides”” and “File list”. And install that file.

There’s a x86_64 rpm here:

I’ll install and test it right away

Mine is 4.0.203 (by mine i mean compiled by me :wink: ) and boy did it compile A LOT even on a quad core lol!

By the way, this version uses now native 64 bit libraries and that’s why i wanted to share with people :slight_smile:

No more 32 bit dependencies, google rewrote their V8 JavaScript to 64 bit.

By the way it’s for openSUSE 11.1

I don’t know how it will behave on 11.2.

Onya Bendy, it works on my system :D.

I just uncompressed it into my ~/me/Apps/ folder and ran it from there, fired straight up and asked to import my Firefox bookmarks and stuff.

Well done :wink:

I’m glad to hear it :slight_smile:

I’ll be posting new versions every 1 or 2 days (it’s from a svn repo, the ubuntu’s ppa is 2 weeks behind it unfortunatelly).

P.S. Could you comment on speed? Does it work as fast on your PC as on mine? For me it starts in half a second, rendering is also faster and gmail is a lot smoother than on firefox. How about you? Now i wonder if the vlc plugins will work with it, i’ll create a symlink to /usr/lib64/browser-plugins and i’ll test it out later :slight_smile:

Yes, it’s mega-fast, way faster than FF. It starts in about 2 seconds (FF about 8!), and closes almost instantly (FF 10 seconds).

I don’t get any youtube video though, although I don’t think I have 64bit flash installed. I’ll look into getting that working tomorrow, I’m off to bed now :).

In cases i didn’t have a video in YouTube simple refresh helped :slight_smile:

I got it working, I just had to edit the .desktop file and add my path (as you said in the first post!).

All working nicely here, now I’m really off to bed, thanks again :).

Have a good night :slight_smile:

Anyone else tried it? Tell us about your experience :slight_smile:

well i’m having a problem with it i get this error after telling it to import firefox settings
[10727:10727:2115127660:FATAL:app/gfx/font_skia.cc(90)] Check failed: tf. Could not find font: Adobe New Century Schoolbook
Trace/breakpoint trap
And when i delete the chrome.destop in usr share apps and delete the exracted files and redo it according to your instructions i still get the same error and it dont even ask to import firefox settings it just throughs up that error which i know what it is it cant find my font i use in firefox but why after deleting it and reduing the instructions does it keep giving me the error?
so how to totally get rid of it and redo it?
i was really wanting to try this out

Try importing stuff later. You don’t need to import them straight away. You can import one thing at a time. Where is this font?

Try unpacking it into your home directory and running it from there. But use the terminal to launch it by cd-ing to the chrome dir and typing - ./chrome.

In my case I unpacked it into ~/Apps, and would do this -

cd ~/Apps/google-chrome/chrome

See if that makes a difference.

I just installed it. Took me around two minutes and I didn’t even have to think. I just copied and pasted, lol.

Works great so far. Youtube does work but I am having some flash issues with Hulu, says I need to install it.

Importing for me worked great. It grabbed my log in info, passwords, bookmarks,etc from Firefox. I am using Chrome right now to post this reply.

Thanks for this Bender. (Being a Futurama fan I never thought I would say those words, lol.)

You wouldn’t steal chrome would you :wink: ??

I’m also a BIG BIG fan of futurama :slight_smile:

I’m happy that it works for most of You :slight_smile:

P.S. Hmm hulu works for me fine :slight_smile: If flash doesn’t work on the first go then try to refresh the site.

ok heres where i put the files and unpacked them
and followed your instructions
then ran from terminal in that dir and thats the error i get all the time now even if i delete it and redo it so how do i totally get rid of it now to try it out again without getting that error so it thinks it is the first time it is ran again?

the fonts should be wherever the fonts are installed on the system
sometimes i just feel like a noooooob lol

Chromium must keep a hidden folder somewhere, although I can’t seem to find it. Maybe Bender can help out with that one.

Plus I think KDE4 uses a local copy of fonts, not necessarily the system-wide ones, although I’m just guessing there :).