56k usb modem configuration

Hi, i’m using suse 11.
Got a 56k USB modem Us robotics (5637) that’s supposed to be configured without any problem under linux (at least that’s what they say!).
The modem is indeed detected, but there-s is no way yast can configure it : it’s under ttyACM0.
I did lsusb to check : ok
then lsmod to see wheteher cdc_acm was there : it is !
modprobe cdc_acm to activate the module
did mknod /dev/ttyACM0 c 166 0 to create a node
All this to no avail !!!
Any idea ?4Thanks alot !!!

Try making the soft link (as toot):

ln -sf /dev/ttyACM0 /dev/modem

Now it should be possible to configure via yast.

Hi, Thanks for the reply.
Unfortunatly I still cannot configure the modem with yast, there must be something strange going on with yast as the modem is perfectly detected, I even can have it work with minicom (then I cannot get firefox to connect to the web, but that’s another story).
I’m really at a loss, why yast wouldn’t configure that modem ?
Any idea ?

it doesn’t help you, but this modem was plug and play in an ASUS, (with linux)

EeeUser ASUS Eee PC Forum / MODEM:Dialup Slowband only option !

is anything of swerdna’s post of use to you?

Wireless broadband in Suse/openSUSE for Bigpond Next G Network (HSDPA-enabled bp3-usb)

a bit of homework here for you …

Are you using KDE desktop. Try configuring via kppp. Refer this how to.

Hello mahanand,

I have a usb 56k modem, too. I used YaST to set it up. It is also /dev/ttyACM0.

The one thing I make sure is set the baud rate to 38400. I used to set it at 57600 (not sure of exact number) but found I get a connection each and every time, and I also get a faster connection using this lower baud rate. Some will say use 115200 baud rate, as most modems can use this speed, but I found lower baud rate=faster surfing. Enough said there.

Did you leave the default, “Enable device control for non-root user” ticked under modem parameter details? I also have the it set to “automatically” for “how interface should be set up”. And all except dial on demand are ticked. Firefwall and “ignore prompts” are not ticked. IP details shows dynamic address ticked.

Does your modem dial out at all? Mine did, but I couldn’t ping.

I usually have to use kppp to use my modem. I use it in one other disrto. Happily, I am able to use Kinternet with openSUSE.

Not sure if this will help, especially if your modem isn’t dialing out. How I got my multi-tech modem to work:
SOLVED: kinternet - no name server found w/ dial-up - openSUSE Forums

I finally managed to have the modem dial out, and get a connection established. But as soon as pppd comes in, the connection is turned off !!!
Login and password are ok. What is going on ?

(1) You setup the modem through Yast - it is easy. If you don’t find your provider, create a new one.
(2) From the GUI (KDE), start kinternet. Right click on the icon and select the option “View Log”. This will show a log of what is happening in a separate window.
(3) Now dial by clicking on the kinternet icon. (If you have multiple modems or providers, you have to select the appropriate ones before dialing. You can do it by right-clicking it).

Now, post the log that comes up in the log window here.
Also, post the content of /ets/sysconfig/network/ifcfg-modem0 and /etc/sysconfig/network/providers/provider0

IMPORTANT: If you are saving your dial-up password, it will be in provider0. So, mask it out when you post it here.