5 Things to GET MY New KDE Working Better?

Thanks for looking, and yes I am a new KDE user … giving it a serious try! now back to my problems and our solutions …

1/ How can I change my font size through compiz.or KDE,
I had simply needed to restart the programs for the effects to take place.

  • related
    How can I get a menu that someone else has? The drop down menu seems very confusing and hard to navigate. I have both “App’n Launcher, and App’n Launcher Menu” from the add widget list.
  • I would love to see a simple path like was stated earlier to me. i.e.
  • "System Settings > Appearance > Fonts, …

partially SOLVED!

2/ Why is my Auto-Hide Panel hesitating. or not even responding until I move to a different workspace?

  • still a hassle!!,

3/ How to Get the cool tux pointer in KDE?
-NOT SOLVED!, though not serious.

4/ How to get avi files that require windows media player, to play?

  • I followed the media guide which I already had, Though after all my changes a few things needed re-installation, but still NOT SOLVED!
  • it seems I need a Windows Media equivalent, for it’s specific format files, even though they are .avi files. My other avi files had, and are running fine.

5/ How to create shortcuts that work in cairo-dock?

  • OK, as an alternative, I am trying Fancy Tasks, and it looks promising, But it is huge and I can’t seem to find a way to resize other than the typical settings way and it is way to huge for me.

6/ How to Safely upgrade Compiz to 8.x.x?

  • I Ok I followed the guide as I did before and it has not caused any problems, having required the X11:XGL repository. Should I keep it enabled or am asking for trouble?

THANX for anyone helping!!

Have you tried VLC Media Player? This plays most AVI files that I’ve chucked at it so far. Failing this (and assuming you’ve got all the codecs outlined in the media guide, including the w32codec-all package) you could try installing MediaInfo (command line version preferably), then open a terminal window, type the following and report back:

mediainfo video.name

(N.B. Replace video.name with the name/location of the video, remembering to place it in double quotes if there are any illegal characters such as a space. If in doubt just use the double quotes anyway to be sure.)

Hope this helps.



OK so I did as you ask, and have figured out that even though they are avi files, your program recognizes them as wmv? files, here is the output. Does this help narrow down a solution?

and problem #7
7/ I can’t get Avant Window Navigator to install, either in Gnome or KDE. I have tried the 1-click, and it fails. Is there something I am doing wrong with repositories? or are there some dependencies, and if so why doesn’t it tell me whats missing?

I have even tried to download and install the rpm package from packman. It gives me a dependency error:
libawn.so.0()(64bit) and libgnome-desktop-2.so.7()(64bit) are missing, and I don’t know how to install them!, arghhhhhh

well here is the avi file info

Complete name : /home/ack/Download/Daybreakers (2010)/Daybreakers (2010).avi
Format : Windows Media
File size : 684 MiB
Duration : 4s 47ms
Overall bit rate mode : Constant
Overall bit rate : 1 418 Mbps
Maximum Overall bit rate : 3 155 Kbps
Encoded date : UTC 2009-04-25 22:25:24.620
Writing application : 6.0.6000.16386 / Windows Movie Maker
Application : Windows Movie Maker 6.0.6000.16386
AspectRatioX : 720
AspectRatioY : 640

ID : 2
Format : VC-1
Format profile : MP@ML
Codec ID : WMV3
Codec ID/Info : Windows Media Video 9
Codec ID/Hint : WMV3
Description of the codec : Windows Media Video 9 - Professional
Duration : 4s 33ms
Bit rate mode : Constant
Bit rate : 3 000 Kbps
Width : 720 pixels
Height : 480 pixels
Display aspect ratio : 1.500
Frame rate : 29.970 fps
Standard : NTSC
Resolution : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.290
Stream size : 1.44 MiB (0%)
Language : English (US)

ID : 1
Format : WMA
Format version : Version 2
Codec ID : 161
Codec ID/Info : Windows Media Audio
Description of the codec : Windows Media Audio 9.2 - 128 kbps, 48 kHz, stereo (A/V) 1-pass CBR
Duration : 4s 47ms
Bit rate mode : Constant
Bit rate : 128 Kbps
Channel(s) : 2 channels
Sampling rate : 48.0 KHz
Resolution : 16 bits
Stream size : 63.2 KiB (0%)
Language : English (US)

I notice that this video appears to have been encoded using Windows Movie Maker, which is probably why you can’t play it owing to the proprietary nature of the codec.

It’s not ideal for some people, but you could try converting the video into a playable format with something like ffmpeg or HandBrake if you know what you’re doing; if, that is, they actually support the WMV codec, I’m not too sure. These should be available in YaST (open the Kickoff menu > Applications > System > Administrator Settings, enter your password, then choose ‘Software Management’) under the Packman repository if you have it (refer to ‘Software Repositories’ under YaST if in doubt).

Searching in YaST may also help with your missing dependencies regarding Avant, although I cannot guarantee that they will be there. If you still have problems after trying all of this there’s probably not much more I can do myself as my experience with openSUSE only stretches so far. In this instance perhaps one of the more experienced users such as oldcpu or caf4926 could offer some help with this.

Hope this helps.




It would also be beneficial for us to know which version of openSUSE you’re using and which version of KDE you’re using. Also, just to be safe could you please open up a terminal (alt+f2 then search konsole)and copy and paste the output of:

zypper lr -d

Take Care,


I have done a complete re-install with a Suse KDE disk to see if it would help, and am struggling to get it functional. here is my repository list and I am a bit too tired to go into detail right now but will in 12 hours or so …

1 | Compiz | Compiz | Yes | Yes | 99 | rpm-md | Index of /repositories/X11:/XGL/openSUSE_11.2 |
2 | Gnome_Community | Gnome Community | Yes | Yes | 99 | rpm-md | Index of /repositories/GNOME:/Community/openSUSE_11.2 |
3 | KDE4-Stable | KDE4-Stable | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2 |
4 | KDE_Backports,_updates_to_Amarok_and_other_KDE_Applications | KDE Backports, updates to Amarok and other KDE Applications | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Backports/openSUSE_11.2 |
5 | Nvidia | Nvidia | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/11.2/ |
6 | download.opensuse.org-Community | openSUSE BuildService - KDE:KDE4:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2 |
7 | download.videolan.org-SuSE | VideoLan Repository | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.2/ |
8 | ftp.skynet.be-suse | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.2 |
9 | home:dmitry_serpokryl:Enlightenment-cvs-core-metapackage&_Wicd | home:dmitry_serpokryl:Enlightenment-cvs-core-metapackage& Wicd | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/dmitry_serpokryl:/Enlightenment-cvs-core-metapackage/openSUSE_11.2 |
10 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
11 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
12 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |

I’d like to be short:

Kicker menu can be changed to classic menu style.

The panel: did you install 3D support for your videocard?

Tux pointer? Don’t know that one.

On avi files: open the software installer. You should have the Packman repo active. Select it from the repo view, above the right pane, click “Switch system packages…”, Accept. On my systems any avi plays.
There is something strange about the mediainfo, take a look at the duration. BTW, did this avi come to you in a legal way???

Pick the classic menustyle and learn how to use kmenuedit.

In general: Please first get to know your way around in KDE4. The way you’re doing things now, will absolutely lead to a non standard situation, making it hard to see how things should have been if you get into trouble.
And: why compiz on KDE4? kWin does the desktopeffects fast and reliable.

Your first mistake is that you have packman and videolan repositories both active. Most likely, you have some dependency issues between the two as the both hold multimedia codecs and they have a tendency to mix packages which causes a lot of problems.

So, Change your Videolan repository to what I have shown above (which is disabled) since the only thing you need from this repository is the libdvdcss package to play DVDs.

Then open up Yast Software Management and change the filter from Search to Repositories. Click on your packman repository and then right above all the packages there’s an option to switch all system packages to Packman. Click that and it will make sure all your codecs are from packman.

That should get rid of your multimedia problem, as with this method even kaffeine should be able to play nearly any file.

As for Compiz, I agree with Knurpht, you really don’t need it with KDE4. But if you choose to use it, then you should keep the repository enabled and set to autorefresh as you already have it, so basically just leave it alone. That way if there are any changes you’ll get them.

Take Care,


well, thanks for all the thoughtful help,

but this test had to stop at some time because the 2 desktops did not like living together, and KDE was just giving me way too much trouble with inconsistent fonts (in certain programs, wayyyy tooo small),-perhaps compiz related, and I am addicted to the expo function with my multi-tasking,
-the dock is a deal breaker perhaps with openSuse totally
(still trying it with my present attempt at an all Gnome build)

-but the forums sure make me want to stick with Suse

tired after another all nighter … Thanks