5.1 system does not work

Hi all.

I’ve just plugged a 5.1 system to my computer instead of an older 2.1.
Instead of 5 channels only 2 work. The volume control shows only “front right” and “front left” as output devices.

Alsamixer shows only “Master” and “Capture”.

I also tried Yast->sound->other->volume and enabled surround, with no change.

How can I get a real 5.1 sound with suse11.1?
My card is : 82801I (ICH9 Family) HD Audio Controller


I have a surround sound system (5.1) but I’m by no stretch an expert in it … more like a beginner, as I have only a couple of tracks that use the 5.1 surround sound.

I documented my experience here: Exploring surround sound in Linux - openSUSE Forums

If you think this is a configuration problem on your PC then we need more information in which to look at this. …

In that case, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole


Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a detailed recommendation.

If using gnome, note here is a graphical front end/mixer called “alsamixergui” that you can install (it is in the nominal OSS repository, or on your DVD if you installed via DVD).

Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.

Thank you for your reply.

  1. I do suspect it is a configurational problem.
  2. Alsa was upgrade with the script you told me about.
    3)Here is the URL:
    4)The remaining information is found at

Thanks for your help

Interesting. I note a 64-bit openSUSE-11.1 with the kernel and the basic 1.0.17/1.0.18 version of alsa that is packaged with openSUSE. Your PC’s is a Gigabyte EP35-DS3L with an ALC888 hardware audio codec.

Note that for the basic kernel (and also the previous versions up to the kernel) the alsa sound driver is included in the kernel and is approximately 1.0.18 of alsa (possibly a 1.0.18 RC version - I’m not certain of the exact alsa content in the kernel). Hence the 1.0.17/1.0.18 alsa packages you listed are support packages to what is in the kernel.

In the case of alsa driver, which is a kernel module loaded upon boot, it is possible to force a different model configuration. From 1.0.18 alsa’s alsa-configuration.txt file, I note this list of different model configurations (which where applicable may be applied one at a time): pastebin - alc888 models for 1.0.18 alsa - post number 1589573

If one also does a search on the alsa web site for the ALC888 one obtains this: Search results - AlsaProject where it is clear there were various updates to the alc888 between 1.0.18 and the current 1.0.21 of alsa.

If one looks at the HD-Audio-Models.txt file for 1.0.21 of alsa (where that file replaces the alsa-configuration.txt file’s relevant models) one will see this list: pastebin - alc888 models for 1.0.21 of alsa - post number 1589576

Clearly there have been a lot of model definitions added between 1.0.18 and 1.0.21 of alsa to the ALC888.

Hence I recommend rather than mess around with applying the 1.0.18 model options to your sound configuration, you instead update to 1.0.21 of alsa, and see if its auto probe (upon boot) works any better. And if it does not work any better, then and only then start applying different model options to force the alsa configuration upon boot. (One of the applications to update will be alsa-driver-kmp-default which will replace the alsa driver kernel module).

There is guidance here for updating alsa (where one must send six zypper commands to update from the internet): Alsa-update - openSUSE

In your case please send the following six commands to update your user space for alsa (from a terminal with root permissions, in sequence, one at a time, with your pc connected to the internet):

zypper ar http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.1/ multimedia
zypper install alsa alsa-docs libasound2 alsa-plugins alsa-oss-32bit alsa-utils alsa-plugins-pulse alsa-oss
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/ multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

then restart your pc to load the new alsa driver, and test your sound.

If that does not work then IMHO the choice is to either (or both) (1) update to the daily snapshot of alsa, or (2) apply one by one (restarting alsa after each application) the various model options for the ALC888. If it gets to that point, I can help you with the syntax needed for the /etc/modprobe.d/sound file.

Good luck.

Thank you for your time and help.

I ran all six lines in gnome terminal.
The sound test has strange outcome.

All input cables are connected to subwoofer.
I plugged one speaker at a time to each of the 5 subwoofer output terminals.
This is what I get:

speaker connected to front right terminal:

front left: faint
front right: loudly
center: not very loud
front left: very very faint
front right: faint

when the speaker is connected to any other terminal: no sound whatsoever!!!

Disconnecting the input wires from the subwoofer leaving only the “front” terminal plugged I hear (still connecting a single speaker)
front left
front right
rear left
read right
The “rear/front left” notifications are faint when the single speaker is connected to either rear right or front right output terminal while “rear\front right” notifications are loud.

connecting to “center” output terminal I hear all notifications more or less with the same volume level.

The front left output terminal gives nothing.

the rear left output terminal is just like the rear right terminal exchanging right notification with left notifications.


Just to be sure:
on 5.1 system I should hear the rear right notification coming only from rear right speaker. right?

I’m no expert on this, so I can NOT answer that question.

When I run

speaker-test -c6 -Dplug:surround51 -t wav -l1

I see this in the terminal

 0 - Front Left
 4 - Center
 1 - Front Right
 3 - Rear Right
 2 - Rear Left
 5 - LFE

But I hear this:

  • Front Left - 2 speakers (very faint woofer and strong front left)
  • FrontCenter - 2 speakers (very faint woofer and strong front center)
  • Front Right - 2 speakers (very faint woofer and strong front right)
  • Rear Right - 2 speakers (very faint woofer and strong rear right)
  • Rear Left - 2 speakers (very faint woofer and strong left right)

As for left,right,center being faint or not, it is ESSENTIAL one very carefully tune their mixer as in my case there were individual controls for most of the above (in kmix in KDE-3.5.10 in my case on openSUSE-11.1). After I moved up my appropriate volume levels for the speakers, the levels were reasonable.

Anyway, it does appear you have 5.1. surround sound working now. You just need to tune it.

Congratulations on your progress.