42.3 broke Oracle Virtual Box

I recently upgraded 42.2->42.3
I have been successfully running & recompiling vBox as new kernels were released an older Oracle version.
Recompile of Oracle vBox fails in 42.3

make KBUILD_VERBOSE=1 SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 CONFIG_MODULE_SIG= -C /lib/modules/4.4.76-1-default/build modules
make -C /usr/src/linux-4.4.76-1-obj/x86_64/default KBUILD_SRC=/usr/src/linux-4.4.76-1 \
-f /usr/src/linux-4.4.76-1/Makefile modules
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (        \
echo >&2;                            \
echo >&2 "  ERROR: Kernel configuration is invalid.";        \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";    \
echo >&2 ;                            \

There is a previous thread on this problem suggesting that I should remove the Oracle version and install the version in the 42.3 repo (currently shown as v5.1.24-22.1). The repo version is much newer than v5.0.16 that I currently am trying to recompile.

When I uninstall the Oracle version of vbox and install the repo version will it pick up the existing VM settings or will I have to recreate them for each VM?

Thanks, Jon

Do you try the 5.1.26 from Oracle?

I built 5.1.26 vs 42.3 here; http://download.opensuse.org/repositories/home:/Miuku:/VirtualBox/openSUSE_Leap_42.3/

Includes KMP etc. I’ll try to keep it up to date as VBox versions get released.


or will I have to recreate them for each VM?


VirtualBox is exactly the same software regardless whether you install if from Oracle or openSUSE.


Maybe you would have more success if you’d try to compile a current version?

While that’s nice of you of course, I don’t think it’s really necessary. The latest versions should get released as official updates anyway, and are available in the Virtualization repo too for the impatient.

Of course - I only did it for someone in iRC who was complaining “5.1.24 was too old” and wanted 5.1.26 for 42.3.

I’ll keep it up if someone has special requests (that can be filled using OBS, meaning no EXT package etc).

Thanks all who replied. I’ll start with uninstall Oracle & use the one at 42.3 repo.
I originally used the Oracle release because the openSuse repo was not updating vBox. It sounds like it may be kept updated as time goes on.

I did check Oracle forums and the info I found was that there is an issue compiling with 42.3 so I did not try it.


I have reading and tested, 2 of 3 PC s home here. There is as huge problem with 42,3 and Virtualbox littlle canin.Please be humble,


No, there is not.

At least if you use openSUSE’s virtualbox, haven’t tried Oracle’s myself (as there’s no need for that IMHO…).

Nein ,My 2 personal computers take ,22. …24 from repos, even after kernel latest but my server it doesent work, i can live whiouut a VB a day or 2, .-26 doesent eigher,

Still there is a problem with 42.3 and VirtualBox…


What do you have installed exactly?

rpm -qa | grep -ie "kernel|virtualbox"

What exactly does not work?

What does “systemctl status vboxdrv” say?

Still there is a problem with 42.3 and VirtualBox…

It sure works fine here on 2 systems…

Thanks again for the confirmation that the repo version works well. I uninstalled my Oracle version and installed the one in the 42.3 repo.
I had to download and install both the extensions and additions file from Oracle for v5.1.24 (if they are in the repo it was not clear to me which one they are).

It’s all working quite well now

Oh no W. Even the main developer in mailnlist yelling, not working a-o-k.


On Mon, 31 Jul 2017 23:06:01 +0000, jonte1 wrote:

> wolfi323;2832260 Wrote:
>> What do you have installed exactly?
>> >
> Code:
> --------------------
> > > rpm -qa | grep -ie “kernel|virtualbox”
> --------------------
>> >
>> >
>> What exactly does not work?
>> What does “systemctl status vboxdrv” say?
>> It sure works fine here on 2 systems…
> Oh no W. Even the main developer in mailnlist yelling, not working
> a-o-k.

Instead of arguing with someone who’s using it successfully, perhaps you
could provide the answers to the questions he’s asking so he can help you
resolve your issues.

Just a thought.

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Same here.

Then you need to post definitive information demonstrating this.

FWIW, the next Oracle version should work on 42.3 as well:

The extension pack cannot be shipped by openSUSE as it is proprietary, closed source software, and Oracle doesn’t even allow redistribution.
It’s also not included in Oracle’s RPM btw, and also has to be downloaded/installed separately when using Oracle’s version.

The guest additions ISO is probably omitted for space reasons, but it will be downloaded automatically if you choose “Insert Guest Additions CD” in the guest’s menu.

No, there is others in the forum and treads that have similar problems, -I was doing a fresh install at the time(to 42.3). That why I couldn’t attach any logs. Yupp I tried different kernels an repos as described.

But something I haven’t seen before. It went fast from the release (openSUSE 42.3) ver .22 to .24 and then .26. A hint. No I’m not using the Oracle version any longer.

What a freedom to be without e-mail for 4 days :P.