42.3 Booting to Blank Screen with Cursor

Hi all. One of my systems still running OpenSuse 42.3 is booting to a blank screen. It is an older PC still running some useful CAD software amongst other things. It is used intermittently. I have Googled on this quite a bit - but find myself still needing help. Importantly, I can boot to a command line and log in. Initially it was set up to auto-login. I located sddm.config and removed this setting. Immediately I found the login page - Plymouth? presenting itself. But any attempt to log in with user and password would cause a hang or lockup. Attempts to rename .kde4 did not have any affect. A clean up of the temp directory did not have any affect. The disk is not full.
What did work was creating another user and password and booting in to its home directory. I kept thinking I had a graphics driver problem, but the desktop worked ok for the new user. It had little use however as much software was not available. It was like a new install.

Any ideas where to look? The system is not broken imho. Something is stopping the desktop from starting as per normal.

Begin with identifying which Desktop you are using.

Sometimes what’s needed is to delete the content of ~/.cache/.

Hi again. Thanks for your suggestions. Still going on this.
Removing the contents of ~/.cache did not make any change.
Desktop is KDE Plasma Workspace, Windowmaker, and iceWM.

Despite my best efforts I am unable to log in. I can still login in as newuser - created for testing.

The file xsession-errors contains some interesting details, which looks like this - abbreviated.
Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyxrdb: Resource temporarily unavailable
xrdb: Cant open display ‘0:’

When googling about this I was directed to the bashrc file. But bashrc look unchanged. Most things are commented out except for the last line.

From the command line delete ~/.Xauthority - Then see if you’re able to login.

Tried removing .Xauthority.
When looking in /.local/share/sddm/xorg-session.log I get

timeout locking authority file ~/.Xauthority

In the home directory I see in the file

No protocol specified
xrdb: cant open display ‘:0’

What did work

Boot to init 3
run startx as root
Desktop boots

Are owner/group permissions/ownerships correct on your homedir and all the files it contains?

Yay! - success. Permissions were the stumbling block.

Earlier, I had not focused on permissions as I looked for a solution. When I did I saw glaring problems. Creating my test user in ncurses-Yast2 caused more problems than it solved. The new user became the default owner of my home directory. I needed full access for the default user in order to use my CAD software.

Anyway . . without dragging on. . . my problem with logging in started before the test user was created. Your suggestions all helped to resolve this. I made it harder when I created that test user.