3D Support not working in 11.1

openSUSE 11.1 - fglrx auf 64 Bit-Systemen - PC-Forum24.de

Thank you JanGerritJose, i had a bit of trouble translating from German, but i figured it out, this two lines of code solved my problem

rm /usr/lib/dri/fglrx_dri.so #wer
ln -s /usr/lib64/dri/fglrx_dri.so /usr/lib/dri/fglrx_dri.so

Now, just to setup mic and modem (maybe), and i can start fully enjoying suse on my laptop :slight_smile:

Sorry,banisha, I’m German and I tangled up the languages (?)

Nevermind, i learned German for one semester, and when i saw the webpage i realized how much i forgot :slight_smile:

I’m also having a bit of trouble with ATI drivers. I currently have the open radeonhd drivers at working order but I’m trying to switch over to the dark side (official ATI drivers). Now I have added the ATI repo to my Yast repo list but here it becomes tricky.

Should I just install the official driver on top of the closed ones or should I remove them first? And when i install the ATI drivers from the repo, then what? Will that do all the “aticonfig --initial” and “sax2 -r” stuff for me or do I have to fiddle around with them even when installing from yast. Simple questions really but I’d like to know before jumping “head first” to this.

The instructions on ATI - openSUSE
do not clarify if I have to do both “aticonfig” and sax2 -r" when installing from repos.

Hello Foresthill,
I’ve been having quit a time trying to get the ATI driver to work with 11.1, if ATI hasn’t created a drive sufficient for 11.1 it would be nice if they say so! As for me, I install the driver and get errors when I try to test the graphics driver, I also have no drivers in the box to select from! So far it hasn’t hosed up X to the point that I can’t login and use my computer but I am thinking of purchasing a seperate PCIe card and disabling the onboard graphics to see if this combination works better than the former. I wish I knew how to totally uninstall the driver, the directions say to go to this folder /usr/share/ati and run this command “sh ./fglrx-uninstall.sh” I’ve done this once before but I’m not so convinced if that completely removes everything. Any suggestions!

Hello Odintuho,
I can’t say either way, I’ve tried the Automatic, Custom, and Package Specific installs and had no luck with any of them, even though when I select graphics card and display in yast and it shows that 3D is enabled, I still get nothing on the desktop. When I try to test it I get a message telling me that at least one display has to be active! Also, when I open the Graphics and Display module in Yast and try to test and save I receive another error box, something about /var/X11R6/Xorg.conf.99.log or something to that affect. I think I’ll submit to not having any fancy effects, besides, I can still enjoy the Xpenguins!

If Yast doesn’t work for you to set up the displays then use the catalyst control center. ( under Other in application browser (Gnome))

:)Hello Silenuz,
I finally got the ATI drivers to work! I installed them in strict accordance to ATI’s instructions, ensuring every package required was installed with the correct version. I decided to install from the terminal by pressing Ctrl->Alt>F3. I generated a distribution specific package and installed the ensuing RPM, after completion I was stuck with a screen full of small purple and black characters and couldn’t even see the login prompt. So I decided to do one last thing, I did this, sax2 -r -m 0=fglrx, lo and behold it worked once sax2 finished and I rebooted. I had all the 3D affects and it looked great. I speak of this in past tense because once I installed an Adobe update, which installed x11-video-fglrxG01 I now have no 3D!!! :open_mouth: The irony of it all, made me laugh pretty good but I haven’t figured out how to get it back, oh well, who needs 3D desktop anyway! Take it easy and thanks for the tips.

Hi there, guys!

I just finished my tenth our of angry mental sex with fglrx and… it works with 3D-rich kwin =)

So I decided to post the short story of this little hair-tearing adventure =) Not sure if it’ll help anybody, but
a)I just need to spill it out :slight_smile:
b)It might reassure some people of the fact that this is the thread they’ve been looking for.

Here’s the deal. I have a C2D E7300 with 4Gb of Corsair and a HIS RadeonHD 4850 on board. After some partitioning and installing XP it was openSUSE 11.1’s turn. Now, I must inform you that I’ve used CD versions of the installer both times, so LiveDVD users may not encounter the same problem.

First, 64-bit version was installed. X worked fine, except for the 3D. Now, I’ve had some previous experience with Ubuntu, so I checked the x.org (unfamiliar with SaX at the point), and, as expected, radeonhd was the driver used. “No problem! fglrx will do the trick!”. The heck it did… After 7 hours or so of trying every possible solution, smoking mans, installing all mentioned requirements and fiddling with x.org I gave up. fglrx was there, but it failed not only to provide 3D-capabilities, but even to provide glitch-free work of anything more sophisticated than metacity. So I napalmed the partitions and started anew.

32-bit worked, well… Just like its predecessor. Even when I managed to get X up and running, kwin either crashed or worked terribly slow w/o any 3D available, but with flicking elements and trailing window-movement. So I removed anything fglrx-related, restored backed-up xorg.conf and “here it goes, here it goes, here it goes again” (c)

Piece of advice, folks - when in linux and in doubt, do your i-am-root-the-mighty-linux-fiddler-!11!1 from good old tty2. Seriously. It’s just plain more informative! After doing everything step-by-step according to the instruction above (the one starting with “There seems to be no way to edit my last reply…”) from the-e-e-e-e-re hold your breath nothing worked! =) But at least now I knew what the problem’d been - fglrx kernel module couldn’t compiled properly! Running the installation script prompted I received an error. Now, having some experience with Linux, I know that when some packages are missing, fglrx-install script tells you so. This time it was different, 'cause the were all in place. Well, the problem solved itself after installing kernel-source (not just the headers!) through zypper.

Once again: when a smart guy (read: the author of the step-by-step guide in this thread) tells you there are advantages to getting out of X to configure X - do so :wink: Thanks a lot, smart guy! =)