3D Games run slowly

Hello everybody
my name is Karl, I started using OpenSuse 11.2.

I’ve got no big problems on running programs.
Just one.

I’ve tried to install and run both Sauerbraten and Master Chef Ogro but both games runs very very slowly. It seems there is not the 3D acceleration.

Prior to install the 11.2 the programs run very fast and smooth.
After the upgrade they “crashed”.

I’ve tried to install 11.2 from scratch … same problem

Got any idea ?
Thanks a lot for any suggestions

cheers
karl

What graphics card do you have?
Have you installed the driver?

hi

apart of the graphics card … it is an integrated one, an i945.

The games worked perfectly prior to intall the 11.2 … very smooth and fast …

karl

The games worked perfectly prior to intall the 11.2

Prior to installing 11.2, what were you using? I’m not sure I follow you Karl.

Hello
before installing opensuse 11.2 I’ve run opensuse 11.1 and everything was ok.

Then I’ve upgraded to 11.2 and here comes the troubles.
I’ve tried to reinstall 11.2 from scratch but with no any improvements.

I’m thinking to re-installa 11.1 … is it a good step ?
Sounds “good” ?
mmmhh

thanks
karl

11.1 could be the answer.

Yeap
I think so …

Wondering around forums I noticed that the 11.2 release got som problems on configuring xorg.

I ran these commands:

> sax2 -p
> Chip: 0 is -> Intel 945G 00:02:0 0x8086 0x2772 PCI intel

and then
> rpm -qa “fglrx

obtaining … NOTHING
it seems that the accel. hasn’t been installed

Too bad for the 11.2 release … mh
karl

Did you see this?

openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

> sax2 -p
> Chip: 0 is -> Intel 945G 00:02:0 0x8086 0x2772 PCI intel

and then
> rpm -qa “fglrx

The fglrx driver is for AMD ATI chipsets, not intel. Read the guide as suggested by brunomcl.

Hi,

I had exactly the same problem with Penumbra Overture: it run seamless in openSUSE 11.1 with ATI propietary drivers. but in openSUSE 11.2 was too slow, like no 3D acceleration was there (note that games like warzone2100 and tuxRacer still worked).
After installing the latest 2.6.34-x kernel and updating to the latest Xorg packages from the Xorg repo Penumbra is running seamsless again.

I must warn you that if you are new to openSUSE and linux in general, adding such packages in-development state might render your system a bit unstable (which hasn’t happened to me).

You can give it a try and give a feedback of how it worked for you…

hope it helps