32 bit firefox in 64 bit openSUSE 11.0

Could anybody install the 32 bit firefox in a 64 bit OS?

As usual, this is necessary to make java plugin working. Although there may be other solutions, I used this way since years.

But this time I get an error when starting firefox:

Could not find compatible GRE between version 1.9.0 and 1.9.0

I have installed the 64 and 32 bit versions of mozilla-xulrunner, both separately and together.

The 32 bit firefox never worked.

I dont know which rpms I’ve installed but same error message is appears on my laptop.

I don’t have problems with FF 64 bit…
I didn’t do anything after initial install from OS11.

it is weird :s
on my desktop pc FF is working flawlessly but on my laptop, doesnt.
I tried to install xulrunner-1.9.0 32 bit but it doesnt solved.

I removed xulrunner-1.9.0 package with ignore dependencies and re-installed,
it is working again.

I did it on mine opensuse10.2 (64bit) box. So i don’t know if it works on os11.0. I downloaded the generic tar.bz2 for the Mozilla site, then i extracted it in /usr/local and run from there. It asked if i wanted to make it the default browser. I answered yes, and it works flawlessy until now. Give it a try.

I installed xulrunner (not the 32 bit version) as a 32 bit package (thus i586 instead of x86_64) and that helped for me.

I gave up and just installed the 32bit version of Seamonkey - which works fine for java based websites that don’t work too well with knqueror.

changing xulrunner 190 to the i585 version worked for me

I am running openSUSE 10.3, but ran into similar problems.

I have the following packages
rpm -qva |grep -i -E -e ‘firefox|xulrunner|seamonkey’|sort

Using strace on firefox I noticed
open("/usr/lib/firefox/application.ini", O_RDONLY) = 3

precedes the check of the /etc/gre.d/ contents.

In application.ini, I found


Changing those values to did the trick.Further experimenting showed that I only need to set the MaxVersion value to
Which (duh!) makes sense given the xulrunner version I have.

Very frustrating!