3 Questions about scrolling

Hello well here they are
1.Scrolling is choppy and lags when I scroll the page (in a browser) up and down and left to right(seems to only do it if there’s flash on the page) and it doesn’t do this in windows so anyway to fix this.
2.I can’t scroll when the cursor is on a flash video not really a big issue but annoying.
3.In my Windows partition if I run my finger all the way up or down the left side of the pad then release the page continues to scroll untill I touch the pad again (very nice for getting through long pages) anyway to set the touchpad to do this in suse.

Thanks hope I was specific enough

  1. ‘A browser’/ Which? ‘Seems only to happen with flash’ - Shouldn’t be hard to confirm that for sure?

  2. Normal

  3. Sorry, no idea. But settings is my best guess.

1.it does it in both firefox and opera and and the reason I say “seems” is because it’s not always choppy when flash is present

2.Thanks guess I’ll just have to deal with it.

3.I’ve checked the X11 setting but cant find anything that would pertain to what I was asking

I haven’t had the need to play with xorg.conf touchpad settings, but functionality is provided by x11-input-synaptics package. Type ‘man synaptics’ to read available options. In particular, it mentions:

Coasting is enabled by setting the CoastingSpeed parameter to a non-zero value. When coast‐
ing is enabled, horizontal/vertical scrolling can continue after the finger is released from
the lower/right edge of the touchpad. The driver computes the scrolling speed corresponding
to the finger speed immediately before the finger leaves the touchpad. If this scrolling
speed is larger than the CoastingSpeed parameter (measured in scroll events per second), the
scrolling will continue with the same speed in the same direction until the finger touches
the touchpad again.

Maybe you could try adding/adjusting this parameter.

My next suggestion, you may already be familiar with: From firefox menu > edit > preferences > advanced > select ‘smooth scrolling’

3.In my Windows partition if I run my finger all the way up or down the left side of the pad then release the page continues to scroll untill I touch the pad again (very nice for getting through long pages) anyway to set the touchpad to do this in suse.

My touchpad works like that (ie coasting as expected). It also has a better overall response than in windows.

So is it the xorg.conf file I’m editing or is it something else,and if so what? I’m a bit confused with the three options I have “integer” “boolean” and “float” is it saying that I should add an option to my xorg.conf that looks like this…
Option "CoastingSpeed (“1"float”)

and yes I do have smooth scrolling enabled it only seems to make it worse though

Yes, /etc/X11/xorg.conf is the relevant config file. This may take some experimenting with on your part. The coasting speed option can have values like these:

Option CoastingSpeed “0”
Option CoastingSpeed “0.13”

(You may need to Google for more ideas/info).

There are a graphical front ends for the touchpad configuration available if you prefer: ksynaptics (for KDE) and gsynaptics (for Gnome). Not sure how much control over configuration they give, but may be worth a shot.

Thats all I can offer.

ah ok cool tried to use ksynaptics but all’s I get is the following message…No usable driver has been found! Either your driver is not correctly installed or you are using a wrong version. You need at least driver version 0.14.4! which makes no sense at all because I’m using version 0.15.2. I would be nice to get this running though not necessary,and I see that the development of ksyaptics has been discontinued for the development of touchfreeze but alls touchfreeze does is enable/disable my touchpad which isn’t near as usefull as ksynaptics. have any ideas on how to fix this?
Also for some reason I cant edit the xorg.conf file becasue when I try to open it with super user mode I get KDEinit could not launch /usr/bin/kwrite

Also for some reason I cant edit the xorg.conf file becasue when I try to open it with super user mode I get KDEinit could not launch /usr/bin/kwrite

I usually edit root-owned files with a console-based editor like pico or nano:

su (to become root)

cp /etc/X11/xorg.conf /xorg/X11/xorg.working (make a backup)
pico /etc/X11/xorg.conf (edit the file)

oh yes I have that installed and I can edit my file this way. I would just like to know why opening a file as root wont open and it works fine as a non-root user.

also how do I save the modified file ctrl+S doesn’t work

When finished editing with pico edtior, type Ctrl-X to exit. It will then ask you if you want to save changes.

ah ok thanks but any idea on why kwrite wont work as root?

from a terminal are you doing

kdesu kwrite /path to/file

eg: kdesu kwrite /etc/X11/xorg.conf

You need to use kdesu command:

kdesu kwrite /etc/X11/xorg.conf

Nothing like repetition for emphasis!
Sorry @deano_ferrari
I’ll leave you to it.

No actually I’m using dolphin super user mode and doing it that way but I opened my system activity monitor and noticed the process “su” is being a accessed by both root and me users is that a problem?

Dolphin su is buggy.
Do as advised;)

oh ok well I’ve already done what I needed to do thanks just wondering about dolphin but now I know thanks for your help guys…also just a side note I used nano to edit but doing kdesu kwrite /etc/X11/xorg.conf just makes the terminal hang it does nothing

oh sorry caf4926 just found your posts regarding this subject Can’t launch editor as root - Page 2 - openSUSE Forums and dolphin works but konqueror just gives me something about No such signal Dolphin view. Now correct me if I’m wrong but I think silenuz was right in that post about the problem… when I run sudo kdesu kate I’m prompted for a root password then I get the message kdesu cannot connect to the X server.

sudo is not necessary in this

kdesu alone will prompt for password
I don’t ever use sudo in openSUSE. In fact you have to specifically enable sudo for a user account IIRC.