3.10 kernel and Nvidia

Running “zypper dup” today, I see that the kernel was updated to 3.10.0-16.g3dcd746-desktop .

I rebooted to use the new kernel. There was no desktop. This was expected, since I am using the Nvidia drivers.

I reran the nvidia driver installer. It failed to build. The last few lines of the log:

   /tmp/selfgz8190/NVIDIA-Linux-x86_64-304.88/kernel/nv-i2c.c: In function ‘nv_i2c_del_adapter’:
   /tmp/selfgz8190/NVIDIA-Linux-x86_64-304.88/kernel/nv-i2c.c:327:14: error: void value not ignored as it ought to be
   make[4]: *** [/tmp/selfgz8190/NVIDIA-Linux-x86_64-304.88/kernel/nv-i2c.o] Error 1
   make[3]: *** [_module_/tmp/selfgz8190/NVIDIA-Linux-x86_64-304.88/kernel] Error 2
   make[2]: *** [sub-make] Error 2
   nvidia.ko failed to build!
   make[1]: *** [module] Error 1
   make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

Same problem here. I did some searching and there is a patch that appears to work, but I don’t have any experience adding patches to the nvidia drivers. The instructions I saw were for Gentoo. Also, I saw a post on the nvidia forums that none of their drivers work with the 3.10 kernel.

After the drivers failed to build for me, I booted into the desktop and discovered that my display was using /dev/fb0 and running at an odd looking 1600x1200. Anyone know how I can get the nouveau driver to load?

Anyone willing to try the patch and post the instructions here?

I managed to get nouveau working.

# cd /etc/modprobe.d
# rm *nvidia*
# cd /etc/X11
# rm xorg.conf

I then rebooted. Alas, Gnome doesn’t work. Fortunately, I’m a KDE person, and KDE seems fine with nouveau and my particular card (Geforce 6150 LE). As a precaution, I did go into the power settings and disable turning off the display – I know that sometimes cause the mouse pointer to disappear until reboot.

I’m inclined to wait and see whether nvidia fixes their driver installer scripts to handle 3.10 kernels.

I removed /etc/modprobe.d/50-nvidia.conf and /etc/modprobe.d/nvidia.conf.

Then I removed /etc/X11/xorg.conf.d. Nouveau still doesn’t load.

I don’t think you should have removed “/etc/X11/xorg.conf.d” - only “/etc/X11/xorg.conf” (if it is there). My “xorg.conf.d” directory has

05-glamor.conf  50-device.conf   50-synaptics.conf  90-keytable.conf
10-evdev.conf   50-monitor.conf  50-vmmouse.conf
11-mouse.conf   50-screen.conf   50-wacom.conf

which are not nvidia related.

In “/etc/modprobe.d”, you can run the command:

# grep nouveau *

to see if there is any file that is blacklisting nouveau. In my case, it was only the files with “nvidia” as part of their names.

I tried #grep nouveau * which returned nothing. I tried booting into text mode and then

modprobe nouveau

but my display is still using fb0. lsmod shows the nouveau module is loaded.

The nVIDIA driver has not worked with kernel 3.10 since the start with rc1. I have seen a few patches, but did not get them to load. My SANDI bash script does support the loading of a patch, which is just using the driver ability to be patched. You must find the right patch for the version of the driver you want to use and it must be applied to the correct location within the archive. So far, the patches I have seen are very large and way beyond any fix I have seen before. I am thinking if you need to use the proprietary nVIDIA video driver, stick with kernel 3.9.9 for now. It is easy to install any kernel version using my SAKC bash script if you have never used it before.

Thank You,

That might be the best advice.

Is there a way to lock in that kernel (in Tumbleweed), so that a future “zypper dup” won’t try to install a newer kernel?

So I do not use Tumbleweed myself, but if you load the 3.9.9 kernel using SAKC, it matters not what kernel version is loaded by Tumbleweed and with the grub2cmd script, you can set the 3.9.9 kernel as default to load.

S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.60 - Blogs - openSUSE Forums

GNU Grub2 Command Listing Helper with --help & Input - Blogs - openSUSE Forums

The highest kernel version installed is always top dog by default, though a bug in Grub 2 puts 3.10-rcx numbers ahead of 3.10.0 for some reason but rc’s should be uninstalled now if they exist anyway.

That You,

I think you can lock it. I do it using yast2

Thanks. Yes, it looks as if that is the way to go. Either that, or live with nouveau.

I have the same problem. I switched to Nvidia driver because I had a problem with nouveau driver (s2ram did not work since a kernel upgrade). I am thinking about trying nouveau again. As I can remember, it is not easy - jdmcdaniel3 wrote about it somewhere. I would be grateful, if somebody tld me, how to do it safely. Thank you.

also using


For those wanting to use Nvidia with 3.10, see:


Make sure you read right to the end of the thread. The instructions in message #12 are the ones I used.

Another little buggette I found was that the file nvidia-application-profiles-325.08-rc has the wrong permissions and the .manifest file gets upset. They need setting to 444.

John F.

download 325.15 NVIDIA drivers from the NVIDIA manufacturer’s site. This new version will install without patches or problems… It’s a beta version, but it works!

nVIDIA driver version 325.15 is listed as being certified, but not beta as best as I can see. I have used it on my test computer using a nVIDIA GT 460 with the 325.15 proprietary video driver in kernel 3.10.5. I use it with dkms and SANDI on a standard PC.

S.A.N.D.I. - SuSE Automated NVIDIA Driver Installer

Thank You,

I’m going to try it as soon as I can.
Thank you. rotfl!

I installed kernel 3.10 and Nvidia driver 325.15 yesterday - it works.

Works perfectly for me too … :slight_smile:

Still doesn’t work for NVIDIA Optimus/Bumblebee