22" LCD TV detected as 32"

I am a total newbie to linux and have just installed suse 11.3 x64 Gnome version today which I thought went ok. My monitor is a 22" LCD TV which is connected via a HDMI cable but unfortunately suse has detected the monitor as a 32" monitor and so am missing about 1cm of the screen on all 4 sides. Everything else is correct, right graphics card detected, right resolution & refresh rate etc. Is there a simple way for a total novice to change the detected screen size?

Hi phasmatis. I’m not sure about the implications of your monitor size being incorrect, especially if the display resolution is correct. It might be that the reported DPI value is incorrect. What does the following command return?

xdpyinfo |grep resolution

What graphics chipset and driver are you using?

/usr/sbin/hwinfo --gfxcard

Open a console, and type

xrandr

I’m interested in seeing what display size is reported here.

You could try adding the physical display size dimensions in /etc/X11/xorg.conf.d/50-monitor.conf with an editor like this

gnomesu gedit /etc/X11/xorg.conf.d/50-monitor.conf

Add an entry ‘DisplaySize width(mm) height(mm)’ entry similar to

DisplaySize  487 274

When finished, save, the restart the X-server with CTRL-ALT-Backspace (twice).

Hi Deano, many thanks for your assistance, I ran the commands you suggested and the results are as follows:

xdpyinfo |grep resolution

resolution: 96x96 dots per inch

/usr/sbin/hwinfo --gfxcard

23: PCI 100.0: 0300 VGA compatible controller (VGA)
[Created at pci.318]
Unique ID: VCu0.U_RxSFpamz0
Parent ID: vSkL.ouovAhKO8D1
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: “ATI RADEON HD 4350”
Vendor: pci 0x1002 “ATI Technologies Inc”
Device: pci 0x954f “ATI RADEON HD 4350”
SubVendor: pci 0x1682 “XFX Pine Group Inc.”
SubDevice: pci 0x2920
Driver: “radeon”
Driver Modules: “drm”
Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
Memory Range: 0xfe9f0000-0xfe9fffff (rw,non-prefetchable)
I/O Ports: 0xc000-0xcfff (rw)
Memory Range: 0xfe9c0000-0xfe9dffff (ro,non-prefetchable,disabled)
IRQ: 27 (6583 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00001002d0000954Fsv00001682sd00002920bc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: radeonhd
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #9 (PCI bridge)

Primary display adapter: #23

xrandr

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 735mm x 420mm
1920x1080 50.0*+
1280x720 50.0 60.0
720x576 50.0
720x480 59.9
DVI-0 disconnected (normal left inverted right x axis y axis)

gnomesu gedit /etc/X11/xorg.conf.d/50-monitor.conf

Section “Monitor”
Identifier “Default Monitor”

If your monitor doesn’t support DDC you may override the

defaults here

#HorizSync 28-85
#VertRefresh 50-100

Add your mode lines here, use e.g the cvt tool

EndSection

I added the line ‘DisplaySize 487 274’ before EndSection but it made no difference.

Many thanks for any assistance.

Ok. Actually the ‘DisplaySize’ values were just an example, and maybe not the true dimensions of your monitor. Anyway, the DPI value reported seems ok to me.

You might want to consider trying the proprietary ATI graphics driver. Maybe that will detect your monitor correctly, as well as leveraging your graphics card’s capability.

SDB:ATI drivers - openSUSE

My monitor is a 22" LCD TV which is connected via a HDMI cable but unfortunately suse has detected the monitor as a 32" monitor and so am missing about 1cm of the screen on all 4 sides.

Thinking about this some more, this may simply be a configuration setting with your HDMI TV. I’ve seen a few reports like this

Compensating for overscan/cropping using xorg.conf [Text View] - AVS Forum

Resize desktop nvidia overscan

ubuntu desktop - How do I fix overscan on my HDMI HDTV? - Ask Ubuntu - Stack Exchange

Maybe the TV is overscanning and rescaling the image. You may be able to adjust the tv to display the full image.

Hi Deano,

Thank you for your assistance, I downloaded the proprietary ATI graphics driver as suggested and now all is well and I can see the whole screen.

Once again many thanks for your time and effort.

However I am still trying to get my WMP600N-EU wireless card to work but that’s another issue.

That’s great news! Enjoy. :slight_smile: