20151124 snapshot has seriously broken the use of Oxygen Icons

Since updating TW to 20151124 (using zypper dup) the use of Oxygen Icons is seriously broken.

I have a ‘mix and match’ of Oxygen and Breeze :frowning: as shown in this screenshot:

I have tried deleting ~/.cache/icon-cache.kcache to no avail…

I noticed that oxygen-icon-* was replaced during the update with oxygen5-icon-. The original oxygen-icon- is still available in the TW repo and I tried re-installing that, again to no avail…

What’s going on here?.. I want my Oxygen back… :wink: (I’ll refrain from saying what I think about Breeze)

Also saw this on the factory mailing list:

… whilst relating to Leap, this also seems to confirm that ‘something’ recently broke in the way icons are handled.

Not only Oxygen, also happens with “Adwaita”…

I feel a bug report coming on, only I’m not sure which component to report it against :\


Plasma5 will not use the old icon format it must be the new 5 format. It is supposed to change old to new but it seems the process may not be working full for some leaving blank icons.

<Thick Mode>
Sorry, don’t think I fully understand your ‘Upgrade?’ comment. Could you please elaborate?
</Thick Mode>

Yup, I had a blank “Documents” folder icon place via dolphin, for example. Via folder’s properties there is one available and selectable. Not sure why the process failed to find it - maybe case sensitivity or buggy code. In some cases one can find a nearest equivalent that way, and I didn’t have many missing file icons (Breeze) that weren’t there before. I’m guessing some applications using custom file types submitted no new or old “plasma 5 file type” icons.

Question was did you get were you ar by an upgrade or a clean new install?

upgrades tend to bring old stuff along and the change in icon format may cause you problems where in a fresh install all icons should be right to start

Clean install of TW a few months ago (mid June?), then updated as each snapshot issued.

These (Oxygen) icons were displaying perfectly OK prior to the 20151124 snapshot.

Also, if I create a completely new user (which has the default Breeze icons), then change the icon theme to Oxygen (or Adwaita), that new user also then has the mix of icons… :stuck_out_tongue:

Are you able to change icon themes correctly yourself, or do you see the same mix as I’m seeing?

Did you notice that the default Oxygen fonts (KDE) were also replaced by “Noto Sans” fonts?

No, I hadn’t noticed that. I don’t use the Oxygen fonts, they, together with many others I’ve removed. (One of the first things I do on any new install is to remove the plethora of fonts I know I’ll never use. I really dislike wading through what seems like an endless list when selecting a font.)

There was some discussion on the factory mailing list a while back I believe about changing to “Noto”, although I didn’t follow it.

Back to the original Icon problem, I’ve now filed a bug report:
and will see what the outcome of that is.

There have always been too many dubious fonts (IMO). If “Noto” hadn’t automatically replaced the Oxygen fonts, I probably wouldn’t have noticed it, although it should be a system-wide replacement on Tumbleweed for default Sans, Serif, etc. That’s what I half expected from an old ML discussion thread - I missed anything about a decision having being taken (just another “Maker’s choice”). I suppose it will happen for Leap 42.x at some point.

Not a lot it would seem…

One other person at least is also seeing this and has added to the report:

A “sledgehammer” solution I’m using for the moment is:
set ‘breeze5-icons’ as ‘Protected – Do Not Modify’
then in ‘/usr/share/icons’ replace the breeze5 icon set with a dummy set containing no icons. rotfl!

<cynical mode>
I’m sure if this was a case of breeze icons having a few oxygen icons showing, then it would be fixed asap…
</cynical mode>

I see 20151216 is out…

  • breeze5-icons from 5.4.3 to 5.16.0…


This is not caused by the icon set itself though. It is almost as if ‘something’ (that displays the icons) is hard coded to use breeze, ignoring the user set icon theme.

Ahh ok, seemed like a big ‘Leap’ in versions… Tumbleweed rocks along since the original posted version and the current release.

Yeah! … and it’s pushed quite a few of my Oxygen icons into the long grass … ‘breeze rules’ … it’s ‘beautiful’ … sorry, been a long day and my patience is wearing very thin…