20151002 Live GNOME - no GUI in VirtualBox 5.0.6

Not sure to which forum it actually belongs - let’s try here. Booting latest 20151002 Live GNOME under Oracle VirtualBox 5.0.6 results in no GUI - X server fails to start. When 3D acceleration is enabled in VM properties it attempts to load accelerated virtualbox driver and fails because kernel module is no more included in Live image. When 3D is disabled it fails to use VESA drivers as well. I tried several different acceleration settings but it does not look like it depends on it. Anyone was successful in getting any GUI (not necessary accelerated) and can share VM settings?

Hi
Sounds like this… been fixed in the openSUSE version.
http://lists.opensuse.org/opensuse-factory/2015-10/msg00161.html

I’d just find it strange that VESA wouldn’t work either.
It works fine here in the NET-installer, which I’m currently running in VirtualBox 5.0.4 (default settings, i.e. 3D disabled) to install the latest snapshot…

Is xf86-video-vesa (and/or xf86-video-fbdev) actually installed?
Maybe it’s missing from the LiveCD too?

Yes, they do; but neither any kernel framebuffer driver is loaded nor can X drivers access hardware directly (because X runs as non-root user in Live). NET installer likely starts X as root which explains why framebuffer works.

Loading Live in QEMU works using modesetting driver on top of KMS-enabled kernel cirrusdrmfb.

The live Gnome probably used GDM, while the NET installer probably uses XDM. At present GDM seems to have issues. I’m guessing that’s the difference.

Yes, I’d think so too. Although the NET installer probably doesn’t use any DM at all AFAIK.

VESA should work even without a framebuffer (a missing one would prevent fbdev from working).
There was a bug there though, but that got fixed months ago.

Maybe it helps to select a specific resolution in the boot menu?
That should make fbdev work.
But maybe won’t help if GDM is crashing (depending on why it’s crashing)…

This problem is still there on the Gnome-Next LiveCD based on TW 20160321.
Seems definitely a GDM related problem, since:

  • the “Install” option, which doesn’t need GDM, works;
  • booting to CLI (old “runlevel 3”) works;
  • booting to CLI, editing /etc/sysconfig/displaymanager to use xdm instead of gdm, switching to graphical target, gets to a xdm login greeter
    (then xdm keeps complaining “Login incorrect”, but this is another story).

The interesting thing is that while booting to the LiveSession keeps looping on VirtualBox 5.0.12, apparently with gdm or Xorg crashing and restarting, everything is OK on VMWare Player and I can have a taste of Gnome 3.20, which seems promising.
So it seems that VBox adds something of its own to the problem (at least on a Leap Host).

I didn’t try (yet) to burn the .iso to an USB key and booting on bare metal.

Hi
Did you add iomem=relaxed to the boot options? It’s a known bug… plus way old thread :wink:

Hi Malcolm, thanks for the reference that shows clearly why we are witnessing such things and maybe why VMWare seems unaffected.
I had already tried “iomem=relaxed” to no avail. Maybe having no “Guest Additions” at all (not included in the Gnome_Next LiveDVD) in a “diskless” VM added something to the problem.

As to the old thread, I found it still had relevant background info and just added my 2 cents.
Issue closed on my side, waiting for the upcoming fixed version of VBox.