2 Weeks of OpenSUSE 13.2 - An Adventure

It is now two weeks since my installation of OpenSuse 13.2. I want to share my experiences with you, specially all the problems I encountered during installation and first two weeks of usage.

I am using OpenSUSE 13.2 as the only operating system, for work and for fun. Since I got annoyed more and more by Windows and I was using Linux for work for a long time anyway, I decided to give it a try in everyday use. However, soon I realized that using Linux as primary operating system is a very time consuming lifestyle and that I have to give up the ease and comfort known from Windows. In addition I had to give up on some “normal” features like Power Management (sleep, hibernate) which for reasons described further in the text don’t work on my system.

Here are the problems I encountered so far:**Installation & System

  1. The **OpenSUSE installer **
    couldn’t find the source drive with the bootable image. Booting from the bootable USB stick I created seemed to start normally but than at the very beginning of the installation process there was an error and it was not possible to proceed: > Please make sure your installation medium is availible. Retry?
    . I checked the image on the bootable drive and everything should have been fine, I even downloaded a new image, but the problem persisted. Finally, I solved the problem by doing a network install, which required to download a small .iso file which booted properly. For this option you need to have a reliable internet connection during installation.
  2. Configuration of the Nvidia driver
    . Since I have two GPU-s in my system I want to use SLI. However, there is no option available for that in the Nvidia Dock configuration application. I had to configure this manually by adding a configuration file. The procedure can be found on the internet and a little playing around is needed. http://us.download.nvidia.com/XFree86/Linux-x86/173.14.12/README/chapter-25.html https://en.opensuse.org/SDB:Configuring_graphics_cards SLI works fine now. 1. All fonts
    appeared extremely large on the desktop suddenly. I don’t think it had to to anything with the Skype installation which I did before the occurrence of this problem. I solved the problem by forcing DPI (dots per inch) for fonts to 110. This option can be found somewhere in Desktop Configuration. 1. Hanging on startup
    . Around 20 times already the system hanged on startup for no reproducible reason. Usually the problem occurs after a hard shut down. The system freezes while the splash screen is visible and no interaction is possible. Usually, everything works fine on the second try after a hard shutdown. 1. Desktop
    freezes and the clicking function of the mouse as well as the keyboard stop working. This problem happened about 5-10 times and hard shut down was necessary to proceed. After I disabled Power Management (for other reasons which follow) this problem didn’t occur any more. 1. Grub2
    error during booting: > error: Sparse file not allowed
    .This problem appears sometimes after an improper shutdown. The system manages to boot properly, but the boot options are not available any more. Apparently it has something to do with a Grub2 bug with btrfs file systems. After occurrence of the problem I manually delete the

file. The boot options appear again. It is also possible to solve the problem by booting from the Master partition and then again from the boot drive, but in that way I somehow lost all my desktop configuration.

  1. No possibility for Power Management
    , Sleep and Hibernate. This is a major issue. When I put the system to sleep or hibernate a resume is not possible and results in a black screen (no interaction whatsoever is possible). There seems to be a bug either in the OpenSUSE **Kernel **or in the **Nvidia **GPU driver. I went through hell to realize this and tried everything at my disposal to solve it. Finally, I reported a bug to the OpenSUSE developers. They told me that they cannot do anything as long as I am using Nvidia drivers which are not open source. However, I have to use Nvidia drivers because this are the only drivers supporting SLI for two GPUs. I reported the problem to Nvidia, they gave me a few suggestions to try which didn’t work. Now I am running with Power Management disabled, so that the system doen’t go to sleep accidentally. This also solves a few other problems described earlier (5 and 6). However I still have to be extremely cautious not to close the lid of my laptop while running, because the system will go to sleep by kernel-default which will also result in a crash. The problem and all the solutions I tried to resolve it are described in detail at the OpenSUSE Bugzilla Main Page and at the Nvidia Developer forums: https://bugzilla.opensuse.org/show_bug.cgi?id=938440 and https://devtalk.nvidia.com/default/topic/857561/after-resume-on-sleep-or-hibernate-system-freezes-with-black-screen-no-interaction-possible-/#4609677 You should definitely read it just to get a feeling what can happen if you decide to use Linux or OpenSUSE. It goes far beyond “settings”. 1. Apper
    Bug. Apper is the program which handles automatic updates in OpenSUSE 13.2. After each update installation an error appears: > Failed to cache rpm database (1)
    . It is probably no major issue since the updates seem to finish normally. This error appears after every update installation. I have submitted a bug report for this: https://bugzilla.opensuse.org/show_bug.cgi?id=939657

Other applications

  1. Installation of Skype
    . It turned out that the installation of Skype is quite complicated. I followed the procedure described here: https://en.opensuse.org/SDB:Skype#Installing_Skype and everything worked properly. Skype has some bugs, for example when trying to send files via the Menu bar, the application crashes. However, it is possible to attach a file directly to the chat via drag and drop. 1. **Firefox **
    problem: heavily blurred text while scrolling. I solved this problem partially by disabling smooth scrolling in the Firefox options. In this way I lost some functionality but now there is almost no blurring during scrolling text. This problem occurs only in Firefox. I tried to change the configuration of my GPU-s in many ways but nothing helped. 1. **GnuCash **
    bug. GnuCash is a software for personal finance management. It is great, however, the version offered in the main OpenSUSE repository has a bug. It doesn’t display some graphs correctly. I already reported this: https://bugzilla.gnome.org/show_bug.cgi?id=752281 I could probably solve this by installing a newer version of GnuCash from source. That seems to be quite complicated and since I rely on other than graphing features of the program and since it could be very time consuming, I am not going to try the installation from source now. Hopefully someone will prepare the newer version in the standard OpenSUSE repository. 1. **digiKam **
    bug. digiKam is a great program for photo management. I use it now for the first time. After one day some photos didn’t appear any more, but were still found on the hard drive (file manager). I solved the problem by changing some settings to show only the real version of the photos and not the internal database thumbnail copies. It works now. 1. **Amarok **
    bug: no connection with the internet is possible for the Wikipedia and last.fm plug-ins. Possibly even for other internet services. The Wikipedia pluggin has been fixed with an update today, the last.fm plug-in still doesn’t work. Amarok is a great music player and sadly this feature doesn’t work now. 1. **WebEx **
    audio not running. It says: > The Audio Device is Unaccessible Now
    . Apparently this problem arises because of the incompatibility of WebEx with 64-bit architectures. None of the fast solutions found on the internet works. I would probably have to install a 32-bit Firefox version and several additional libraries and create some links by hand as described here: https://forums.opensuse.org/showthread.php/485165-Firefox-and-Webex I am not going to do this since I don’t have time and WebEx is after all not so important for me.

[HR][/HR]This are the biggest issues I was dealing with for the past two weeks. I have to emphasize that there were also some pleasant surprises in everyday use. For example the program digiKam is very good. I will definitely use it from now on and I recommend it to everyone. Some basic features seem to be working much better in Linux than in Windows, like file-copying. It was almost impossible for me in Windows to copy 200-300 pictures from a folder containing about 2000 pictures from my smartphone to Windows. In Linux, things like that work smooth and easily. Another thing soon realized is the overall stability of the system. In Windows, when a single program crashes it very often causes a system crash where everything freezes. In Linux, on the other hand, if a program doesn’t respond it usually affects only this window or process. The functionality of the rest of the system seems unaltered. Another cool thing, I am using the Kaffeine media player and the subtitles were just too small. I easily solved this by changing the font size for the subtitles in the configuration file of the application. Such elegant solutions are seldom found in Windows. I don’t want this to become a comparison between Windows and Linux, I am just emphasizing some functionality issues in every day use. The advantages of Linux in many areas of professional usage are clear and I am not talking about that here.

My conclusion is simple, you have to bring with you a lot of patience and love if you want to use Linux in everyday life. In addition, you have to be prepared to possibly give up some functionality you are used to getting elsewhere. Black and white comparison of Linux to other operating systems is definitely no correct approach. For example, articles like this: http://www.makeuseof.com/tag/5-lies-linux-haters-like-tell/ definitely don’t create an accurate opinion abut Linux and are very misleading. While it definitely isn’t old and ugly, it can indeed easily become very difficult, you certainly have to use the command line and sometimes you even have to build from source.

If you support the idea of open source and want to be part of a friendly and familiar community of Linux users you may give it a try. Just don’t expect everything to work perfectly. :wink:

At one time, the online instructions said that you should use F4 and tell the installer to search all disks for repos. I’mt not sure if they say that, but my experience with recent installs is that this causes the source to not be found. If I just directly boot into the installer with no related options, then it seems to always work.

All fonts appeared extremely large on the desktop suddenly.

I have not seen that. However, installing Nvidia drivers does change default font sizes for some applications. I never tried to investigate. In particular, I noticed this with “konsole”.

Desktop freezes and the clicking function of the mouse as well as the keyboard stop working.

I have had a problem of freezes with my laptop and Intel graphics. The freeze usually occurs when the brightness changes. Most often it is a return to full brightness that initiates the freeze. So in power settings, I tell it to never dim the screen.

No possibility for Power Management, Sleep and Hibernate.

I don’t much use those. But, on testing, they work with Intel graphics. I ran into problems with Nvidia graphics (using nouveau driver at the time).

Wow! that seems a lot of problems! haha.

In my experience I’ve found some really annoying bugs bout most of them were from the KDE Desktop (Witch I love… and hate).
I will try to add any possible related bugs I’ve found on the same items you shared.

  1. The openSUSE installer:First of all, did you check the hash of the ISO?
    Never had too many problems with this and I think the SUSE/openSUSE installer is one for the best around there, really awesome.
    Although sometimes the Installer starts in a different “mode” I guess, the UI is changes and the MemTest option does not appear.

  2. **No possibility for Power Management, Sleep and Hibernate:**I myself had problems when suspending and hibernating with my AMD card, I’ve tried both open source and proprietary drivers, removed pm-utils, etc… It didn’t worked.
    Also I’ve tried SEVERAL DISTROS and SEVERAL KERNELS and I had the same problem, on Windows 7 suspend works fine. So this could be a driver, kernel or even BIOS issue for me.

  3. **Apper Bug:**Sometimes the Apper system tray app hangs. (I mean the one with the bug icon). But it isn’t a big deal.

Sorry for my terrible English.

Yes, indeed there were and still are plenty of problems. But at least the system is running and I can use it .lol!

First of all, did you check the hash of the ISO?

I did indeed check the hash of the ISO. Everything seemed fine.

I myself had problems when suspending and hibernating with my AMD card, I’ve tried both open source and proprietary drivers, removed pm-utils, etc… It didn’t worked.
Also I’ve tried SEVERAL DISTROS and SEVERAL KERNELS and I had the same problem, on Windows 7 suspend works fine. So this could be a driver, kernel or even BIOS issue for me.

That’s similar to my problem. I think it will never be solved actually. I have seen posts related to similar stuff going back as far as 2008.

Yes, PackageKit just “hangs” at the moment when a license agreement is required (for a flash-player update e.g.).
But interact with it in any way, and it should continue to install the updates.
Possible workarounds include:

  • Right-click on the “bug” icon and choose “Check For New Updates”, you won’t see any progress in this case but it will continue in the background.
  • Run Apper itself and check for updates, the applet will then continue to install the updates.
  • run “pkcon get-updates” in a terminal window.
  • wait until Apper checks again for updates automatically… It does so only once a day by default though (you could set it to hourly).

Regarding the problem with the “openSUSE installer”: how did you copy the ISO to the USB stick?
Apps like Rufus or unetbootin modify the image to make it bootable (by default at least). The openSUSE image is already bootable (via USB too), trying to make it bootable destroys it. An error like you mention is a typical symptom in that case.

Use “dd”, SUSE’s ImageWriter, or any other tool that just does a plain copy.
See also SDB:Live USB stick - openSUSE Wiki for more details.

Yes, I noticed that. Thanks for the feedback.

I have had no problems with Linux or OpenSUSE over 12 years; but I always try a machine on Live Knoppix before loading a Linux system. I however only use Intel Graphics (no dedicated graphics card.) As I only use office applications, with odd photo saving (no editing of photos) , no music downloads, but a lot of iPlayer on BBC watching TV documentaries, I have a very big difference in approach. Machine running Linux system are from 1998 (OpenSUSE ) to 2013 (OpenSUSE, Win 7, Win 10 Knoppix).
You have very different requirement to me, so I am great full for your comments.

Regarding the problem with the “openSUSE installer”: how did you copy the ISO to the USB stick?

it is indeed possible that i destroyed the image. i was using Universal USB Installer for Windows. I was reading the instructions on how to install OpenSUSE but I didn’t get that the downloaded file is already bootable. Maybe thath should be emphasized more clearly. Interestingly, with the Internet Install file everything worked fine, although I used Universal USB Installer again to make it bootable.

Well, this one doesn’t have any packages or repos/metadata on it, it uses the online repos as installation source (and even downloads the actual installer from the internet).

All fonts appeared extremely large on the desktop suddenly.

But for some time it is so. Just large, not extremely - 13.1, Xfce, Nvidia proprietary driver. Fix with DPI settings (but for some older applications it does not work).