2 problems after last week update...

After doing last weeks update, last week March (zypper -n dup) I have 2 problems:

  1. I do not have graphical password entry field (and background) to unlock the encrypted /home partition. But I do when I revert the kernel from v5 to the last installed version 4.20
  2. has problems in 2 ways
  • Using Plasma Wayland (my default) I get a crash from Akonadi server after login and from there the desktop is stuck. or
  • Using Plasma Wayland after login I will get always re-directed back to the login page.

I have the same behaviour using Plasma.

I installed from the shell the mate-desktop environment and can login to this desktop now. But I rather would like to stick to KDE Plasma default

Anyone with a idea how I can fix KDE default desktop (and get the /home decryption graphic back again)

This reply is only about the decryption problem.

While booting, hit ‘e’ at the grub prompt. That should get you into an edit screen. Scroll down until you reach a line that begins with “linux” (or maybe “linuxefi”). Scroll right. Delete the text “splash=silent”. Now continue booting (usually CTRL-X or I think F10, but there will be a note on the screen.

Do you now get a prompt for the encryption password? (It will be a text prompt rather than a graphic prompt).

An alternative: Same steps, except replace “splash=silent” with “plymouth.enable=0”. Do you now get a prompt?

By the way, you can make these changes permanent with Yast bootloader (use the kernel parameters tab). But at this stage we are really debugging. Is this a plymouth problem or some other problem.

I’m not using plymouth with Tumbleweed, but I will give it a try in a while to see if I run into that issue.

An update. When I boot with plymouth, to get a graphic screen for decryption – that works fine with 5.0 kernels.

My guess is that your problem there might be related to your graphics card and driver.

Can you reach a desktop booting old kernel and choosing a non-Wayland Plasma session?

Please install inxi using zypper or yast (if not already installed), then in an Xterm or other X terminal, do:

inxi -GxxS

and paste the output here using the code tag button ( # ]) above the input window.

Maybe I wasn’t clear enough,
I do get a one line shell promt to enter de password for de-crypting the /home partition. But that is a shell promt and not the nice graphic background with text entry field for the password.
Also de-crypting isn’t the problem.

Okay. Then I misunderstood the problem.

What this implies, is that the plymouth graphics splash screen is not showing. There is, perhaps, a text based plymouth screen as a fallback. Is I recall, that shows 3 green dots, except that the dots might be squares or question marks or some other character.

It’s some kind of graphics driver issue. Maybe you should mention your graphics card, so others with the same card can comment. I have only Intel graphics, and that seems to be working properly at present. Personally, I prefer the text screen with all of those boot messages.