2 possible problems: DNS resolution and "Networking disabled"

Worked great here; quick easy and simple.

Thank you

Done! It worked! Many thanks!

The “netconfig -f update” just worked for me too and solved the “no internet issue” in a Leap 15.0 (upgrade from 42.3). Thanks!

The “netconfig -f update” just worked for me too and solved the “no internet issue” in a Leap 15.0 (upgrade from 42.3). Thanks!

This worked for me. Deleted /etc/resolv.conf then “netconfig -f update” then rebooted to a working internet. This added two lines to the file - 1st line is “search (my domain and internet provider)” 2nd line is "nameserver xxx.xxx.x.x (router address). I am running Leap 15. The resolv.conf file had no actual configuration info in it. The internet stopped working after a system reboot for an unrelated reason. I had probably done some software updates that hadn’t required rebooting and the reboot resulted in this issue. I had been able to use our local network and access the server, but was no longer able to access the internet. I could ping various computers on our network, and could ping this computer from others. I could ping out to the internet, but could not get a response using traceroute. I had tried changing various settings with Yast’s network settings software, but this never changed the /etc/resolv.conf file. I even changed from using Wicked to the Network Manager app and activated both the ethernet card and the wifi card. I still had no internet access and this was shown on the Network Manager panel icon with a small orange ! indicating no internet access. I then went back to the Wicked network management and began the investigation that led me to this solution, but I can’t specifically identify the cause of the problem. The computer has been working fine since June with Leap 15, then it wasn’t.

Maaanythanks, it solved also for me, renamed /etc/resolv.conf and rebooted and now browsers works

You have created everything in detail, It is greatly instructive HostGator coupon code 75% off. A debt of gratitude is in order for putting aside the chance to post. I acknowledge there will be more people like me. You can similarly visit my site

I know this is an old thread, but I did exactly the same upgrade about three weeks ago and had exactly the same problem.

I went into YaST2, checked the DNS config, and found that it was not running nor was it set to start at boot time as it was in 42.3. So, I simply started the DNS, and set it to start at boot time. For me, this resolved the issue.

HTH for anyone subsequently encountering this issue.

Because the LeAP 15 DVD is frozen and can’t be updated, any problems with the DVD can’t be fixed except by an update… But unfortunately for this kind of problem, if networking won’t work then you probably can’t get an update unless you can fix the networking problem on your own.

Networking is today critical for a lot of installation functionality…


The fix is:

netconfig -f update

It renews /etc/resolv.conf

The “original post” that I am replying to is “ifconfig was dropped”. This thread was subject to it. The reason I am replying??? I just want to thank all of you, especially Carlos, Wolfi and TSU for all the info that you have provided. I have been using openSuSE for a long time. Since it was just SuSE. Always the people mentioned plus some others have had good info and advice. I miss “oldcpu” a lot. I am now old, 72, and could probably use that name -but- I am not as knowledgeable as he was. Anyway, it is 4 years now since that post was made and I just found it in a search because I just UpGraded from 42.3 to Leap 15. And I was trying to use “ifconfig”. So thanks for leaving it to be found and a double thanks for the “IP Cheatsheet”.

Cheers and have a good day,

I have had a similar problem on my OpenSuse TW after i changed the ISP.
The above solution worked for me.
Wanted to say many thanks for this.
Regards, Gigi

Glad to read that this helped you. As this is now an old thread it will be closed.