2 networks cards – NFS via route on eth1 - OpenSuse 11.3

I have a Suse 11.3 installed on a server with 2 network cards (eth0 and eth1).
Everything is set up using Yast. The drivers for the network cards are installed using drivers from Intel.

Eth0 is connected to a subnet 10.32.1.x with gateway 10.32.1.1 – works fine

Eth1 is connected directly via a crossed network cable to a NAS disk. Eth1 has the ip-address 169.254.86.86.

The NAS disk has also 2 network cards – one connected to the subnet 10.32.1.x and the other connected directly to eth1 on the server, which has been given the ip-address 169.254.86.87

The idea is to NFS mount the NAS disk via the eth1 network card, so the traffic is not limited or disturbed by any other traffic on the “real world” network on eth0.

To force the traffic to the ip-adress 169.254.86.87 (the NAS) on to eth1 on the server, I have set up a route table with “Destination: 169.254.86.87”, “Genmask: 255.255.255.255”, “Gateway: 0.0.0.0” and “Device eth1”.

I have tested the route with the ping command. It works!. When I ping 169.254.86.87 from the server, the activity is on eth1 and the response from the NAS is fine.

So here is the problem!

When I try to set up a NFS to the server, it fails. I put in the 169.254.86.87 and click on “Select”, I get a correct list of possible remote directories from the NFS server (/volumen1/nuklear). I choose a mount point on the server and the “options” are default.
So when I click ok and accept, the Yast program stops and starts the service and I get the error “Unable to mount the NFS entries from /etc/fstab”

Followed by a new error saying “YaST got signal 11 at YCP file nfd/routines.ycp.284, /sbin/yast2: line 399: 17260 Segmentation fault $ybidir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS

and the NFS mount is not working as the mounted directory on the server is emty.

If I NFS mount using eth0 on the server (the 10.32.1.x subnet) and the first network card on the NAS, it sometimes comes with the same error, but it works. The mounted directory shows the data that is on the NAS disk.

The fstab looks like this:

/dev/disk/by-id/raid-ddf1_4c5349202020202080861d60000000004711471100001450-part2 swap swap defaults 0 0
/dev/disk/by-id/raid-ddf1_4c5349202020202080861d60000000004711471100001450-part3 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/raid-ddf1_4c5349202020202080861d60000000004711471100001450-part1 /boot ext4 acl,user_xattr 1 2
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
169.254.86.87:/volume1/nuklear /nuklear/nfstest nfs defaults 0 0

And if I also NFS mount using eth0, the fstab looks like this:

/dev/disk/by-id/raid-ddf1_4c5349202020202080861d60000000004711471100001450-part2 swap swap defaults 0 0
/dev/disk/by-id/raid-ddf1_4c5349202020202080861d60000000004711471100001450-part3 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/raid-ddf1_4c5349202020202080861d60000000004711471100001450-part1 /boot ext4 acl,user_xattr 1 2
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
169.254.86.87:/volume1/nuklear /nuklear/nfstest nfs defaults 0 0
10.32.1.65:/volume1/nuklear /nuklear nfs defaults 0 0

So I have a hard time locating the problem. Is it something with the route that I have set up? – maybe NFS has a problem using routes?

Any help is appreciated.

Claus

Am 21.05.2013 12:16, schrieb claus232:
> I have a Suse 11.3 installed on a server

If you refer to a SUSE Linux Enterprise with service pack 3 then you are
on the wrong forum, this is for openSUSE.
SLES is here https://forums.suse.com

In order to make sure what you have, please post the output from


cat /etc/SuSE-release


PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.2 | GTX 650 Ti
ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.3 | HD 3000
HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.2 | GMA4500

And when you realy mean openSUSE 11.3, then that is out of support and won’t get any more security updates.

And aboy tour question, you shouldn’t need any special routings. Both systems are clever enough to route packets to a LAN network were they have an IP adddres configured. Sho the output of

netstat -rn

And when you post computter output, please do so between CODE tags, it is the # button in the toolbar of the post editor. And then do not tyype storiees like “the fstab looks like”. When you post including the cat/etc/fstab statment we will see that.

Sorry for all my mistakes - have forgotten how nice and constructive this forum is.

Anyway - I mean OpenSuse 11.3 and not Enterprice - just like I wrote it.

cat /etc/SuSE-release

openSUSE 11.3 (x86_64)
VERSION = 11.3

I have just tested on OpenSuse 12.3 - same problem.

netstat -rn

linux-e9jp:~ # netstat -rn
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
169.254.86.87 0.0.0.0 255.255.255.255 UH 0 0 0 eth1
169.254.86.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
10.32.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 10.32.1.1 0.0.0.0 UG 0 0 0 eth0

Have a nice day!

Claus

claus232 wrote:
> The idea is to NFS mount the NAS disk via the eth1 network card, so the
> traffic is not limited or disturbed by any other traffic on the “real
> world” network on eth0.

FWIW, I have used this technique and it does work. But you then have an
unusual and somewhat fragile configuration to maintain. So it might be
easier to just get faster NICs and/or bond the two NICs to increase
bandwidth over a single link.

> I have tested the route with the ping command. It works!. When I ping
> 169.254.86.87 from the server, the activity is on eth1 and the response
> from the NAS is fine.

What about when you run the ping command on the other machine. Does that
work too?

> So here is the problem!
>
> When I try to set up a NFS to the server, it fails. I put in the
> 169.254.86.87 and click on “Select”, I get a correct list of
> possible remote directories from the NFS server (/volumen1/nuklear). I
> choose a mount point on the server and the “options” are default.
> So when I click ok and accept, the Yast program stops and starts the
> service and I get the error “Unable to mount the NFS entries from
> /etc/fstab”

Personally I would give up on YaST here and edit the files manually so
you are completely sure what is going on.

> The fstab looks like this:

I would comment out the entries in fstab until you have got it working
using manual mount commands.

> So I have a hard time locating the problem. Is it something with the
> route that I have set up? – maybe NFS has a problem using routes?

You need to look at all the files and status: /etc/exports,
/proc/mounts, /proc/fs/nfs* and show us what you find if you can’t
diagnose it. Oh and the output from mount when you try to mount, but
using the -v option. And anything relevant in /vra/log/messages in the
various machines. And check carefully what version of NFS is in use.

> Any help is appreciated.

As Martin says, the first step is to confirm exactly which OS you are
running.

Where are the CODE tags! This is next to unreadable.

@djh-novell

Thanks for all your sugestions. I will try them one-by-one and return with results.

@hcvv
You are not helping. Take your lemmon attitude somewhere else please! (Didn’t know it was a moderators job to be like this!)

Have a nice day.
Claus

As a mod I try to teach new peple here as quick as possible to make usage of the forums with maximum effect. Now these CODE tags are far from obvious to find (one of the backdraws of the forums software package used) thus I have to tell again and again to new people. That is no problem at all. But when you then after reading my post, do provide the technical information I asked for, but you do as if you threw away without further explanation my request for using the CODE tags to show that information in a readable form, you already spoiled my experience in trying to help you. Thus to add a bit of lemmon to the whole recipe might be something to expect from me.

Nevertheless if you are satisfied with the help you got: Enjoy openSUSE.

claus232 wrote:
> @djh-novell
>
> Thanks for all your sugestions. I will try them one-by-one and return
> with results.

Good luck

> @hcvv
> You are not helping. Take your lemmon attitude somewhere else please!
> (Didn’t know it was a moderators job to be like this!)

Well, you were posting an answer to his question, so it would only have
been polite, and sensible. So I’ll duck out of this thread too now,
given your attitude.