2 issues with SLED 10 sp2

Hello guys,

I currently have 2 issues with SLED10sp2 which didn’t appear in original
SLED which makes me somewhat unhappy to say the least. I installed
SLED10sp2 as a new installation erasing the original version.

** 1) FLV video format**: vlc can’t play flv videos and totem only plays the
video (not the audio). It was fine in original SLED, so it may be a codec
issue (all other formats play nicely). Strange aspect is, that i installed
the very same codecs I had previously (i wrote down the list before
erasing original SLED) but in their updated versions from the original
SLED10sp2 CD and from SLED 10 Custom RPMs - pcc-services.com ; in conclusion: i’m unable
to watch the flv videos i downloaded previously. Can you guide me on which package would be causing the problem and solve this issue?

** 2) Joystick:** can’t complete the first stage to detect joystick on boot
(compiling the kernel). When i re-tried to follow the procedure from piko
Usb Joystick & Joy2key - SuSE Linux Forums ]]
(worked beautifully in original SLED), there were many errors shown on the console screen and couldn’t pass the first phase. What am i doing wrong?
Can somebody please double-check as the errors were meaningless to me and couldn’t get a hint on where to begin looking?

Thank you in advance for your replies.