2 Issues with 11.2

I have been through the whole development stage with openSUSE 11.2 (milestones/rcs etc) and now i just have installed the final version. However i still have two issues that have been following me through everything.

  1. No bootsplash, complaining about no good signatures. Is it suppose to be like that? Ubuntu, Fedora and Mandriva have all nice boot experiences while my openSUSE is just a wall of text.

  2. No sound with flash in firefox. This is a big issue for me, for some strange reason it don’t seem to be a problem with gnome just kde which makes me wonder if it’s phonon related?

Otherwise i have to give big props for this release, absolutely the best KDE experience by far.

No its supposed to have a bootsplash, however if the splash screen does not appear and your system still boots and you can use your system then I would not worry about bootsplash.
Its all effect anyhow, if bootsplash does not appear yet you can use your system i would ignore it.
Its just odd for a new user, or a longtime windows user.
But I have seen linux come up with a test bootup in the past, been a linuxer for 5 years.

  1. No sound with flash in firefox. This is a big issue for me, for some strange reason it don’t seem to be a problem with gnome just kde which makes me wonder if it’s phonon related?

It might be pulse but its hard to say, but I might have found a solution for you:

Open up the kde mixer applet (click the speaker icon in your system tray) and click the button that says “mixer”, or right click the icon and select “open mixer window”
in the mixer applet go to “settings” then “configure channels”
i suggest you put a checkmark next to pretty much everything in the window that pops up by clicking your mouse on the boxes.
Its probably one of the hidden mixer channels, for me it was “PC speaker” that solved my issue by turning it up but this may be different for you so play around with it.
Or worse comes to worst install the flash from adobe’s website, but you might have to do some configuring there too.

I haven’t experienced this problem with 11.2, but I have in the past with 11.1. Based on forum responses, I learned that the package libflashsupport sometimes causes sound issues. Make sure that package is not installed. Uninstalling that package in 11.1 fixed my sound issues with flash, and I made sure it wasn’t installed on 11.2.


Definitely, try Tarakelda’s suggestion 1st,then after that go to yast & if that doesn’t work take out pulseaudio, it seems that it & phonon hate each other.
Welcome to OpenSuSe & its forum.

Thank you TaraIkeda! It solved the issue with sound in flash, i just had to crank up the volume for PCM in kdemixer which was muted by default.

Bootsplash is not really a issue, was more wondering if it was suppose to be like that since it’s complaining about missing signatures.

Thank you all for your suggestions, a very nice and friendly forum :slight_smile: Was distro hopping before i decided on KDE and openSUSE and i must say 11.2 is just perfect!

Yes Taralkeda your solution works brilliantly! Got my flashplayer sound working now!

I also had a problem with bootsplash, i was always setting it as vga=0x365 which was supposed to be 1440x900 BUT i found that vga=0x0365 works for me :slight_smile:


I just installed 11.2 GNOME and it doesn’t display the bootsplash either; however I’ve never had this problem with previous versions of openSUSE.
Maybe it’s a problem with the display auto-configure feature I’ve read about on the forums recently; But, unfortunately, know nothing about.


openSUSE on my system displays the boot and the shutdown splash screens all right, but sometimes before showing it, it shows me a black screen with text information on it, for a second or two. Still, it probably can’t be fixed, so I’m happy. :slight_smile:

@Taralkeda: When I installed openSUSE, I had the problem that sound was very quiet on my system. Immediately I began thinking of sound drivers and became frightened. Luckily, I saw the KMix icon in the toolbar and saw that one slider was muted, and fixed that. Funny how seemingly big problems have such simple solutions. :slight_smile:


Muhammad Bin Javaid.

The black screen that flashes for a sec is GRUB :slight_smile:

I also had problems with my splash screen, fortunatelly i found my framebuffer “number” for 1440x900x24bit which is vga=0x365 (unfortunatelly this one didn’t work as i had to add additional 0 so it looked like that vga=0x0365 on the boot line AND you also need to have the splash=silent in the boot line :slight_smile: