2 directly related bluetooth questions on Tumbleweed

So, just got an upgrade to test Wifi 7 to the Qualcomm NCM865 Wifi 7 + BT 5.4 card for my Lenovo ThinkPad L14 G3 AMD.
Wifi works perfectly straight out of the box, FANTASTIC!
Bluetooth, not so much. bluetoothctl list does indeed see the bluetooth controller

chimaera:~ # bluetoothctl list
Controller 4C:82:A9:50:56:3A chimaera [default]

rfkill shows nothing hard blocked

chimaera:~ # rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: tpacpi_wwan_sw: Wireless WAN
        Soft blocked: no
        Hard blocked: no
2: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
3: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

But bluedevil shows bluetooth disabled, and bluetoothctl show lists it as unpowered and non-discoverable, which would certainly explain why KDE shows it disabled

chimaera:~ # bluetoothctl show
Controller 4C:82:A9:50:56:3A (public)
        Manufacturer: 0x001d (29)
        Version: 0x0c (12)
        Name: chimaera
        Alias: chimaera
        Class: 0x00000000 (0)
        Powered: no
        Discoverable: no

Try powering it on and/or setting it to discoverable, and it fails

chimaera:~ # bluetoothctl power on
Failed to set power on: org.bluez.Error.Failed
chimaera:~ # bluetoothctl discoverable on
Failed to set discoverable on: org.bluez.Error.Failed

So, here’s the first question. How in the world do I even figure out what bluetooth chipset it has? Neither lsusb nor lspci lists anything that stands out as Bluetooth, so even trying to troubleshoot beyond the very basics included is difficult. As luck has it, I’ve never had to really do much in the way of Bluetooth troubleshooting, so I’m clueless how to figure out what the actual chipset even is!!! (lspci does obviously show the Qualcomm 785 wifi chipset)
Second question is the obvious does anyone know if it’s possible (currently) to get this card’s bluetooth working on Tumbleweed? Without knowing exactly what chipset it is, googling has been less than fruitful for searches.

“Manufacturer: 0x001d (29)” + Bluetooth-Company-Identifiers.csv = Qualcomm

I am not a fan of WLAN-BT combo’s both can work in the crowded 2.4 GHz band on that does not work well unless the manufacturer/OS pays a lot of attention.

So if you use your WLAN in 2.4 GHz better get a separate USB dongle.

So it’s actually called Qualcomm, that’s a start.

As far as 2.4GHz and WLAN, it’s been probably close to a decade since I’ve used anything 2.4GHz for wifi. Just need to get an AP that works with 6GHz now, but the price is rather painful.

Note that moving your WiFi to 5/6G will not solve the BT problem.

I see the ThinkPad L14 Gen 3 has already 802.11 AX and Bluetooth 5.2 standard on-board. Why did you want to upgrade?

Very simple, AX isn’t Wifi 7. Wifi 7 is newer and theoretically faster than AX, and I like to play with the new standards.

And I’m not “moving” my wifi to 5/6G. I’ve been using 5GHz for over about a decade. This is a 2 year old laptop. It’s literally never seen a 2.4Ghz connection. The BT issue is in no way related in any way. I’m fairly certain it’s firmware because it works in a EndeavourOS live environment just fine.

If you AP does not support WiFi7 I see no reason why to upgrade your “STA” to WiFi7.

Because AP’s are easily unplugged and a new, replacement one is easy to plug in and replace it that does support Wifi 7. But whereas a card for the laptop is $20, the AP is ~$600. So no point in buying the AP first. Buy the cards, make sure the cards actually work, THEN spend the big money on an AP when you know the cards at least work for the core functionality.

Okay, good luck testing.

Linux is not that good in supporting “new” hardware so I am not surprised that this Qualcomm card is not supported (fully) yet.

Is seems to me the BT on the card can work:

How is the card connected, USB or PCI/M.2?

Yeah, it definitely can be made to work, like I found, it works in an EndeavourOS live session. And it’s definitely SEEING the hardware on my OpenSUSE install, just not quite able to fully utilize it yet. Given the fact that they’re using very nearly the same kernel version, that’s why I’m assuming it’s a firmware thing.

It’s an internal m.2 card.

You tried the “ControlPortOverNL80211” setting?

In the thread I read also:

Bluetooth worked until something disconnects or you try to turn off bluetooth, at which point Bluetooth becomes non-functional until powered off.

You might be better of hijacking that thread.

I haven’t done anything with that setting, no. Haven’t a clue what it even does. I’ll take a look in that thread. I also found a few possibly relevant articles today that I’ve just been too lazy to grab that laptop and test with. Thanks for the suggestion.

A little upset (with myself). Turns out, all I needed was the bluez-firmware package. Wasn’t apparently automatically installed. But installed it, restarted, and wala…working bluetooth. Very, very disappointed that it was such as simple solution and it took me so long to even LOOK at it…

1 Like

As a semi-related aside, since I have both the MediaTek 7925 and Qualcom NCM865 Wifi 7 + BT 5.4 cards up and running now on wifi and BT, I ordered a Wifi 7 router yesterday. Found an open-box sale on the TP-Link BE19000 (Arch BE800) for <$400, so got that coming.