2 computers now useless after upgrade to Leap 15

I have two machines which worked just fine with Leap 43.x.x. After updating both to 15 I am constantly bombarded with kwallet screens which won’t go away. I have disabled the subsystem in the config but no joy. kwallet is still there. I can’t use the samba shares or WiFi and several others. I never used kwallet before and so never had a password. I have tried to put one in, even a blank one, but nothing works. Wallet just won’t go away. I don’t want it. I don’t need it. I just want Leap 15 to function as well as 43.x.x did.
Any ideas welcome.

Welcome to openSUSE Forums mart998. It can be frustrating when an OS upgrade presents unexpected changes/challenges with operational behaviour. One workaround with respect to Network Manager wireless connection credentials is to edit the connection and it a “system connection” with the password being stored system-wide in the connection profile instead (ie not via kwallet).

I recommend starting a new thread for you samba issue. Use a descriptive title to attract the attention of those who may be able to help.

Thanks for that. I have got round the WiFi thing by leaving the cable connection that I used during the upgrade. It can stay like that for the moment.
Samba is very important but there are other things affected too.

In general, it’s best to create separate threads for individual issues (unless you think they’re somehow related). I’m sure you’ll sort out some of these for yourself, but lots of volunteer support around if/when you need it. :slight_smile:

To put it in strong wording: It is very unlikely that the Samba gurus will open a thread where there is not at least the keyword Samba in the thread title.
You must advertise your thread to make it attractive for people to open it.

Here’s how to deal with the “kwallet” issue.

Step 0: If you use automatic login, then turn that off.

Step 1: logout from your desktop.
Step 2: login to Icewm. I think you won’t be prompted for kwallet with an Icewm login.

Step 3:

cd ~/.config
rm kwallet*

Step 4:

cd ~/.local/share
rm -rf kwalletd

Step 5: Logout from Icewm and login to KDE. You should no longer have kwallet problems.


When you upgrade from 42.3 to 15.0, “pam_kwallet” is installed. However, if you do a clean install, then “pam_kwallet” is not installed unless you select it. So, in your case, “pam_kwallet” was installed.

Normally, “pam_kwallet” wants to open “kwallet” during login. And it is persistent and annoying about that. I’m pretty sure that’s what you were seeing.

The steps that I suggested are to remove “kwallet”. The effect should be that a new “kwallet” is created on your next login. And it will be configure to use your login password and be automatically opened during login. So it will do it’s job silently without the annoyance.

However, autologin does break this, because kwallet_pam needs access to your login password during login in order to automatically open “kwallet”.

On 9/17/18 6:56 AM, hcvv wrote:
> mart998;2880519 Wrote:
>> Samba is very important …
> To put it in strong wording: It is very unlikely that the Samba gurus
> will open a thread where there is not at least the keyword Samba in
> the thread title.
> You must advertise your thread to make it attractive for people to open
> it.

Perhaps a better title here would have been
“KWallet insists on inputting a password.”

Then we could see that all of the @OP issues are related to KWallet.

unix since 1986
S.u.S.E.-openSUSE since 1998

Completey agreed. I even tend to skip posts stating “useless”, “completely broken”, “too buggy” and so and leave them for whatever’s left of my spare time.

Thank you for all the help. I have had enough of the problems with openSUSE 15 and have re-installed 42.3 on one of the machines which now functions as before. On the other machine I have installed Windows to run my multimedia stuff on my projector because samba is just too painful.
Problems solved !

Thank you all again.

Those read like workarounds than solutions, but I guess you need to use what works for you.

Yes, probably far easier than investigating the problem and finding the solution.

In my own case, I have moved several machines to Leap 15.0 without any issues, all running superbly.

Please confirm that, from within the KDE System Settings, section “Personalization”, module “Account Details”, sub-section “KDE Wallet”, tab “Wallet Preferences”, you unchecked the box “Enable the KDE wallet subsystem” and then pressed the button “Apply”.

Please check the following:

  • Edit “~/.config/kwalletrc”, section “[Wallet]”, parameter “Enabled” – check that it is set to “Enabled=false” …

Is there anything within the KDE System Settings, section “Workspace”, module “Startup and Shutdown”, subsection “Autostart”, which possibly starts the KWallet Manager on login?

  • Check Plasma Desktop’s System Tray for a running KWallet Manager …

Please be aware that, the KDE module for the “Network Manager” and, applications such as KDE’s Kontact PIM suite, will attempt, by default, to use the KWallet system for storing the passwords needed to access WLAN access points and e-Mail servers …

This KDE URL describes how to use the KDE Wallet Manager to “tell” applications that, they shouldn’t be using the KWallet sub-system: <https://userbase.kde.org/KDE_Wallet_Manager&gt; – "go to Settings -> Configure Wallet… -> Access Control, and there adjust application settings …