[2.6.37.6-0.20-desktop online update failure] Modules and (consequently) X server can not launch

Greetings,

I did a “online update” (needed patches) and at reboot there was a blank screen.
Booting in safe mode I opened the /var/log/messages file and these are the “seemly” interresting messages:

Aug 14 01:16:41 antares modprobe: FATAL: Could not load /lib/modules/2.6.37.6-0.9-desktop/modules.dep: No such file or directory

When doing ls -lah on the /lib/modules directory:

drwxr-xr-x 12 root root 4.0K Aug 14 01:38 .
drwxr-xr-x 13 root root 4.0K Aug 14 01:16 ..
drwxr-xr-x  3 root root 4.0K Aug 14 01:16 2.6.37.6-0.11-desktop
drwxr-xr-x  2 root root 4.0K Aug 14 01:16 2.6.37.6-0.20-debug
drwxr-xr-x  6 root root 4.0K Aug 14 01:16 2.6.37.6-0.20-desktop
drwxr-xr-x  2 root root 4.0K Aug  3  2011 2.6.37.6-0.5-debug
drwxr-xr-x  3 root root 4.0K Aug 14 01:16 2.6.37.6-0.5-desktop
drwxr-xr-x  2 root root 4.0K Nov 19  2011 2.6.37.6-0.7-debug
drwxr-xr-x  3 root root 4.0K Nov 19  2011 2.6.37.6-0.7-desktop
drwxr-xr-x  2 root root 4.0K Aug 14 01:16 2.6.37.6-0.9-debug
drwxr-xr-x  4 root root 4.0K Aug 14 01:16 2.6.37.6-0.9-desktop
drwxr-xr-x  3 root root 4.0K Aug 10 14:30 fglrx

The file modules.dep is located in 2.6.37.6-0.20-desktop.
How can I specift at boot that this file is no more located in /lib/modules/2.6.37.6-0.9-desktop/ but in the right directory ?
Should I “rmize” all the other directories ?

Concerning the X Server that won’t start:

Aug 14 01:20:44 antares kdm[1092]: X server died during startup
Aug 14 01:20:44 antares kdm[1092]: X server for display :0 cannot be started, session disabled

Which session is about ?

The Xorg.0.org has been overwritten with the log for this session (safe mode)… so it can’t help.
Should I start in run level 3 and then try a startx ?

I disabled the vmware and vmtoolsd services following the boot.msg informations:

Failed services in runlevel 5: vmtoolsd vmware

I’m back untill I tested if the chkconfig has fixed the issue.

This thread may be usefull if someone else experienced same issue.

nope… it does nothing… the keyboard id unresponsive and the screen is blank… no hard-disk “movements”…

kdm.log:

X.Org X Server 1.9.3
Release Date: 2010-12-13
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux antares 2.6.37.6-0.20-desktop #1 SMP PREEMPT 2011-12-19 23:39:38 +0100 x86_64
Kernel command line: root=/dev/disk/by-id/ata-ST31500341AS_9VS1WYY5-part1 resume=/dev/disk/by-id/ata-SAMSUNG_HD321KJ_S0MQJ9DQ217875-part1 splash=silent quiet vga=0x345
Build Date: 07 February 2012 04:30:59PM

Current version of pixman: 0.20.0
Before reporting problems, check X.Org Wiki - Home
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Tue Aug 14 02:16:43 2012
(==) Using config file: “/etc/X11/xorg.conf”
(==) Using config directory: “/etc/X11/xorg.conf.d”
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:3) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:4) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:5) found
FATAL: Module fglrx not found.
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
/usr/bin/Xorg: symbol lookup error: /usr/lib64/xorg/modules/drivers/fglrx_drv.so: undefined symbol: GlxInitVisuals2D

…that’s the explaination I think → I recently added a driver to have 1920x1080 resolution…

How can I fix this issue ? Uninstall the ati radeon HD driver ?

I put the content of 2.6.37.6-0.9-desktop (where fglrx is located) and put it in 2.6.37.6-0.20-desktop…

added the absolute path to fglrx.ko in modules.dep file…

…very bad idea !! Believe me ^^

I used depmod absolute path to the ati driver but it set the driver for the video card only and then all the other modules were not loaded…
So depmod -a solved this mess…
Now as I saw in the modules.dep that the driver was added I will try a “normal” boot… back in minutes… (gettin’ tired)

nope…
The X Server won’t start…

The “modules” issue seems to have been solved… at least there is no more messages refering to old /lib/modules directory (by disabling the services linked to vmware)
The “fglrx” issue seems to have been solved… there is no more messages in the logs refering to the unavailability of this module

The question is: how can I get the X Server back ???

Aug 14 03:09:54 antares kernel:    25.443102] fglrx: Unknown symbol acpi_lid_notifier_register (err 0)
Aug 14 03:09:54 antares kernel:    25.443632] fglrx: Unknown symbol acpi_lid_open (err 0)
Aug 14 03:09:54 antares kernel:    25.444453] fglrx: Unknown symbol acpi_lid_notifier_unregister (err 0)
Aug 14 03:09:55 antares kdm[1137]: X server died during startup
Aug 14 03:09:55 antares kdm[1137]: X server for display :0 cannot be started, session disabled

that is as good as:

Aug 10 14:28:02 antares kernel:    56.060090] [drm:radeon_vga_detect] *ERROR* VGA-1: probed a monitor but no|invalid EDID   
Aug 10 14:28:02 antares kernel:    56.060910] i2c i2c-0: sendbytes: NAK bailout.
Aug 10 14:28:02 antares kernel:    56.627200] [drm:radeon_vga_detect] *ERROR* VGA-1: probed a monitor but no|invalid EDID   
Aug 10 14:30:13 antares kernel:   187.119263] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GE
Aug 10 14:30:13 antares kernel:   187.119268] Disabling lock debugging due to kernel taint

trying starting run level 3 at least…

Nice one-sided conversation. But you never ever mentioned which level of openSUSE this all is about.

It is a bad idea to copy kernel modules from an older version of the
kernel to a newer version, unless someone knows better I would say that
is a recipe for disaster.
From your kernel version I guess you run 11.4, but it would help if you
confirm that.

Tell us how you originally installed the fglrx driver, I am not familiar
with it since I did not use ATI cards for years, but when a newer kernel
is installed you most likely need to run atiupgrade again to rebuild the
kernel modules properly.


PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.5 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

atiupgrade doesn’t rebuild the kernel module, but it knows that it is going to happen - following the installation of the fglrx package. Therefore it installs the kernel source if it is missing and makes sure that the running kernel matches the kernel source. Once both kernel and kernel source are installed, they should normally get updated together - unless you manually explicitely update the kernel but not the kernel source, which is a bad idea.

Further **/etc/init.d/boot.fglrxrebuild **is responsible for rebuilding the kernel module after a kernel update. As the name and the location indicate, this service is run at boot. There is normally nothing to do, but if you are in doubt, you can run the following command:


# /etc/init.d/boot.fglrxrebuild status
Check for rebuild the fglrx kernel module if necessary ...
   The fglrx kernel module was already built.
Check for the fglrx kernel module is running...
                                                                                                                           running

Don’t move kernel modules around or change symlinks! It’s not the way to solve problems.

And before doing anything with kernel modules…

check the running kernel version:


# uname -r
2.6.37.6-0.20-desktop

check which kernel and kernel devel packages are installed:

# rpm -qa | grep '^kernel'
kernel-source-2.6.37.6-0.20.1.noarch
kernel-firmware-2.6.38-1.2.1.noarch
kernel-default-devel-2.6.37.6-0.20.1.x86_64
kernel-desktop-2.6.37.6-0.20.1.x86_64
kernel-desktop-devel-2.6.37.6-0.20.1.x86_64
kernel-devel-2.6.37.6-0.20.1.noarch
kernel-syms-2.6.37.6-0.20.1.x86_64
kernel-xen-devel-2.6.37.6-0.20.1.x86_64

and make sure that /usr/src/linux points to the right directory and that this directory exists:

# find  /usr/src/linux -maxdepth 1 -ls
2506950    0 lrwxrwxrwx   1 root     root           19 Jul  7 12:23 /usr/src/linux -> linux-2.6.37.6-0.20

They should all be the same version or your modules are not going to compile (i.e fglrx, vboxdrv or whichever module vmware is using).

Greetings.

Yes, I omited to specify that I was working on a SuSE 11.4 KDE.

I tried to find a way to rebuild the module for the ATI but I have no fglrxrebuild nore atiupgrade program to help me so.
I tried with zypper to find something but I think the repositories for ati drivers are not set.
zypper repos confirmed → no repositories for ATI.
I jumped on the additional packages and there is nothing for ATI… the link is dead…
My X server only works on safe mode… I can reach run level 5… but in the “normal boot” there is nothing…
I will get the dvd and reinstall the whole ting that starts to seriously take on my nerves… ****ing update… I had a bad feeling starting it and I now I know why…

http://forums.opensuse.org/english/other-forums/development/programming-scripting/449058-upgrading-ati-driver-atiupgrade-20.html#post2475905

You are probably now creating more bewilderment. There is openSUSE (that is the subject of these forums) and there is SUSE Linux (SLES/SLED). When you say SuSE that is none of both. openSUSE has a version 11.4 and I know that SUSE Linux has a version 11 with several service packs, but I do not know if there is a service pack 4.

When you are not able to provide the correct operating system and it’s version by heart, you can post here he output of:

cat /etc/SuSE-release

I’m very sorry, I have an evident lack of toughness concerning the handling of this issue.

openSUSE 11.4 (x86_64)
VERSION = 11.4
CODENAME = Celadon

This is the “level” of the openSUSE I’m working with.

I found a build_mod folder and I did in safe mode the ./make.sh then ./make_install.sh

The results are:

make[1]: Leaving directory `/usr/src/linux-2.6.37.6-0.20-obj/x86_64/desktop'
build succeeded with return value 0
.
duplicating results into driver repository...
target location: /lib/modules/fglrx
the debug info stripped from the kernel module
copying fglrx.ko
copying logfile of build

…so I assume that the module is now compiled for the new kernel.

 fglrx.ko -> ./fglrx.2.6.37.6-0.20-desktop.ko

was previously

glrx.ko -> ./fglrx.2.6.37.6-0.9-desktop.ko

So, without rash conclusions, it may let the X Server to boot… untill I detect another anomaly ^^

I’ll reboot from “safe mode” and then go back if it works better (or not) ^^

Argh !! Same issue…

The X server died at startup…

/var/log/messages

Aug 14 16:43:55 antares kdm[1323]: X server died during startup
Aug 14 16:43:55 antares kdm[1323]: X server for display :0 cannot be started, session disabled 

/var/log/kdm.log

usr/bin/Xorg: symbol lookup error: /usr/lib64/xorg/modules/drivers/fglrx_drv.so: undefined symbol: GlxInitVisuals2D

This is the result of a locate (I didn’t executed updatedb):

[root]antares:/var/log # locate fglrx_drv
/usr/lib64/xorg/modules/drivers/fglrx_drv.so

…so the entry has been removed…

What are the suggestions ?

I told you in another thread to use atiupgrade. All you have to to is to download this script, make it executable and run it. You should NOT need to do anything else. There is another version of atiupgrade in my repo, that you can install with zypper, but this version would install the wrong driver for your graphics card unless you tell it explicitely to install version 12.4 (which was the last version which supported all models of HD radeon).

Of course you can compile the driver with make, etc … but you won’t have a package in this case, and I’m not sure the module will get recompiled automatically next time you update the kernel.

Just another information but i don’t know if it is efficient:**

./check.sh** (from the ATI driver directory)

[root]antares:~/installz/ati/AtiDrivers # ./check.sh 
Detected configuration:
Architecture: x86_64 (64-bit)
which: no XFree86 in (/sbin:/usr/sbin:/usr/local/sbin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/mit/bin:/usr/lib/mit/sbin)
X Server: unable to detect

Yes it works that was the point I said that I haven’t the atiupgrade program and was unable to find it untill you gave me the link.
Now it works but there is a “AMD testing use only” at the lower right corner…
It is supposed to be disabled ?

I did atiupgrade 12.4
it has been solved…