15.5 Leap boots to grub prompt

Since upgrading from 15.4 to 15.5, I can’t boot. I have to boot a live installation USB and then select “Boot from Hard Drive”. It starts. I use YaST to update grub2-efi. I start YaST again and it shows 15.5 as the only option. I reboot. I end up at a grub prompt. Any suggestion?

Are you able to change the boot order in BIOS? I’ve had to do that before with UEFI Linux installs.

Tried that, no change.

Booted SuperGrub2 on USB and it ended in a blank screen.

Just curious, does your BIOS have the option for UEFI boot order? Just want to rule that out before digging in deeper.

Yes it does have it.

And you have tried changing the boot order there as well, right? The UEFI boot order is different from the boot device order just to clarify.

Let’s start with basics. Show output of

efibootmgr -v

I think I found a solution. I normally have the BIOS set to UEFI for booting Ubuntu on another drive. The onboard drive and the swap drive are exactly the same Barracuda model, are listed identically in BIOS setup. If I switch to CSM Leap does boot.

1 Like