15.2 not starting after update

i have an odd problem. Running 15.2 KDE Plasma, last updated in early June using zypper refresh/update procedure. Today I started my system and ran zypper, it updated among many items, the kernel (using kernel stable repo) to 15.12.9-3 to 15.12.12-1.
Now I cannot start. I get the grub boot screen but the nothing happens once the kernel starts. I have tried advanced options with prior kernels (I have 4 default kernels in that list), same problem. I was able to start using a snapshot but to my dismay each time I tried to do something the snapshots overwrote and now I have no bootable snapshots either.

The screen has a blinking cursor for a few seconds then the cursor either stops blinking or disappears leaving a totally blank screen. I do have hard drive activity for a short while (presume this is copying the kernel stuff that I’ve selected in advanced options). The drive activity does not last as long as a typical startup so I presume it is hanging quite early in the startup.

I cannot switch to a virtual console to login.

While snapshots were still useable I saw in the messages log a possible problem with loading Getty.

I do have a Leap 15.0 CD which has a choice to start a shell but I have not figured out how to do anything with it.

Any suggestion on how to move forward in this situation?

Boot with “quiet” removed from and “plymouth.enable=0 debug” added to kernel command line, this may provide some more information.

Thank you.

This gives me a “hang” at the following lines after detecting the usb ports:

[drm] radeon kernel modesetting enabled.
fb0: switching to radeondrmfb from VESA VGA

There is further disk activity indicated by the HD light but no further screen output.

My display is an HDMI TV but until the update I did today it worked fine from 4.2 thru to 15.2


Can you please, give us an indication of the hardware you’re using?

 > inxi --graphics --filter --admin

Also, the Kernel Command Line would be useful –

 > cat /proc/cmdline

If possible, also, an extract of the systemd Journal –

 # journalctl --this-boot --no-hostname --output=short-monotonic | grep -i 'radeon'

Same problem using amdgpu - solved using old kernel-firmware instead of 20210609-35.1

I wish I could execute those commands but I cannot get a commandline.

That said, this computer has an onboard video card that I am not using. It is an Intel VGA compatible controller. There is no bios entry for this so I cannot disable it. Interestingly it uses a driver module of “drm” and that seems to be where the boot stops. This info is derived from a file I saved to another computer in 2016. The video card I’m using, which came with my computer, is a Advanced Micro Devices, Inc. [AMD/ATI] Turks PRO [Radeon HD 7570], I don’t know which driver it is using.

I’m thinking I can remove the Radeon card and plug in an old video monitor. I might then get to a commandline. In light of the above info I am doubtful that this will work.

I’m also considering downloading the 15.3 DVD install and trying to perform an upgrade. I was going to do a online upgrade in a few weeks so maybe this can be done now. Not sure if it will work tho.

The comment by @MonsieurChat is interesting. Not sure how I can go back since I can’t boot.

Download the OpenSUSE Network Image - boot - choose UPGRADE - and ONLY “upgrade”/downgrade the kernel-firmware to the one provided by the Main-Repository.

Thanks! this sounds good. Have you upgraded to 15.3? I wonder if it has same problem

Solved. Suggestion by @MonsieurChat fixed my issue.

Did you report it? What is bug number?

Not even a Virtual Terminal (VT)?

  • tty1 … tty6
  • <Ctrl-Alt-F1> … <Ctrl-Alt-F6>

yes, not even tty1…6. I know how to use it. It did not work.

came to say that I’m having the same issue: system is not booting suspect that the update of the kernel-firmware-amdgpu package is the reason. (now installed version: 20210609-35.1)

just in case it might help diagnosing/fixing the problem:

I running Leap 15.2 but besides the stock kernel (5.3.18-lp152.78-default) I ran the latest kernel from OBS-Kernel (https://download.opensuse.org/repositories/Kernel:/stable/standard ; version: kernel-default-5.12.12-2.1.g43254cf). Only the version 5.12.12-2… is affected by the boot crash.

the info requested in another message in this thread (this info is when running the stock 5.3.18-lp152.78 kernel, since 5.12.12 does not boot):

 # inxi --graphics --filter --admin
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir vendor: Lenovo driver: N/A bus ID: 07:00.0 
           chip ID: 1002:1636 
           Device-2: Chicony type: USB driver: uvcvideo bus ID: 2-2:2 chip ID: 04f2:b6d0 serial: <filter> 
           Display: server: X.org 1.20.3 compositor: kwin_x11 driver: ati unloaded: fbdev,modesetting,radeon,vesa 
           tty: 118x26 
           Message: Advanced graphics data unavailable in console for root. 
# cat /proc/cmdline 
BOOT_IMAGE=/boot/vmlinuz-5.3.18-lp152.78-default root=/dev/mapper/root-root splash=silent mitigations=auto quiet
# journalctl --this-boot --no-hostname --output=short-monotonic | grep -i 'radeon'
    0.360299] kernel: smpboot: CPU0: AMD Ryzen 7 PRO 4750U with Radeon Graphics (family: 0x17, model: 0x60, stepping: 0x1)

the last message I see before the boot stops:

[2.528...] [drm] amdgpu kernel modesetting enabled
[2.529...] amdgpu: Topology: Add CPU node
[2.530...] fb0: switching to amdgpudrmfb from EFI VGA

Hope there is a solution soon.

<EDIT>: apparently the old version(s) of the kernel-firmware-amdgpu package are gone? Why would someone do that?

Manged to solve my problem thanks to this other thread:

The steps:

  1. Install “old”/stable version of the firmware-amdgpu package (had version: 2021-06-09) with vendor-change.

    zypper in --oldpackage

  2. previous step rebuilds the initrd for the current kernel version, but I run the latest stable, so rebuild initrd for that as well:

    dracut --kver 5.12.12-2.g43254cf-default --force

  3. reboot, select the Grub option for 5.12.12

  4. optional: lock the kernel-firmware-amdgpu package to remind myself to check out 1 a year if this bug is solved :wink:

    zypper addlock kernel-firmware-amdgpu

Thanks for this suggestion. I have done the same. However, since I plan to do an online upgrade to 15.3 I wonder about the wisdom of doing this.