15.2 Gnome Classic unable to move certain folders and files on Desktop

I’ve got a real headache, although the issue may be considered minor. I use Gnome Classic on 15.2. I’ve asked about a couple of issues, and this one ties into the others IMO.

There are certain folders on my desktop that no matter what I do, I can’t arrange them how I want. For instance, one of them contains my dissertation research. I can move it to other folders (which I do NOT want to do), but if I try to move it’s location from the leftmost edge of the main desktop (central monitor on three monitor setup) to another position, it won’t move. I click on the folder to move it, but it seems to ‘stick’ to the cursor and will not release in any other position than the original. If I move it to another folder (like Documents), and replace the blank space with a different file, as soon as I try to move Dissertation back, the file that was where it was originally located gets moved (randomly) elsewhere on the desktop and the Dissertation folder goes back to its original location. This activity is true for several folders and files - the big thing is that they’re all on the left edge of the main desktop screen. I’ve always kept that area for certain specific folders and apps that I regularly use/access but not enough to try to place them on a taskbar (which I still cannot do).

I’ve got Gnome Tweaks, Dconf editor, and nothing there applies to any of the (minor but vexing) issues I see. (I also have some trouble moving items to the desktop, but have learned that to do so I have to open the desktop as a folder, open the original location - and copy and paste the file over.)

I’ve checked the permissions for the folder, and checked for additional setup options under both the home folder and under the computer folder. Nothing improperly set there.

(1) Where do I find (for instance) folders related to what shows on the desktop and in the menu bars, so I can see if I can edit things and fix this (and other problems)?

(2) Is there a program available under YAST or Software that would deal with this?

(3) Has anyone encountered this issue in Gnome Classic?

Note: I’m sticking with Gnome Classic. It’s the most efficient one for the sort of things I do.

Thanks for any help!


AFAIK the classic desktop is controlled by system extensions, as in hard coding, not sure if installing the upstream version would override the system version…

That extension was already there - part of the original setup, I think. I tried a few other extensions, but so far nothing has changed the issues I’ve encountered.

I think there should be a file with code, listing the icons and their locations. I just don’t know what to look for or even where to look. Such a file might give a hint as to why certain icons cannot be moved.

Thanks for the suggestion! I’m hoping that someone will recognize the issue and have a workaround or solution!


More information that might help figure this issue out!

I did some searching (again, I’ve spent hours looking). In most cases I see an option for “Desktop” in Gnome Tweaks. I also see (in a couple of instances) “Advanced Settings”. “Advanced Settings” is mentioned in several articles.

I don’t show that in my version of Gnome Tweaks. I installed an extension that is supposed to enable (or help you to) editing the Desktop. In that module, it looks for a gui-based SUDO type access - either gksu or beesu. However, I cannot find those anywhere in Software, Yast, or the Gnome Extensions.

As a test, if you log out and select SLE Classic, how does that go? If you create a test user and login, (classic) does it help?

Nope. SLE Classic just moved the taskbar to the bottom and changed the layout a bit. I also tried regular Gnome. I then created a new user and logged in there in Classic. No icons or anything, of course - I had to add some to the Desktop and set it so that they showed. Same problem - some of the icons could be moved, others could not (just ‘stuck to the cursor’). No detectable pattern. It’s a puzzle!

I also checked the other issues - Desktop didn’t show in “Places”, and I couldn’t add programs to the taskbar. However, I have found one extension that added a button for Desktop to the top taskbar. It works, so that’s dealt with - instant access.

It’s strange. I’ve checked the permissions for the folders that won’t move - no different than those folders I can move. I did some digging in the ‘guts’ of the system, but… too much to dig through.

Thanks for replying and trying to help! It IS greatly appreciated!

I’m on Leap 15.3 and could add/move desktop icons in the SLE Classic desktop (well any files in the ‘Desktop’ folder). It was an upgrade from Leap 15.2. Do you have any additional shell extension installed?

Here is a list of the installed extensions, including some comments for most of them. I had to re-install Gnome Classic, as I lost it when I turned some of the extensions off.

In any case, off or on (for all of them), no difference to the problem.

Add on desktop
Applications Menu (removed and added - no difference)
Bluetooth quick connect (going to disable and use it only when needed)
Desktop Editor - this looks for gksudo or beesudo. Installed today… no difference detected.
Desktop Folder - added today, makes it easier to work with files.
Desktop Icons (by rastersoft) - I think this one was there in the beginning.
Horizontal Workspaces - also there all along. Disabling it doesn’t change problems.
Launch new instance - removed, no difference.
Places Status Indicator - off, on, no difference.
SLE Classic - removed - no difference
System Menu - off or on, no difference. Original file.
Tray Icons - removed, no difference
UTC Clock - one I added, very useful.
Window List - Also original. I’ve tried turning it off… no difference.

How long has 15.3 been out? I am usually quite reluctant to jump on the newest version until at least a few months have past, because of all of the problems usually found in the beginning. If it’s been long enough to settle down, I may try an upgrade from 15.2 to 15.3.

I would suggest waiting if not in a rush, Leap 15.3 went gold on 05/26… My test was SLE Classic, not GNOME Classic, likewise just a test machine and only the oss/update repos active when moving from 15.2 to 15.3.

Thanks for the tip! I learned a long time ago (early 80s) to not jump on the latest and greatest because usually bugs needed to be found and weeded out. I even wrote a short piece (put up on a BBS) about my experiences with an upgrade to a new OS on an old 8 bit computer - and what it took to get my data and software back out and operational again (part of a review of different OSes used on an early Atari system). I’m in no rush, although I’d really like to get this bug figured out. The way I have things arranged (and what I’m used to) - this bug has become a major irritation (I did notice it when I first started trying out OpenSUSE.

I hope that someone who has a good understanding of the “innards” of the Gnome Classic desktop would see this thread and could point to folders or files where the actual information is stored (folder and position on the desktop for instance). Then maybe I could get it figured out and fixed from there.