15.0 original partition still exists, prompts mount request login

The full install on my desktop was Leap 15.0, followed by upgrade to 15.1, with subsequent upgrade to 15.2 release. When I performed the latest upgrade there were existing partitions for 15.0 and 15.1, and I chose to install on the latter. The install went fine but the 15.0 partition still exists. I now get prompted for root login to mount this partition on /dev/sda3.
While I found that I can edit that partition to not mount, I am wondering about the proper way to remove references to this older installation and reclaim space?

Here is the output from df -l:
Filesystem 1K-blocks Used Available Use% Mounted on
devtmpfs 3993540 8 3993532 1% /dev
tmpfs 4004228 37716 3966512 1% /dev/shm
tmpfs 4004228 9836 3994392 1% /run
tmpfs 4004228 0 4004228 0% /sys/fs/cgroup
/dev/sda5 41943040 21785924 19372572 53% /
/dev/sda5 41943040 21785924 19372572 53% /.snapshots
/dev/sda5 41943040 21785924 19372572 53% /srv
/dev/sda5 41943040 21785924 19372572 53% /opt
/dev/sda5 41943040 21785924 19372572 53% /boot/grub2/i386-pc
/dev/sda5 41943040 21785924 19372572 53% /var
/dev/sda5 41943040 21785924 19372572 53% /tmp
/dev/sda5 41943040 21785924 19372572 53% /boot/grub2/x86_64-efi
/dev/sda5 41943040 21785924 19372572 53% /root
/dev/sda5 41943040 21785924 19372572 53% /usr/local
/dev/sda6 882143392 66248684 815894708 8% /home
tmpfs 800844 16 800828 1% /run/user/1000
/dev/sda3 41946112 20119324 21347620 49% /run/media/fuscop/de64cdf9-2e96-4267-8ebb-3bb5e64935d6

When you next boot, login to “icewm” instead of to your usual desktop environment. There should be an option on the login screen (unless you have it set for auto-login).

Are you still prompted to mount the partition?

If not, then the request to mount is coming from your desktop configuration rather than from the system.

Can you tell us which desktop environment you normally use?

Logging in with icewm did NOT replicate the prompt for login. I gave it a couple of minutes and then logged out. As soon as I logged back into Plasma (no Wayland) I received the prompt.
Plasma 5.18.5 running on Leap 15.2

A couple of additional notes. On my first restart after the installation completed, the grub menu listed both 15.2 and 15.0 with kernel/other options. The 15.0 choices went away at some point. Also, when I first looked at the Boot Loader options in YaST the dropdown listed both 15.2 and 15.0 choices similar to the grub menu. The 15.0 choices are also gone from here, leaving the 15.2 choices with options for latest kernel/previous kernel. The only change I made in the Boot Loader was to uncheck Probe Foreign OS since this isn’t a multi-boot system.

That would already explain why the 15.0 choice disappeared from the menu.

Here’s my suggestion:

System Settings → Startup and Shutdown → Desktop Session

It is probably set to “Restore Previous Session” (that’s the default).
Change that to “Start with an Empty Session”.

See if the problem goes away.

I’m guessing that you mounted it at some time in the past. And since on login you restore previous session, that is why it is mounting each time.

If that solves the problem, you could later go back to “Restore Previous Session” as long as you remember to never mount during that session. Or switch to “Restore manually saved session”, and then setup your session the way you like and save it. Save-session is in the “Power/Session” part of the main menu. After that, it should always start up the way you like it.

No that didn’t prevent it, still getting prompted. Since I noticed previously that /dev/sda2 and /dev/sda3 (the original swap and btrfs partitions for 15.0) are being identified as Windows data partitions I decided to look at my UEFI settings. When I turned off the Compatibility Support Module it booted to a grub menu with 15.0 only and didn’t complete. After rebooting and enabling the Compatibility Support Module I looked at Boot Option/Order. The choices I have are as follows:
opensuse-secureboot (P1: WDC WD10EZRX-00L4HB0)
P1: WDC WD10EZRX-00L4HB0 (953869 MB) This one was default and boots to the 15.2 grub menu

Disregarding the external DVD (HL-DT…) the UEFI OS and opensuse-secureboot choices both try to boot to 15.0 and fail. I’m not sure how to include a picture of the Partitioner GUI so I’ll include the “fdisk -l” results instead to show the Windows identification on those two partitions:
Device Start End Sectors Size Type
/dev/sda1 2048 321535 319488 156M EFI System
/dev/sda2 321536 4530175 4208640 2G Microsoft basic data <=== This is the 15.0 swap
/dev/sda3 4530176 88422399 83892224 40G Microsoft basic data <=== This is the 15.0 btrfs
/dev/sda4 88422400 88438783 16384 8M BIOS boot
/dev/sda5 88438784 172324863 83886080 40G Linux filesystem
/dev/sda6 172324864 1937473535 1765148672 841.7G Linux filesystem
/dev/sda7 1937473536 1953525134 16051599 7.7G Linux swap

I’m not sure what to do at this point outside of a clean install. I hate doing that since the upgrade (outside of this issue) was successful and everything else is running smoothly. I suppose I should have deleted those partitions during the upgrade but wasn’t sure. I appreciate your help though and will check back. Thanks!

That the partition says “Microsoft basic data” is not actually a problem.

Try creating a new user. Does the same thing happen when you reboot, and then login as that new user?

Perhaps look at changing the partition type to what they should be, sda2 type 8200, sda3 type 8300 via gdisk?

You can actually hide the partitions as well via a udev rule?

vi /etc/udev/rules.d/99-hide-disks.rules


udevadm trigger

umount /dev/sda2 /dev/sda3

I see your point on the “Microsoft basic data”. I suppose that’s why unchecking that “Probe Foreign OS” box in Boot Loader prevented those 15.0 entries from showing in the grub menu at startup, as well in the Default Boot Section within the Boot Loader GUI.
Okay, on to the test user. No, the prompt did not appear when I logged in as that user.

Also, I haven’t specifically asked, but do I actually need those two partitions? I can see there is an option to delete in the Partitioner, as well as a format option under Edit, but wasn’t sure if either would be advisable.

I’ll keep that hiding option in mind in case that ends up being the only option. Thanks!

So the problem is somewhere in your user settings.

Also, I haven’t specifically asked, but do I actually need those two partitions? I can see there is an option to delete in the Partitioner, as well as a format option under Edit, but wasn’t sure if either would be advisable.

You probably don’t need them. But you would know that better than I would.

Here’s my concern. If you delete the partition, but there is something in your settings that wants to mount that partition, then you may get a weird error message.

Actually as long as 15.0 remains intact on /dev/sda3 you do have a multiboot system. As long as you keep probe foreign enabled, and both 15.0 and 15.2 are both installed in the same mode (both legacy vs both UEFI), 15.0 should be in the boot menu, and available to boot in case you need to make repairs to a corrupted 15.2 installation. It won’t hurt anything to keep 15.0 installed as long as you have adequate freespace on 15.2. You can eliminate the prompting to mount by adding sda3 to 15.2’s fstab, and configuring it to automount same as anything else, or not mount at all by using the noauto option.

AFAIKT, user is booting UEFI (sda1 is efi)…

+1 on the user settings, thanks for the suggestion of creating the test user.
+1 on the comment about removing those partitions, that was/is my fear. I don’t want go down the rabbit hole of creating another, possibly worse issue that might impact functionality.

I’m going to enable probe foreign and then check if I can actually complete booting to the prior 15.0 environment.
If that is okay I’ll move on to editing fstab. I’ll have to read up on it since I’ve never messed with that. Seems worth learning though.
Thanks very much to you (and Malcolm) for your assistance. I’ve already learned some things that will be valuable going forward.

I read this thread and want to add an intermezzo. I post this here because for some reason I there is no PM item in when I click on your username above a thread.

There is an important, but not easy to find feature on the forums.

Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

An example is here: Using CODE tags Around your paste.


After enabling probe foreign and rebooting I was not able to complete booting to the prior 15.0 environment. It wanted to do maintenance but I decided I was done messing with it.
After backing up what I needed to I deleted /sda2 (swap) and /sda3 (btrfs) related to 15.0 environment. I restarted but still see the menu entries related to 15.0 and the old kernel.
The good news is that 15.2 is still good and the only prompt I received was for my secondary Hitachi drive which has been mounted previously. I was able to set it within Partitioner to mount using UUID and allow mount by user. So this is fixed.
I checked YaST for “kernel-” and found that I only have the latest standard kernel installed.
I checked the /boot directory and found the following:

fuscop@linux-gwab:/boot> ls -a
.                                   initrd                                   sysctl.conf-5.3.18-lp152.33-default     vmlinuz-4.12.14-lp151.28.52-default
..                                  initrd-4.12.14-lp151.28.52-default       System.map-4.12.14-lp151.28.52-default  .vmlinuz-4.12.14-lp151.28.52-default.hmac
boot.readme                         initrd-5.3.18-lp152.33-default           System.map-5.3.18-lp152.33-default      vmlinuz-5.3.18-lp152.33-default
config-4.12.14-lp151.28.52-default  symvers-4.12.14-lp151.28.52-default.gz   vmlinux-4.12.14-lp151.28.52-default.gz  .vmlinuz-5.3.18-lp152.33-default.hmac
config-5.3.18-lp152.33-default      symvers-5.3.18-lp152.33-default.gz       vmlinux-5.3.18-lp152.33-default.gz
grub2                               sysctl.conf-4.12.14-lp151.28.52-default  vmlinuz

My question at this point is whether removing the seemingly orphaned files related to the old 4.12.14-lp151.28.52-default kernel version will get rid of references to the old kernel? Provided I run

grub2-mkconfig -o /boot/grub2/grub.cfg

Like I said, I’ve got things backed up at this point, and after thinking back through this I’m not going to be too unhappy if it is easier just to do a clean install. I could have already done that by now, but this has been pretty interesting to work through.:slight_smile:
This isn’t my only computer so it isn’t like I’m stranded either way.

Now that the 15.0 filesystems have been removed, the next grub2-mkconfig should automatically remove 15.0 boot selections. On next 15.2 kernel update or two, the purge-kernels service should automatically remove the 15.1 kernel. No action on your part need be taken now. If you’re in a rush to see them gone, you can use grub2-mkconfig or yast to purge the 15.0 selections from the grub menu, and zypper or yast to remove the 15.1 kernel, if one more boot first isn’t enough to trigger purge-kernels service already, which also should update the grub menu.

Thanks! Running the grub2-mkconfig cleaned up the menus and everything looks good with them now.
Once that was done I tested booting 15.2 with the older kernel and it was fine. Since there is no reason to remove those entries I will leave them alone. Think I’m set now and will acknowledge you all for the valuable assistance provided!