15.0 installation hang - how do I collect information to make a useful bug report?

I had seen positive comments about installing 42.3 on a Dell XPS15 (9560) portable so I picked one up. The installer came up fine but could not see the PCI-e flash drive. I then tried 15.0 Beta Build 234.2 which hung early as the green bars at the bottom scrolled to the right of the screen. Hitting the ESCAPE key says the “Starting hardware detection…” After some experimentation I switched from UEFI booting to BIOS based booting and whatever SATA emulation inside the Dell seemed to be acceptable to the 42.3 installer and I was able to complete an install. Unfortunately I tried loading Bumblebee later and that trashed some microcode file for the Wifi so the system would never get through boot.

I decided to restart with the 15.0 Beta Build 234.2 DVD again in BIOS mode but it hangs the same way it did before which implies a regression from the original 42.3 DVD installation image. Unfortunately I’m not finding good step by step instructions on collecting important information at this stage in the installer so I was hoping someone here might have some suggestions on what and how to gather data to make a useful bug report. I don’t “need” the machine for a bit so I can keep it free to run experiments.

Thanks for any help!


Wrong sub forum, will close temporarily and move to insta//boot/login.

Thread moved and reopened for consumption.

Add this to the end of the installer command line (Press e to edit the command line):


You will need to wait a little while, but not too long, just a minute or two. This is a self update for the installer itself. No worry, though, this is not to update the complete install package, just the installer portion.

If that does not get you going, you can try again by adding the above again, and then add this at the end of the line:


This will give you the ncurses version of the installer, not quite as fancy-looking for graphics, but otherwise operates much the same.

Unfortunately family issues have left me with little time. I’ve downloaded version 247.1 and tried both these options in both UEFI and BIOS modes with no change.

When started the machine has a DVD drive and no network access so I don’t see how any update not associated with the data on the DVD can happen. It’s dying in the hardware detection phase which appears to be in a text mode in all cases with three different pattern characters used to create three different brightness green progress bars at the bottom of the screen. Ultimately it stops before handing off to the installer. This time instead of saying “Starting hardware detection…” it says “Loading basic drivers…” when I hit the <ESCAPE> key. Before it gets to this green bar thing the last thing I see (in all forms of boot) is “Starting udev”. I’ve done the same with the original 42.3 DVD and it passes the green bar bit much faster and when “textmode=1” is used it does use the text mode installer instead of the graphical installer. 15.0 Beta 247.1 still has a regression against 42.3.

I don’t know what goes on in that passage where the green progress bars but this is where 15.0 Beta is dying so this is what needs to be instrumented.

As far as i can tell from the Dell website a Dell XPS 15 (9560) laptop can be equipped with either an Intel® Core™ i5-7300HQ or an Intel® Core™ i7-7700HQ processor. Both provide Intel® HD Graphics 630. In addition there is a NVIDIA® GeForce® GTX 1050 graphic card installed (looks to me like an Optimus setup).

To avoid UEFI-related problems it might be a good idea to check the Dell website for newer versions of your UEFI.

This sounds strange to me?!

My laptops configuration is similar to yours (Intel Core i7-7820HK CPU + Intel HD Graphics 630 + NVIDIA GeForce GTX 1060 graphics card) and i had problems similar to yours when installing openSUSE Leap 15.0 Beta (although i always use UEFI mode for booting).

The UEFI of my machine allows to choose between two setups of the graphic cards. One (a) is called “DISCRET” and disables the Intel HD Graphics 630 so that only the NVIDIA card will be used. The other (b) is called “MSHYBRID” which will keep both cards active.

When i use (a) i can install and run openSUSE Leap 15.0 Beta without problems (apart from the fact that the NVIDIA card drains the battery within one hour).

So if the UEFI of your laptop allows you to disable one of the two graphic cards you should give that a try.

If your machine does not allow to run with only one graphic card enabled then you could try this:

  • Boot the installation media
  • Edit the entry “Installation” of the GRUB2 boot menu by pressing “e”
  • Change the line “linuxefi /boot/x86_64/loader/linux splash=silent” to “linuxefi /boot/x86_64/loader/linux acpi_os_name=“Linux” nouveau.modeset=0 3”
  • Press F10 to continue booting

That helped me to get the installation going (while my UEFI graphic cards option was set to “MSHYBRID”, i.e. both cards active).



I tried your command line with the 15.0 Beta Build 247.1 in UEFI mode and everything worked great! I reran it with just the ‘nouveau_modeset=0’ as the graphical installer runs even when runlevel 3 is specified and to see if I didn’t need the ‘acpi_os_name’ and it also worked fine.

Unlike the 42.3 BIOS install which used the VESA video driver by default (imagine graphics drawn with a hammer and chisel) and downed a full battery charge in well under two hours the 15.0 Beta Build 247.1 seems to select the Intel 630 graphics driver and maintains the block on the nouveau driver so I didn’t have to add anything to the boot configuration on the installed system, and it reports over 5 hours of runtime. The 15.0 build also recognized the NVME device just fine. I closed the lid to make it sleep (apparently the default) and it lost only a few minutes of battery over more than 12 hours in sleep mode. I brought up a YouTube video where the WiFi (Enterprise mode,) audio and video were fine. This was the model with the i7-7770HQ, 16G RAM and 512G PCIe flash storage. If they didn’t raise the price by nearly 50% in the past couple weeks I’d strongly recommend it while it’s still available.

BTW, the boot ROM (not sure if it should be called a BIOS even though it still has one embedded) doesn’t offer an option to disable the nvidia device.

Thanks for your help!


In case it helps anyone, I had exactly the same problem on the 2018 Dell XPS 15 9570, trying to install 15.0. Adding nouveau.modeset=0 3 worked a treat and got me past the hardware detection phase of the installation process, only problem was it added it to the boot options in grub and it was booting into text only mode by default until I changed it to nouveau.modeset=0 5 in the YaST boot loader module.

nouveau.modeset=0 and 3 are two distinct and unrelated boot parameters. 3 on cmdline specifies desire to override whatever the default target happens to be and boot into text mode (multi-user). 5 on cmdline also overrides the default, designating graphical target startup. If graphical is your desire, then

systemctl get-default

should return


and the 5 should be removed from /etc/default/grub’s GRUB_CMDLINE_LINUX_DEFAULT=, and bootloader update performed so that /boot/grub2/grub.cfg contains neither 3 nor 5. 3 & 5 are intended to be used as option for a current boot, added while a Grub boot menu is active, not persisting.

Ah OK, thanks, that makes more sense now. Out of interest, is nouveau.modeset=0 the same as nomodeset?

This sounds like the exact same problem I have on a laptop from a completely different brand. I will post an update if this has solved my issues as well.
Thank you all for the valuable information.

No first stops the nouveau modesetting the second stops ALL modesetting drivers though the results may be similar depending on hardware and drivers available

@Susejunky and Fraser_Bell,

Between your two posts, I managed to get my laptop going.
Thank you both very much for sharing your knowledge with us!!

Now I can continue configuring my system in stead of getting frustrated about the installation procedure. :smiley:


Welcome. And, thanks for reporting back.