13.3 install freezes while loading drivers...

Hello All

Firstly I want to point out that im completely new to Suse and have limited experience with Linux so pleeease bear with me:dont-know:

I tried to install Suse 3.1 on my Sony Vaio netbook using a USB stick.
I made up the stick according to the instructions and it booted up perfectly. Then I started installing and along came the green loading bar which slowed down alot towards the end and then once it reached the end, nothing happened, even after waiting for a veerrrry long time. when i pressed esc. it just said loading drivers…

Has this happened to anyone else and or does any of you know how to fix or get around this?
Please help :slight_smile:


Does the machine have a floppy drive? If not check the BIOS and see if the BIOS thinks there is a floppy. If so turn it off there.

Other possible reason is a problem with video. So what video chip does the machine have?

Definately no floppy drive, physically or in BIOS.

as for video, it has a AMD Radeon HD3610 graphics card, Should be strong enough, but would there be a problem with drivers?

In your title you talk about 13.3. In your post you talk about 3.1
Can you please try to find out which version of openSUSE you have this problem with and post that here?

It is strong enough.

Are you installing on a EFI or older BIOS machine?

If BIOS you might try selecting F3 (if my memory is right) and no KMS option You will see at the bottom of screen

IF EFI (does not have the option at the bottom) I think you may have to edit the boot options directly

On 2014-04-06 20:06, yohanmidden wrote:
> Definately no floppy drive, physically or in BIOS.

Just in case, we mean this:

Disable floppy in BIOS

There is a bug in the installation that makes it delay for half an hour
or more if the bios has a floppy enabled, and there is no floppy drive
in the hardware.

Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Certain wireless devices apparently can cause a freeze as well.
So try to disabling those as well (either in the BIOS or via the hardware switch).

AFAIK installing kernel-firmware should cure that freeze, so you should be able to use the wireless later on after installing that package.

Thanks for all the replies :slight_smile:

Henk, thanks for pointing out my typing mistake, I guess 13.3 doesnt exist…

anyway the problem has been solved. I tried the no KMS option and then also waited for a 1/2 hour, then things started to finally happen :), thanks gogolthorp and robin_listas.

I guess my patience was also an issue. lol!

The BIOS is very basic on this notebook and the only devices “boot” or otherwise that it lists is “external drive”, “hard drive” and “network drive”.

Well anyway, now to find out how to use openSuse…

Thanks again


There should be a selection for a floppy drive. Not as a boot but as just hardware. It looks like you BIOS has set that there is a floppy but there is not one. You really should be able to set the BIOS straight on the matter.

This is a kernel bug that goes off looking for that non extant floppy after all the BIOS swears there is one.

Another possibility to disable the use of the (non-existent) floppy driver would be to add “brokenmodules=floppy” to the boot options, i.e. jaust type it at the installation medium’s boot menu.

This is a kernel bug that goes off looking for that non extant floppy after all the BIOS swears there is one.

It’s not only a kernel bug, but also sub-optimal behaviour in other software like blkid f.e.
The kernel side should be fixed in the meantime, the kernel on the 13.1 installation medium of course still has this problem (as the ISO’s have not changed), but it shouldn’t happen any more in 13.2 when it is released.