13.2 update and system conflicts

File /usr/share/man/man1/vncserver.1.gz
  from install of
     xorg-x11-Xvnc-1.3.1-6.14.1.x86_64(openSUSE-13.2-Update)
  conflicts with file from package
     tightvnc-1.3.10-14.2.1.x86_64(@System)

File /usr/share/vnc/classes/VncViewer.jar
  from install of
     xorg-x11-Xvnc-1.3.1-6.14.1.x86_64(openSUSE-13.2-Update)
  conflicts with file from package
     tightvnc-1.3.10-14.2.1.x86_64(@System)

File /usr/share/vnc/classes/index.vnc
  from install of
     xorg-x11-Xvnc-1.3.1-6.14.1.x86_64(openSUSE-13.2-Update)
  conflicts with file from package
     tightvnc-1.3.10-14.2.1.x86_64(@System)

File conflicts happen when two packages attempt to install files with the same name but different contents. If you continue, conflicting files will be replaced losing the previous content.
Continue? [yes/no] (no): yes


#  | Alias                     | Name                               | Enabled | Refresh
---+---------------------------+------------------------------------+---------+--------
 1 | Virtualization            | Virtualization (openSUSE_13.2)     | Yes     | Yes    
 2 | isv:ownCloud:desktop      | isv:ownCloud:desktop               | Yes     | Yes    
 3 | mozilla                   | mozilla                            | Yes     | Yes    
 4 | openSUSE:13.2             | openSUSE:13.2                      | Yes     | Yes    
 5 | repo-debug                | openSUSE-13.2-Debug                | Yes     | Yes    
 6 | repo-debug-update         | openSUSE-13.2-Update-Debug         | No      | Yes    
 7 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | No      | Yes    
 8 | repo-non-oss              | openSUSE-13.2-Non-Oss              | Yes     | Yes    
 9 | repo-oss                  | openSUSE-13.2-Oss                  | Yes     | Yes    
10 | repo-source               | openSUSE-13.2-Source               | Yes     | Yes    
11 | repo-update               | openSUSE-13.2-Update               | Yes     | Yes    
12 | repo-update-non-oss       | openSUSE-13.2-Update-Non-Oss       | Yes     | Yes

Im getting errors when updating my machine, seems to be a conflict of packages from update repo and system repo. Anyone else experiencing this?

Prior to 13.2, I think that conflict would not have been noticed and the file would have been clobbered. That check for conflicts seems to be a new check for 13.2.

I ran into that last summer when running factory. The files involved were unimportant, so I told it to continue.

In your case, the first file is a man page (i.e. documentation). It probably won’t cause you any serious problems. The third file (/some/path/index) is probably documentation and likely won’t cause a problem. The second file (the “.jar” file) might be the one to raise concerns.

If it were me, I would probably make a backup of that file, then let the file be clobbered and see what happens.

Ah so its a new feature of 13.2 i see.

Yes i shot from the hip and just wiped it. It looked related to vnc which i dont use so i really didnt think twice :confused:
ill keep an eye out for this again but wasnt sure if it was a known bug or issue. I have not installed any new repos that would mess with vnc so not sure why its doing that.

Cheers

IMO in this case over-writing should just be accepted.

Your warning clearly is just saying that packages from your Update Repo are replacing packages installed from your original source (likely DVD).

Speculating, but this scenario is a common one which is a result of openSUSE’s policy to backport patches to an existing version, which causes the contents to be different when packages are named the same.

TSU

Is this a package from openSUSE 13.1:

tightvnc-1.3.10-14.2.1.x86_64

I do not find a package for openSUSE 13.2