13.2 Thunderbird font rendering inconsistent with Gnome Shell settings

Hi everyone,

I’m really enjoying openSUSE 13.2 and the new Tumbleweed, but the perennial complaint of font rendering/subpixel hinting keeps rearing its head.

This time, it’s the font rendering of Mozilla apps, especially Thunderbird. Please notice the difference between the nice fonts in Nautilus and the rest of Gnome Shell, and the uglier fonts in Thunderbird:

http://s11.postimg.org/50eqq0msf/Screenshot_from_2014_11_05_22_16_50.jpg](http://postimg.org/image/50eqq0msf/)

Any ideas on what I can do to tweak this? I am aware of the Namtrac repo for Infinality font rendering, but I’d just like to know if it’s possible to get decent results with the stock system first.

Thanks for the help!

Hi
Have you tried Settings -> Tweak Tool -. Fonts and played with the Hinting and Antialiasing, I set mine to Full and Rgba. You might need to restart the shell, Atlt+F2 r <enter>

Hi, thanks for the reply. I do like the regular GTK app font rendering, which I have set to “Slight” RGBA. But Thunderbird seems to be using Medium or Full, which I don’t like.

Have you gone into Preferences | Display | Formatting tab in Thunderbird and played with Font settings?

Also thanks for the reply. Yes, I looked around there too. The fonts are set to the same style (DejaVu Sans), but there are no subpixel hinting settings in TB.

                 Try Valmar's Muzlocker font rendering repo for openSUSE 13.1:

http://download.opensuse.org/reposit…openSUSE_13.1/

Valmar has not yet published a 13.2 repo but I bet that the 13.1 repo will work with OpenSUSE 13.2. This repo dramatically improves the font rendering with Mozilla products. You will need to either reboot or log out/in after you install the repo.

FYI,

Gordon

Thanks Gordon, I actually prefer the Namtrac repo, but I was just wondering if there’s a way to make this work with the default font libs first.