13.2 RC1 x64 Hanging During Boot: ATA Errors

I’m getting these strange ATA errors during boot with 13.2 x64 RC1. They happened with 13.1 x64 on my machine but passed by rapidly. Now, the system hangs for about 60 seconds when all these errors come up. I filed a bug and nobody has responded yet, but I wanted to see if anybody else is getting this or could tell me why this is happening?

The bug is here: http://bugzilla.opensuse.org/show_bug.cgi?id=900661

No, I’m not seeing this.

I would wonder whether your problem is due to a failing disk, a failing SATA controller, or overclocking.

I don’t think it’s the hard drive because it passes SMART, is a relatively new drive, and other people have had this same issue in the past:



Also, it’s interesting how I get these errors with 13.1 and they scroll by very quickly, yet with 13.2 RC1 it hangs. I’ll run a SMART test now, but i’m betting against that it’s my hard drive or SATA controller. Also, the system is not overclocked.

I ran a “smartctl --test=long /dev/sda” and it came up with no errors. There are no bad sectors either. I tried swapping out the SATA cable and plugged it into a different (Z68 controlled) port on the motherboard, and the problem still occurred. The SATA port the drive is plugged into is being controlled by the Intel Z68 chipset on my board. There are two other ports on the board which are controlled by a Marvell 9128 chipset, and I tried one of those. I get the same problem. So I’m really at a loss, unless there’s some problem with NCQ by being on and causing the errors.

Bad cable??? Just a thought and can happen

Did some more troubleshooting, and found out that if either my DVD burner or HD is plugged into this one specific SATA port the errors happen during boot. I also tried a brand new SATA cable in said port with my DVD burner and got the same issue. So, I guess I have a bad SATA port. :open_mouth:

Thanks for tracking that down. And I note that you have added this information to your bug report.

I did some more testing and found that the ATA errors I described go away if “SATA Hot Plug” (1-6; one port per line in BIOS) and “External SATA 6GB/s Controller Mode” are both disabled in the UEFI BIOS. If both of these options are enabled or one or the other is enabled, the errors appear. I haven’t yet tested to see if enabling each SATA hot plug option (port-by-port, and only having one enabled at a time) does or doesn’t cause the errors.

I was thinking of installing 13.1 x64 with the 3.11 kernel to see if the errors come up. So, maybe I don’t have a bad SATA port or maybe I do. I realized that even after switching the HD to a different SATA port I still get the errors. This is probably because I cleared the CMOS and did a BIOS update today in hopes of it maybe being a BIOS-related issue. I may have disabled all the options I talked about above before the update which is why I may have been under the impression that switching ports fixed the problem, but I forget exactly how I had it set. And maybe switching the port did prevent the errors from coming up and both of those options were disabled, yet there’s some intermittent issue with the SATA controller. Does anybody have the “SATA Hot Plug” and/or “External SATA Controller Mode” option(s) in their BIOS, and can maybe run a test to see what happens when you enable these?