[13.2/KDE] plasmoid opens DVD with vlc instead of file manager

there is this plasmoid (device <something>, I don’t know the english name) in the KDE panel that pops up when eg. a USB stick is attached or a DVD is inserted, and asks which of several proposed actions should be performed.
one of such actions is to open the USB stick (or DVD) with a file manager.
If I select the file manager then vlc is starting up!! instead of the file manager.

how can I repair that to use dolphin instead of vlc?

Maybe “Configure Desktop”->Default Applications->Filemanager, or have a look in “File Associations” as well. The file type that affects this is “inode/directory” I think, move dolphin to the top of the list of applications there.

Probably easiest is to
Open Dolphin
Browse to the specified file in question
Rt-click on the file and select “Properties”
Follow the instructions to set the file type to open using Dolphin instead.

Note that some file types can be used for multiple purposes, so you’ll have an ongoing issue regardless what default app you choose to open a file.


maybe may problem was misunderstood.
there are no problems when opening anything from within the file manager / dolphin.
the problem only occurs with the plasmoid.
file associations, therefore, seem to me correct and need not to be changed.

I thought about modfying system settings -> device actions
but I don’t know how to properly modify it.

This usually means that the device you plug in has or once had media on it.

this is controlled in KDE at System settings (configure desktop) -> Device Actions. There you will find the rules of what opens when the system sees this or that.

“Open with Filemanager” actually opens it with the default application (which normally is the filemanager).
So I still think the file associations are wrong, for “inode/directory” in particular as mentioned.

Dolphin itself ignores the settings for that filetype, it just opens directories directly. So that’s why it’s working there.

I thought about modfying system settings -> device actions
but I don’t know how to properly modify it.

That shouldn’t be necessary, unless you modified them yourself in the first place.

thank you for the explanation.
vlc was the default application under inode/directory.
changing the order solved it