13.2 Installs but will not boot

I am using a 13.2 DVD that I used to install for this computer where I am writing this. So we know that the DVD is good. Actually it has been used for two other systems.

About a week ago, my wife’s desktop crashed. The end result was me getting a new mobo/CPU and two 1 TB HDDs. I can get all of it up and running, if I boot from the CD/DVD. I can boot and install Fedora 21. I can boot and install SUSE 12.1. I can boot and install SUSE 13.2. But in all cases, boot from the hard drive fails. All I get is a flashing cursor.

It seems that there is a problem with getting a /boot partition that the BIOS will communicate with. What I have is an ASUS M5A78L-M USB3 board and an AMD FX4300.

I have been searching using Google and within this group. I know that there is something I need to do about the new BIOS features (I can’t remember the abbreviation its something like IEFU) that has insufficient memory and works great for Windows. All I know is, during the last SUSE 13.2 install that I tried it failed during the install with an error -15005 (I think it is because I was having /boot be part of the “/” partition).

I have tried all kinds of partitioning schemes. And with a live CD/DVD I can mount the hard drive(s) and look at their contents.

Does anyone have an idea about what I need to do to get a valid /boot partition built? Nothing I’ve tried works.

Regards,
Steve.T

At this stage, it is hard to guess.

Does your computer use UEFI firmware? Did you install for UEFI?

(I can’t remember the abbreviation its something like IEFU)

That was probably UEFI. Booting with UEFI is different.

Sounds like UEFI this is the new BIOS (ok it really is not but you can think of it as a BIOS it serves the same purpose)

First off you seem very confused

here is the details you will have to decide what to do

Since it has an EFI BIOS you can boot two different ways.

  1. traditional MBR boot (in EFI speak it is called legacy) This is where MBR code is used to boot the rest of the system
  2. EFI boot. This is a more modern approch and is radically different from the old MBR boot method. In this case the EFI looks for a special partition called an EFI boot partition which uses a FAT (old DOS) file system. In this partition you will have a directory for each OS you install in EFI mode. openSUSE if you boot the install media in EFI mode (an option on the screen at the BOOT often but not always F12 to select) the the installer should do things right for an EFI boot. This would be 3 Linux partitions swap/root and home + a EFI boot partition mounted as /boot/efi (note the name not /boot) You can as an option, but generally don’t need to, create a fourth Linux partition that will mount as /boot (it should be a Linux format and be about 500 meg). Unless you are doing special things you really don’t need a separate boot but you do need to create or mount an existing EFI boot(formatted as FAT) as /boot/efi if you are going for an EFI boot. But that should be automatic if you booted the media in EFI mode.

We don’t know how you Installed RedHat in MBR or EFI mode. You should never mix modes it is better to have all OS booting in the same mode if you multi boot

First, do you know how you installed? MBR or UEFI? Is the setting in the BIOS set for Secure Boot or not?

Also, where did you install GRUB to? MBR? or a special BOOT partition? or ROOT partition?

Wherever you installed GRUB to, make certain that the BOOT flag is set there.

Often, with the flashing cursor stop as you describe, it seems most simply do not have the BOOT flag set to where GRUB is installed.

You don’t seem to be running windows, If that is the case try this.

Go to what you refer to as the BIOS (use a key combination at boot)

Disable “secure boot” if it is there.

Look for and use an option that offers “legacy” , “MBR” , “BIOS” or similar as opposed to an option of UEFI .

Reinstall your chosen Linux.

This is just one option, it may not suit you, I have used it and for me it has worked well + it’s easy and simple to explain!

Also look for ‘Compatibility mode’ which is another name for BIOS booting.

Ok, let me clarify a few things:

I work on z/frames for a living. IEF is a prefix used within the z/OS operating system. It is easy to get it confused with UEFI. I also work on Linux for z (SLES-11 SP2 to be specific), and z/VM (which is where we run SLES-11 guests).

Next, I know that this MOBO that I’m working on has a BIOS that does not 100% match the book that came with it. I have not found by the book or going panel by panel through the Setup displays most of the things stated.

All the mentioned installs have to do with me trying to diagnose the SUSE 13.2 install. It is possible to have a bad MOBO out of the box. I’ve had that problem before and spent 30 hours trying to figure it out before I took it back and got another board. I don’t have time for this – this crash was not scheduled, it has completely hosed my schedule. I’m supposed to be testing some hardware with some specific software right now – which is outside of my paying job.

Back to the problem at hand: I finally found where one is to tell SUSE 13.2 (64Bit) about a UEFI based system. It does not like my partitioning scheme. It either works or it don’t. I have given the “/” partition 150 GiB of space (works out to be about 149GB) followed by a 4GB swap with a priority of 0. The other 1T HDD (PATA) has a 4GB swap on it with a priority of 5. (Future plans, 16GB SDD for swap with priority of 10).

All I need is to figure out is how to get a working install. I can reconfigure as needed from there (BTDT many times). I just need to figure out how to make it work. And the latest test just now failed with the same flashing cursor.

Until next weekend…

ok but you did not mention the efi boot partition. If you plan to use EFI mode then you must have a small (under 100 meg ) FAT formatted partition

Assumimg the drives are clean and empty and you are not multi booting

boot the Install in EFI mode. You may need to tell the BIOS (UEFI) to boot the installer in that mode. At BIOS boot screen it is normally F12 but that can be different so there should be an indication on the screen or in the manual. Do not select legacy boot unless you plan on iinstalling in legacy mode.

With openSUSE there is by default and highly recommended a separate home partition. In is not strictly needed BUT all user personal settings are there so it makes things much easier if upgrading or even installing a different Linux. You just don’t format the home partition and mount it as home.

If you have booted into EFI mode you will just have a menu if in MBR (legacy) mode you will have some options at the bottom.

In EFI mode the efi boot partition should be marked as FAT and mounted at /boot/efi. The boot code should be grub2-efi. If you have secure boot on it is not auto detected so you must check the secure boot box. Note it does not hurt to check it if secure boot is off.

If installing in the traditional MBR mode and not dual booting with Windows. I put grub2 in MBR and the boot partition.

You can set the partitions pretty much like you want but the default will be a root forammted BTRFS and a swap and a home formatted XFS. You must have a root and should have a swap home is optional but as stated highly recommended. For most Desktop usage BTRFS with 40 gig is plenty. Or ext4 with 20 gig. swap should be 1 to 2 X memory but a max of about 8 gig unless you have loads of memory and plane to hibernate in which case the swap should be a bit more then memory You may want more root space if you planing on using huge databases. But in that case recommend a partition just for those DBs’

If none of the above works then I’d look at the hardware. check the memory, run smartctrl on the drives to check them, see if there is a BIOS update etc

Also be sure the down load is good by the check sums and if installing from DVD run the media check to be sure you have a good burn

Okay, but is that a UEFI install or a non-UEFI install?

The installer can be booted either into UEFI mode or MBR legacy mode. You have to set that at the BIOS, and some BIOS might not be very flexible.

For a UEFI install, the installer will want to use GPT partitioning and will want an EFI partition mounted at “/boot/efi”.

For a legacy MBR install, the installer can use either GPT partitioning or MBR legacy partitioning and it will not need “/boot/efi”.

If you want a legacy MBR install, but you booted the installer into UEFI mode, it will be confusing though it is possible (I’ve tested that). But, in that case, better to partition separately, before you boot the installer, then tell the installer to use existing partitions.

Back from biz trip.

Bottom line is, the system booted this time when it asked to reboot. :cool:

So, I think this is now a UEFI install using the 50MB FAT partition. The BIOS F8 (boot menu) was worthless in this case. Everything had to be done in the install. I had to customize the partitions (“expert” option), and then in the boot area (when the summary(?) window came up, tell it what to do there.

Thanks for all the tips. This was not a straight forward install. And the AMI bios and mobo install booklet just did not discuss anything or give any options.